Poznámka
Přístup k této stránce vyžaduje autorizaci. Můžete se zkusit přihlásit nebo změnit adresáře.
Přístup k této stránce vyžaduje autorizaci. Můžete zkusit změnit adresáře.
Původní číslo KB: 2966790
Příznaky
Uživatel, který nemá delegáta poštovní schránky, narazí na jeden nebo oba následující problémy v Microsoft Outlooku:
Když se uživateli odešle žádost o schůzku, v kalendáři uživatele se schůzka správně zobrazí jako nezávazná, ale Outlook žádost nepřesměruje do složky Doručená pošta. Požadavek se například zobrazí ve složce Odstraněná pošta.
Když účastník odpoví na žádost o schůzku, kterou uživatel vytvoří, informace o sledování schůzek v kalendáři uživatele správně odrážejí odpověď, ale Outlook nepřesměruje odpověď do složky Doručená pošta. Například odpověď se zobrazí ve složce Odstraněná pošta.
Příčina
K problémům může dojít z následujících důvodů.
Příčina 1
Složka MAPI Receive, která obsahuje příchozí zprávy pro IPM. NAPLÁNOVAT. Třída zprávy MEETING není nastavená na složku Doručená pošta. Místo toho se položky schůzky zobrazí ve složce Odstraněná pošta.
K otestování této příčiny můžete použít Exchange Online PowerShell . Použijte některou z následujících metod.
Poznámka:
Obě metody poskytují užitečné informace. Například metoda A ukazuje, kolik položek schůzky bylo nesprávně směrováno do složky Odstraněná pošta, a metoda B potvrdí, do které složky byla konkrétní položka doručena.
Metoda A
Spusťte následující rutinu PowerShellu Get-MailboxFolderStatistics :
Get-MailboxFolderStatistics -Identity <user ID> -FolderScope NonIpmRoot -IncludeOldestAndNewestItems | ? Name -eq "Schedule" | FL Name,FolderType,NewestItemReceivedDate,ItemsInFolder
Následující snímek obrazovky ukazuje příklad výstupu rutiny.
V této příčině je hodnota count ItemsInFolder nenulová a hodnota časového razítka NejnovějšíItemReceivedDate odpovídá datu a času poslední chybně určené položky schůzky.
Metoda B
Spusťte následující rutiny PowerShellu Get-MessageTrace a Get-MessageTraceDetail :
Get-MessageTrace -StartDate <search start date> -EndDate <search end date> | ? Subject -match <item subject> | Get-MessageTraceDetail
Následující snímek obrazovky ukazuje příklad výstupu příkazu.
V této příčině je hodnota parametru Detail pro událost doručení: The message was successfully delivered to the folder: DefaultFolderType:LegacySchedule
.
Příčina 2
Pro zprávy, které mají IPM. Rule.Version2.Message message třída, hodnota PR_RULE_MSG_PROVIDER vlastnost je nesprávně nastavena na Schedule+ EMS Interface
.
Řešení
Pokud jste testovali příčinu 1 v Exchange Online PowerShellu a zjistili jste, že příčina 1 není použitelná, začněte v řešení příčiny 2. V opačném případě začněte řešením pro příčinu 1.
Řešení příčiny 1
Poznámka:
Pokud chcete použít následující postup, musíte být uživatelem nebo mít úplná přístupová oprávnění k poštovní schránce uživatele. Spusťte postup na počítači se systémem Microsoft Windows, na který je nainstalovaný desktopový klient Outlooku, a profil aplikace Outlook pro poštovní schránku.
V Outlooku vyberte Souborový>účet>Office o Outlooku a určete, jestli je desktopový klient 32bitovou nebo 64bitovou verzí.
Stáhněte a extrahujte nejnovější verzi KNIHOVNY MFCMAPI, a to buď 32bitovou, nebo 64bitovou, aby odpovídala instalaci Aplikace Outlook.
Důležité
I když je editor MFCMAPI podporovaný, při úpravě nastavení poštovní schránky buďte opatrní. Nesprávné použití editoru MFCMAPI může trvale poškodit poštovní schránku.
Zavřete Outlook a spusťte MFCMapi.exe. Pokud se zobrazí úvodní obrazovka MFCMAPI, zavřete ji.
Výběrem možnosti nástroje>otevřete okno Možnosti.
Pokud chcete nastavit MFCMAPI na online režim, vyberte obě následující možnosti a pak vyberte OK:
- Při volání OpenMsgStore použijte příznak MDB_ONLINE
- Při volání OpenEntry použijte příznak MAPI_NO_CACHE
Důležité
Ujistěte se, že jste dokončili krok 5.
Výběrem možnosti Přihlášení k relaci>otevřete okno Zvolit profil.
Vyberte profil aplikace Outlook pro ovlivněného uživatele a pak vyberte OK.
Poklikáním otevřete příslušnou poštovní schránku ve sloupci Zobrazovaný název .
V novém okně, které se zobrazí, vyberte MDB>Display Receive>folder table.
V okně Tabulka složek příjmu ověřte, že sloupec Třída zprávy má IPM. NAPLÁNOVAT. Položka schůzky. Následující příklad snímku obrazovky ukazuje danou položku.
Pokud okno Tabulka složek příjmu neobsahuje IPM. NAPLÁNOVAT. Položka SCHŮZKY, pečlivě zkontrolujte, že jste dokončili krok 5 (nastaví MFCMAPI na online režim). Pokud jste dokončili krok 5, přeskočte zbývající kroky a místo toho zkuste řešení příčiny 2 , pokud jste to ještě neudělali.
Rozbalte kořenový kontejner.
Klepněte pravým tlačítkem myši na Plán a potom vyberte Advanced>Set receive folder to open the SetReceiveFolder window.
Zadejte IPM. NAPLÁNOVAT. SCHŮZKA v poli Předmět , vyberte Odstranit přidružení a pak vyberte OK.
Aktualizujte okno Tabulka složek příjmu a pak ověřte, že IPM. NAPLÁNOVAT. Položka SCHŮZKY již neexistuje.
Zkontrolujte, jestli je problém pro uživatele vyřešený. Pokud problém přetrvává, zkuste problém vyřešit příčinu 2 , pokud jste to ještě neudělali.
Řešení příčiny 2
Proveďte kroky 1 až 8 v řešení příčiny 1 k inicializaci MFCMAPI.
Rozbalte kořenový kontejner a potom rozbalte horní část úložiště informací.
Pravým tlačítkem myši klikněte na Doručená pošta a pak vyberte Otevřít přidruženou tabulku obsahu.
V horním podokně vyberte záhlaví sloupce Třída zpráv a seřaďte sloupec.
Pro každou zprávu ve sloupci Třída zprávy, která má hodnotu
IPM.Rule.Version2.Message
:Vyberte zprávu.
V dolním podokně zkontrolujte hodnotu vlastnosti PR_RULE_MSG_PROVIDER .
Pokud je
Schedule+ EMS Interface
hodnota vlastnosti PR_RULE_MSG_PROVIDER , odstraňte zprávu v horním podokně.
Následující příklad snímku obrazovky ukazuje, jak odstranit zprávu, která má třídu
IPM.Rule.Version2.Message
zprávy a PR_RULE_MSG_PROVIDER hodnotuSchedule+ EMS Interface
vlastnosti .Zkontrolujte, jestli je problém pro uživatele vyřešený. Pokud problém přetrvává, zkuste problém vyřešit příčinu 1 , pokud jste to ještě neudělali.