K Skype pro firmy Online se nemůžete přihlásit, protože certifikát nejde získat ani ověřit.

Problém

Když se uživatel Microsoftu 365 pokusí přihlásit k Skype pro firmy Online (dříve Lync Online) pomocí Lyncu 2010 nebo Lyncu 2013, zobrazí se uživateli následující chybová zpráva:

There was a problem acquiring a personal certificate required to sign in. If the problem continues, please contact your support team.

Navíc při pokusu o přihlášení k Lyncu po výpadku sítě nebo výpadku služby Skype pro firmy Online se zobrazí následující chybová zpráva:

Cannot sign into Lync. There was a problem verifying the certificate from the server.

Příčina

K tomuto problému může dojít, pokud platí jedna nebo více z následujících podmínek:

  • Software je zastaralý.

    • Klient Lyncu je zastaralý.
    • Pomocník pro Sign-In služeb Microsoft Online Services je zastaralý.
  • Certifikáty nelze získat ani ověřit.

    • Osobní certifikát Skype pro firmy Online nebo přihlašovací údaje uložené v mezipaměti jsou poškozené nebo zastaralé.
    • Část řetězu certifikátů je nedůvěryhodná a řetěz certifikátů selže při ověřování.

Řešení

Řešení pro Lync 2013

Odstranění přihlašovacích údajů

Během procesu přihlášení Lync 2013 ukládá vaše přihlašovací údaje a další informace o připojení k Skype pro firmy Online do mezipaměti. Pokud máte potíže s přihlášením k Skype pro firmy Online, klikněte na Odstranit moje přihlašovací údaje a Lync 2013 automaticky odebere všechna uložená hesla, certifikáty a nastavení připojení pro uživatelský účet.

Snímek obrazovky znázorňující přihlašovací stránku Lyncu 2013 s vybranou možností Odstranit moje přihlašovací údaje

Řešení pro Lync 2010

  1. Aktualizujte klienta Lyncu na nejnovější verzi, která je k dispozici na stránce Stažené soubory na portálu Microsoft 365.

  2. Pomocí následujícího postupu se ujistěte, že je pomocník pro přihlášení ke službám Microsoft Online Services spuštěný ve službách Windows:
    (Tyto kroky platí pro Windows 10)

    1. Klikněte pravým tlačítkem na tlačítko Start a vyberte Spustit.
    2. Zadejte services.msc a vyberte OK.
    3. V okně Služby zkontrolujte, jestli je stavPomocníka pro přihlášení ke službám Microsoft Online Services uvedený jako Spuštěný.
  3. Vymažte certifikáty, přihlašovací údaje a připojení uložené v mezipaměti.

Další kroky pro řešení potíží s Lyncem 2013 a Lyncem 2010

Poznámka

Dodržujte prosím pečlivě postup uvedený v této části. V případě nesprávné úpravy registru by mohly nastat závažné problémy. Před zahájením úprav vytvořte zálohu registru pro případ, že by nastaly potíže.

Pokud kroky uvedené výše v tomto článku problém nevyřeší, vyzkoušejte následující metody, které odpovídají vaší situaci:

  • Když se Lync připojí ke konkrétnímu front-end serveru, uloží tento koncový bod do mezipaměti, aby se proces přihlášení v budoucnu urychlil. Někdy se ale může koncový bod změnit a může způsobit selhání přihlášení. Pokud chcete odstranit mezipaměť koncových bodů, postupujte takto:

    1. Vyhledejte složku s daty místní aplikace:
      • Windows Vista, Windows 7 a Windows 8 (kromě Windows 8 RT):

        %LOCALAPPDATA%\Microsoft\Communicator<sip_address@contoso.com>\

    • Windows XP:

      %USERPROFILE%\Local Settings\Application Data\Microsoft\Communicator<sip_address@contoso.com>\

    1. Odstraňte složku přidruženou k vaší přihlašovací adrese.
    2. Restartujte Lync a zkuste se přihlásit k Skype pro firmy Online.
  • Pokud používáte Lync 2010, odstraňte osobní certifikát Skype pro firmy Online a pak si stáhněte nový. Mějte na paměti, že když uživatel klikne na Uložit heslo v Lyncu 2010, tato akce také uloží certifikát ve Správci certifikátů systému Windows.

    Pokud chcete odstranit osobní certifikát, postupujte takto:

    1. Odstraňte certifikát ve Správci certifikátů systému Windows. Postupujte takto:
      1. Otevřete Správce certifikátů systému Windows. Uděláte to tak, že stisknete Windows + R, zadáte certmgr.msc a pak kliknete na OK.
      2. Rozbalte položku Osobní a potom rozbalte položku Certifikáty.
      3. Seřaďte je podle sloupce Vystaveno a vyhledejte certifikát vydaný komunikačním serverem.
      4. Ověřte, že certifikát existuje a jestli nevypršela jeho platnost.
      5. Odstraňte certifikát a zkuste se přihlásit k Skype pro firmy Online. Pokud se nemůžete přihlásit k Skype pro firmy Online, přejděte ke kroku 2.
    2. Pokud používáte Windows 7, odeberte přihlašovací údaje uživatele uložené ve Správci přihlašovacích údajů systému Windows. Postupujte takto:
      1. Otevřete Ovládací panely a klikněte na Správce přihlašovacích údajů.

      2. Vyhledejte sadu přihlašovacích údajů, které se používají pro připojení k Skype pro firmy Online.

      3. Rozbalte sadu přihlašovacích údajů a pak vyberte Odebrat z trezoru.

      4. Zkuste se znovu přihlásit k Skype pro firmy Online a zadejte novou sadu přihlašovacích údajů.

        Poznámka

        Tyto kroky nejsou v Lyncu 2013 nutné, protože dříve uvedené kroky odstranění přihlašovacích údajů certifikáty automaticky odeberou.

  • Vyprázdnění mezipaměti DNS Postupujte takto:

    1. Stiskněte Windows + R, zadejte následující příkaz a stiskněte Enter:

      Ipconfig /flushdns

  • Upozornění: K vážným problémům může dojít, pokud nesprávně upravíte registr pomocí Editoru registru nebo jinou metodou. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

    Na ovlivněných počítačích zkontrolujte následující klíč registru:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\MachineGuid

    Pokud hodnota MachineGuid obsahuje závorky kolem identifikátoru GUID (například {c1cbd94c-0d35-414c-89ef-dd092b984883}), odeberte závorky, restartujte Lync a zkuste se přihlásit znovu.

Řešení pro správce Skype pro firmy Online: Ověření řetězu certifikátů

Koncovým uživatelům se může zobrazit chyba s oznámením, že certifikát nejde ověřit, a k tomu obvykle dochází, protože jeden z certifikátů v řetězci je nedůvěryhodný a nejde ho ověřit. K tomu obvykle dochází u zákazníků, kteří používají jednotné přihlašování v Microsoftu 365 nebo pro zákazníky, kteří mají hybridní nasazení Lyncu.

Další informace o ověřování certifikátů v Lyncu najdete v tématu Uživatelé Lyncu Mobile se nemůžou přihlásit po aktualizaci na klienta verze 5.4.

Poznámka

I když je tento článek napsaný pro mobilní zařízení, stejné koncepty platí pro klienty Lyncu.

Další informace

Pokud problém přetrvává i po provedení těchto kroků pro řešení potíží, obraťte se na technickou podporu Microsoftu 365 nebo na fóra komunity Microsoftu 365. V některých případech může být uživatelský účet Active Directory Domain Services neúplný nebo poškozený. Proto Skype pro firmy Online nemůže vygenerovat osobní certifikát. To nemusí mít vliv na všechny účty tenanta, protože účinek závisí na stavu serveru při vytvoření uživatelského účtu.

Pokud chcete tento problém zúžit, zjistěte, jestli k problému dochází u více uživatelských účtů na stejném počítači. Pak se zkuste přihlásit k Skype pro firmy Online ze stejného počítače pomocí několika uživatelských účtů. Tento proces označuje, jestli problém souvisí s konfigurací počítače, nebo problém s uživatelským účtem Skype pro firmy Online.

Byly potíže vyřešeny?

  • Ověřte, zda jsou potíže vyřešeny.
  • Uvítali bychom vaši zpětnou vazbu. Pokud nám chcete poskytnout zpětnou vazbu nebo nahlásit případné problémy s tímto řešením, pošlete nám e-mailovou zprávu.

Stále potřebujete pomoc? Přejděte na web Microsoft Community.