Poznámka:
Přístup k této stránce vyžaduje autorizaci. Můžete se zkusit přihlásit nebo změnit adresáře.
Přístup k této stránce vyžaduje autorizaci. Můžete zkusit změnit adresáře.
platí pro:SQL Server
Dotazujte sys.dm_hadr_automatic_seeding na primární repliku, abyste zkontrolovali stav automatického procesu seedování pro dostupnou skupinu. Zobrazení vrátí jeden řádek pro každý počáteční proces.
| Název sloupce | Datový typ | Description |
|---|---|---|
| start_time | datetime | Čas zahájení operace. |
| completion_time | datetime | Čas dokončení operace (NULL, pokud probíhá). |
| ag_id | uniqueidentifier | Unikátní ID pro každou skupinu dostupnosti. |
| ag_db_id | uniqueidentifier | Unikátní ID pro každou databázi ve skupině Dostupné. |
| ag_remote_replica_id | uniqueidentifier | Unikátní ID pro druhou repliku, kterou tato operace seedingu zahrnuje. |
| operation_id | uniqueidentifier | Jedinečný identifikátor této operace seedingu. |
| is_source | bit | Označuje, zda je tato replika zdrojem (primárním) operace osazování. |
| current_state | bit | Současný stav seedingu, ve kterém se operace nachází. |
| performed_seeding | bit | Streamování databáze pro seedování je inicializováno. |
| failure_state | int | Důvod selhání operace je vyjádřen jako celé číslo. Pokud je failure_state tříciferné celé číslo, hodnota 1 v číslici se sto místy označuje, že chyba nastala na zdroji seedingu. Hodnota 2 v číslici sta míst znamená, že došlo k chybě na cíli nasazení. Hodnoty pro failure_state zahrnují následující. Můžete také použít sloupec failure_state_desc k interpretaci těchto hodnot. 0 = vnitřní chyba 1 = Zrušení uživatelem 2 = SQL chyba 3 = Žádost zamítnuta 4 = Přerušení vlákna 5 = Primární selhání 6 = Doprava 7 = Transportní replika 8 = Zkontrolovat, zda je potřeba nasadit 9 = Odeslat informace o databázovém souboru 10 = Vytvořit zpětnou volbu 11 = Operace vytvoření 12 = Vytvořit VDI klienta 13 = Open VDI Client 14 = Vytvořit USC Session 15 = Nasazení 16 = Obnovit tvorbu řetězce 17 = Vyhledávání ID v databázi 18 = Vytvořit asynchronní úkol 19 = Vytvořit úkol s časovým limitem 20 = Asynchronní selhání úkolu 21 = Kontrola nasazení, časový čas 22 = Časový limit zprávy souboru 23 = Databáze s názvem již existuje 24 = Sekundární timeout na dohnání 25 = Sekundární obnovovací streamový připravený časový limit |
| failure_state_desc | ncharvar | Popis příčin neúspěchu operace. Mezi možné hodnoty patří: Vnitřní chyba Zrušení uživatelem SQL chyba Žádost byla zamítnuta. Přerušení nitě Primární selhání Transport Transportní replika Zkontrolujte, zda je potřeba setí Odeslat informace o databázovém souboru Create Callback Operace vytvoření Vytvořit VDI klienta Open VDI klient Vytvořit USC Session Setí Obnovení tvorby řetězců Vyhledávání ID v databázi Vytvořit asynchronní úkol Úkol vytvořit časový limit Selhání asynchronního úkolu Timeout zprávy o kontrole nasazení Časový limit zprávy souboru Databáze s názvem již existuje Sekundární timeout na dohnání Sekundární obnovovací stream – časový limit |
| error_code | int | Jakýkoli SQL chybový kód nalezený při seedování. |
| number_of_attempts | int | Počet pokusů o tuto nasazení byla provedena. |
Povolení
Vyžaduje VIEW oprávnění SERVER STATE na serveru.
Oprávnění pro SQL Server 2022 a novější
Vyžaduje VIEW oprávnění SERVER PERFORMANCE STATE na serveru.