Informace o službě WinINet

Important

Kdy použít WinINet – WinINet je správnou volbou pro desktopové klientské aplikace , které potřebují sdílet nastavení proxy serveru Internet Options uživatele, soubor cookie jar a mezipaměť přihlašovacích údajů. Poskytuje automatické výzvy k zadání přihlašovacích údajů a integruje se s Internet Explorer zónami zabezpečení.

Nepoužívejte WinINet pro:

  • Windows služby nebo kód na straně serveru – místo toho použijte WinHTTP (podporuje zosobnění a izolaci relací).
  • Moderní aplikace pro UPW/WinUI – používají Windows. Web.Http (C++/WinRT) nebo System.Net. Http.HttpClient (.NET)
  • Multiplatformní aplikace – používají přenosnou knihovnu, jako je libcurl

WinINet není podporován ve službách a při volání z kontextu služby selže nebo se bude chovat neočekávaně. Podrobné porovnání funkcí najdete v tématu WinINet vs. WinHTTP .

Poznámka

Od Windows 10, verze 1709, jsou pro kontejnery aplikací HTTP/2 (viz RFC7540) ve výchozím nastavení zapnuté.

Programovací rozhraní aplikace Windows Internet (WinINet) umožňuje vaší aplikaci komunikovat s protokoly FTP a HTTP pro přístup k internetovým prostředkům. S vývojem standardů tyto funkce zpracovávají změny v podkladových protokolech a umožňují jim udržovat konzistentní chování.

Windows XP a Windows Server 2003 R2 a starších verzích: Také umožňují aplikacím pracovat s Gopherem.

Další informace najdete tady:

Internetové protokoly

Dva primární internetové protokoly jsou FTP a HTTP. Další informace o těchto protokolech najdete v dokumentech RFC (Request For Comments) pro FTP a HTTP:

  • RFC 959, FTP (Protokol přenosu souborů).
  • RFC 1945, Protokol pro přenos hypertextu – HTTP/1.0.
  • RFC 2616, Hypertext Transfer Protocol – HTTP/1.1.

Poznámka

(Tyto zdroje nemusí být dostupné v některých jazycích a zemích.)

Windows XP a Windows Server 2003 R2 a starší: Byl podporován také protokol Gopher. Viz RFC 1436, Internet Gopher Protocol.