401 Nicht autorisierte Ausnahme tritt in Microsoft Dynamics 365 bei Verwendung der Server-Side-Synchronisierung auf

Dieser Artikel bietet eine Lösung für einen Fehler, der auftritt, wenn Sie Server-Side Synchronization in Dynamics 365 verwenden.

Gilt für: Microsoft Dynamics 365
Ursprüngliche KB-Nummer: 3212785

Wichtig

Wenn Sie Exchange Online verwenden und dieser Fehler nach dem 1. Oktober 2022 auftritt, kann dies durch die Deaktivierung der Standardauthentifizierung verursacht werden. Weitere Informationen zum vorübergehenden Aktivieren der Standardauthentifizierung für einen begrenzten Zeitraum finden Sie unter Verwenden der Standardauthentifizierung mit Exchange Online.

Symptome

Wenn Sie Server-Side Synchronization in Dynamics 365 verwenden, erhalten Sie einen der folgenden Fehler:

  • Die E-Mail-Nachricht "Testnachricht" kann nicht gesendet werden. Stellen Sie sicher, dass die im Postfachnamen <> angegebenen Anmeldeinformationen korrekt sind und über ausreichende Berechtigungen zum Senden von E-Mails verfügen. Aktivieren Sie dann das Postfach für die E-Mail-Verarbeitung.
  • Termine, Kontakte und Aufgaben können nicht synchronisiert werden. Stellen Sie sicher, dass die im Postfachnamen <> angegebenen Anmeldeinformationen korrekt sind und über ausreichende Berechtigungen verfügen. Aktivieren Sie dann das Postfach für die Synchronisierung von Terminen, Kontakten und Aufgaben.
  • Email kann für das Postfach < nicht empfangen werdenPostfachname>. Stellen Sie sicher, dass die im Postfach angegebenen Anmeldeinformationen korrekt sind und über ausreichende Berechtigungen zum Empfangen von E-Mails verfügen. Aktivieren Sie dann das Postfach für die E-Mail-Verarbeitung.

Die Meldung enthält auch den folgenden Fehlercode:

Email Serverfehlercode: Http-Server hat die Ausnahme "401 Nicht autorisiert" zurückgegeben.

Ursache

Diese Fehler können aus einem der folgenden Gründe auftreten:

  1. Die E-Mail-Adresse des Postfachdatensatzes in Dynamics 365 stimmt nicht mit der E-Mail-Adresse des Postfachs in Exchange überein.

  2. Wenn Sie Dynamics 365 (online) mit Exchange Online verwenden, kann dieser Fehler auftreten, wenn Sie ein Exchange Server (Hybrid)-Profil verwenden, obwohl sich das Postfach des Benutzers in Exchange Online befindet.

  3. Wenn Sie Dynamics 365 mit Exchange Online verwenden, kann dieser Fehler auftreten, wenn der Benutzer nicht über eine Exchange Online-Lizenz verfügt.

  4. Wenn Sie Dynamics 365 (online) mit Exchange Online verwenden, kann dieser Fehler auftreten, wenn sich Ihr Dynamics 365 Abonnement nicht in demselben Office 365 Mandanten wie Ihr Exchange Online-Abonnement befindet. Wenn Sie ein Exchange Online-E-Mail-Serverprofil verwenden, müssen sich Dynamics 365 (online) und Exchange Online im gleichen Office 365 Konto/Mandanten befinden.

  5. Wenn Sie Dynamics 365 (online) mit Exchange lokal verwenden, kann dieser Fehler auftreten, wenn die Standardauthentifizierung für EWS (Exchange-Webdienste) nicht aktiviert ist.

  6. Der Benutzer oder das Postfach, das gelöscht wurde, wurde später mit derselben E-Mail-Adresse neu erstellt.

    Wenn Sie versuchen, das Postfach zu testen und zu aktivieren, sehen Sie möglicherweise, dass die NoUserFoundWithGivenClaims-Nachricht als Teil einer Warnung zur Fehlerstufe enthalten ist. Möglicherweise wird auch eine Warnung angezeigt, in der im Detailabschnitt "Benutzer ist nicht im Mandanten mit der ID '<Benutzer-ID>' vorhanden" angezeigt wird.

Lösung

Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben:

  1. Überprüfen Sie, ob die E-Mail-Adresse des Postfachdatensatzes in Dynamics 365 mit der E-Mail-Adresse in Exchange übereinstimmt. Der Fehler enthält einen Link zum Postfachdatensatz in Dynamics 365. Sie können diesen Link verwenden, um das Feld Email Adresse schnell zu überprüfen.

  2. Wenn Sie Dynamics 365 (online) mit Exchange Online verwenden, stellen Sie sicher, dass Sie ein Exchange Online-E-Mail-Serverprofil verwenden. Verwenden Sie ein Exchange Server (Hybrid)-Profil nur für Benutzer, die über Postfächer in Exchange lokal verfügen.

  3. Wenn Sie Dynamics 365 mit Exchange Online verwenden, überprüfen Sie, ob der Benutzer über eine Exchange Online-Lizenz verfügt. Weitere Informationen zum Zuweisen von Lizenzen in Office 365 finden Sie unter Gleichzeitiges Hinzufügen von Benutzern und Zuweisen von Lizenzen.

  4. Wenn Sie Dynamics 365 (online) mit Exchange Online verwenden, überprüfen Sie, ob sich Dynamics 365 (online) und Exchange Online im selben Office 365 Konto/Mandanten befinden.

  5. Wenn Sie Dynamics 365 (online) mit Exchange lokal verwenden, überprüfen Sie, ob die Standardauthentifizierung für EWS (Exchange-Webdienste) aktiviert ist. Weitere Informationen finden Sie im Abschnitt Voraussetzungen von Connect Dynamics 365 (online) to Exchange Server (on-premises).

  6. Wenn der Benutzer oder das Postfach, das gelöscht wurde, später mit derselben E-Mail-Adresse neu erstellt wurde:

    1. Stellen Sie sicher, dass der zuvor vorhandene Benutzer oder das Postfach endgültig gelöscht wurde. Standardmäßig kann ein Benutzer, der aus Microsoft Entra ID gelöscht wird, sein Konto innerhalb von 30 Tagen wiederhergestellt werden. Weitere Informationen finden Sie unter Dauerhaftes Löschen eines Benutzers.
    2. Nachdem Sie überprüft haben, dass kein Benutzer oder Postfach dieselbe E-Mail-Adresse verwendet, können Sie versuchen, das Postfach erneut zu testen und zu aktivieren. Wenn die Fehlermeldung weiterhin angezeigt wird, kann das Problem durch das Zwischenspeichern verursacht werden. Es kann bis zu 72 Stunden dauern, bis der Cache gelöscht wird. Wenn Sie nicht 72 Stunden warten können, wenden Sie sich an Microsoft-Support.