Entwickeln von U-SQL-Skripts mit Data Lake-Tools für Visual Studio

Azure Data Lake- und Stream Analytics-Tools enthalten Funktionen für zwei Azure-Dienste: Azure Data Lake Analytics und Azure Stream Analytics. Weitere Informationen zu den Azure Stream Analytics-Szenarien finden Sie unter Installieren der Azure Stream Analytics-Tools für Visual Studio.

Dieser Artikel beschreibt, wie Sie Azure Data Lake Analytics-Konten mithilfe von Visual Studio erstellen. Sie können Aufträge in U-SQL definieren und Aufträge an den Data Lake Analytics-Dienst übermitteln. Weitere Informationen zu Data Lake Analytics finden Sie unter Übersicht über Azure Data Lake Analytics.

Wichtig

Wir empfehlen Ihnen das Upgrade auf Azure Data Lake Tools für Visual Studio Version 2.3.3000.4 oder höher. Ältere Versionen stehen nicht mehr als Download zur Verfügung und sind veraltet.

  1. Überprüfen Sie, ob Sie von Azure Data Lake Tools für Visual Studio eine niedrigere Version als 2.3.3000.4 verwenden.

    Check tool version

  2. Falls es sich bei Ihrer Version um eine Version vor 2.3.3000.4 handelt, aktualisieren Sie Ihre Azure Data Lake Tools für Visual Studio über das Download Center:

Voraussetzungen

Installieren von Azure Data Lake Tools für Visual Studio

Für dieses Tutorial muss Data Lake Tools für Visual Studio installiert sein. Weitere Informationen finden Sie unter Installieren von Data Lake Tools für Visual Studio.

Herstellen einer Verbindung mit einem Azure Data Lake Analytics-Konto

  1. Öffnen Sie Visual Studio.

  2. Öffnen Sie Data Lake Analytics-Explorer, indem Sie Ansicht>Data Lake Analytics-Explorer auswählen.

  3. Klicken Sie mit der rechten Maustaste auf Azure, und wählen Sie dann Verbindung mit Microsoft Azure-Abonnement herstellen aus. Befolgen Sie die Anweisungen unter Bei Ihrem Konto anmelden.

  4. Wählen Sie im Server-ExplorerAzure>Data Lake Analytics aus. Es wird eine Liste Ihrer Data Lake Analytics-Konten angezeigt.

Schreiben Ihres ersten U-SQL-Skripts

Der folgende Text ist ein einfaches U-SQL-Skript. Es definiert ein kleines Dataset und schreibt dieses Dataset als Datei mit dem Namen /data.csv in die Standardinstanz von Data Lake Store.

USE DATABASE master;
USE SCHEMA dbo;
@a  = 
    SELECT * FROM 
        (VALUES
            ("Contoso", 1500.0),
            ("Woodgrove", 2700.0)
        ) AS 
              D( customer, amount );
OUTPUT @a
    TO "/data.csv"
    USING Outputters.Csv();

Übermitteln eines Data Lake Analytics-Auftrags

  1. Klicken Sie in Visual Studio auf Datei>Neu>Projekt.

  2. Wählen Sie den Typ U-SQL-Projekt und dann Weiter aus. Wählen Sie in Neues Projekt konfigurieren die Option Erstellen aus.

    Visual Studio erstellt eine Projektmappe mit der Datei Script.usql.

  3. Fügen Sie das Skript aus Schreiben Ihres ersten U-SQL-Skripts in das Fenster Script.usql ein.

  4. Klicken Sie im Projektmappen-Explorer mit der rechten Maustaste auf Script.usql, und wählen Sie dann Skript senden aus.

  5. Wählen Sie unter Auftrag übermitteln ihr Data Lake Analytics-Konto aus, und wählen Sie Übermitteln aus.

    Submit U-SQL Visual Studio project

Nach der Auftragsübermittlung wird die Registerkarte Auftragsansicht mit dem Auftragsstatus geöffnet.

  • Auftragszusammenfassung enthält die Zusammenfassung des Auftrags.
  • Auftragsdiagramm visualisiert den Fortschritt des Auftrags.
  • Metadatenvorgänge zeigt alle Aktionen, die auf den U-SQL-Katalog ausgeführt wurden.
  • Daten zeigt alle Eingaben und Ausgaben.
  • Unter State History (Statusverlauf) werden die Zeitachse und Statusdetails angezeigt.
  • Unter AU-Analyse sehen Sie, wie viele AUs im Auftrag verwendet wurden, und Sie können Simulationen verschiedener AU-Zuordnungsstrategien erkunden.
  • Diagnose enthält eine erweiterte Analyse für die Optimierung der Ausführung und Leistung des Auftrags.

U-SQL Visual Studio Data Lake Analytics job performance graph

Um den aktuellen Auftragsstatus anzuzeigen und den Bildschirm zu aktualisieren, wählen Sie Aktualisieren aus.

Überprüfen des Auftragsstatus

  1. Wählen Sie im Server-ExplorerAzure>Data Lake Analytics aus.

  2. Erweitern Sie den Namen des Azure Data Lake Analytics-Kontos.

  3. Doppelklicken Sie auf Aufträge.

  4. Wählen Sie den Auftrag aus, den Sie zuvor gesendet haben.

Anzeigen der Auftragsausgabe

  1. Navigieren Sie im Server-Explorer zu dem Auftrag, den Sie gesendet haben.

  2. Klicken Sie auf die Registerkarte Daten .

  3. Wählen Sie auf der Registerkarte Auftragsausgaben die Datei "/data.csv" aus.

Nächste Schritte