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Problembehandlung mit Azure Resource Graph

Beim Abfragen von Azure-Ressourcen mit Azure Resource Graph können Fehler auftreten. In diesem Artikel wird beschrieben, welche Fehler auftreten und wie diese behoben werden können.

Ermitteln von Fehlerdetails

Die meisten Fehler werden durch Probleme beim Ausführen einer Abfrage mit Azure Resource Graph ausgelöst. Wenn eine Abfrage fehlschlägt, stellt das SDK Details zu dem Problem bereit. Diese Informationen enthalten Hinweise zum Problem, damit Sie es beheben können und die nächste Abfrage erfolgreich verläuft.

Allgemeine Fehler

Szenario: Gedrosselte Anforderungen

Problem

Bei Kunden, die große oder häufige Ressourcenabfragen tätigen, sind die Anforderungen gedrosselt.

Ursache

Azure Resource Graph ordnet, abhängig von einem Zeitfenster, jedem Benutzer eine Kontingentnummer zu. Ein Benutzer kann innerhalb eines Zeitfensters von 5 Sekunden beispielsweise höchstens 15 Abfragen ohne Drosselung senden. Der Kontingentwert wird von vielen Faktoren bestimmt und kann verändert werden. Weitere Informationen finden Sie unter Drosselung in Azure Resource Graph.

Lösung

Es gibt mehrere Methoden für den Umgang mit gedrosselten Anforderungen:

Szenario: Zu viele Abonnements

Problem

Kunden mit Zugriff auf mehr als 1.000 Abonnements, einschließlich mandantenübergreifender Abonnements über Azure Lighthouse, können nicht über einen einzigen Aufruf von Azure Resource Graph Daten zu allen Abonnements abrufen.

Ursache

Die Azure CLI und PowerShell leiten nur die ersten 1.000 Abonnements an Azure Resource Graph weiter. Die Rest-API für Azure Resource Graph akzeptiert eine maximale Anzahl von Abonnements, für die die Abfrage durchgeführt werden soll.

Lösung

Verwenden Sie Batchanforderungen für die Abfrage, die nur aus einem Teil der Abonnements bestehen, um unter der Grenze von 1.000 Abonnements zu bleiben. Verwenden Sie den Parameter Subscription (Abonnement) in PowerShell, um das Problem zu lösen.

# Replace this query with your own
$query = 'Resources | project type'

# Fetch the full array of subscription IDs
$subscriptions = Get-AzSubscription
$subscriptionIds = $subscriptions.Id

# Create a counter, set the batch size, and prepare a variable for the results
$counter = [PSCustomObject] @{ Value = 0 }
$batchSize = 1000
$response = @()

# Group the subscriptions into batches
$subscriptionsBatch = $subscriptionIds | Group -Property { [math]::Floor($counter.Value++ / $batchSize) }

# Run the query for each batch
foreach ($batch in $subscriptionsBatch){ $response += Search-AzGraph -Query $query -Subscription $batch.Group }

# View the completed results of the query on all subscriptions
$response

Szenario: Nicht unterstützter REST-Header „Content-Type“

Problem

Kunden, die die Azure Resource Graph-REST-API abfragen, erhalten die Antwort 500 (Interner Serverfehler).

Ursache

Die Azure Resource Graph-REST-API unterstützt nur application/json als Content-Type. Einige REST-Tools oder -Agents legen standardmäßig text/plain fest. Dies wird in der REST-API nicht unterstützt.

Lösung

Überprüfen Sie, ob in dem Tool oder Agent, das oder den Sie zum Abfragen von Azure Resource Graph verwenden, der REST-API-Header Content-Type für application/json konfiguriert ist.

Szenario: Keine Leseberechtigung für alle Abonnements in der Liste

Problem

Kunden, die mit einer Azure Resource Graph-Abfrage explizit eine Liste mit Abonnements übergeben, erhalten die Antwort 403 (Verboten).

Ursache

Wenn der Kunde nicht über die Leseberechtigung für alle angegebenen Abonnements verfügt, wird die Anforderung aufgrund fehlender entsprechender Sicherheitsrechte abgelehnt.

Lösung

Fügen Sie mindestens ein Abonnement in die Abonnementliste ein, für das der Kunde, der die Abfrage ausführt, mindestens über Lesezugriff verfügt. Weitere Informationen finden Sie unter Berechtigungen in Azure Resource Graph.

Nächste Schritte

Wenn Ihr Problem nicht aufgeführt ist oder Sie es nicht lösen können, besuchen Sie einen der folgenden Kanäle, um weitere Unterstützung zu erhalten:

  • Erhalten Sie Antworten von Azure-Experten über Azure-Foren.
  • Mit @AzureSupport verbinden – das offizielle Microsoft Azure-Konto für die Verbesserung der Kundenzufriedenheit durch Verbinden der Azure-Community mit den richtigen Ressourcen: Antworten, Support und Experten.
  • Wenn Sie weitere Hilfe benötigen, können Sie einen Azure-Supportvorgang anlegen. Rufen Sie die Azure-Support-Website auf, und wählen Sie Support erhaltenaus.