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In diesem Artikel werden Schritte zur Problembehandlung und mögliche Lösungen für Probleme bei der Interaktion mit Azure HDInsight-Clustern beschrieben.
Problem
Die Kernel-Syslog-Protokolle enthalten die folgende Fehlermeldung: watchdog: BUG: soft lockup - CPU
.
Ursache
Ein Fehler im Linux-Kernel verursacht eine vorübergehende CPU-Blockierung.
Lösung
Wenden Sie einen Kernelpatch an. Das folgende Skript aktualisiert den Linux-Kernel und startet die Computer im Laufe von 24 Stunden zu verschiedenen Zeitpunkten neu. Führen Sie die Skriptaktion in zwei Batches aus. Der erste Batch wird für alle Knoten mit Ausnahme des Hauptknotens ausgeführt. Der zweite Batch wird für den Hauptknoten ausgeführt. Führen Sie die Batches nicht gleichzeitig für den Hauptknoten und die anderen Knoten aus.
Navigieren Sie im Azure-Portal zu Ihrem HDInsight-Cluster.
Rufen Sie die Skriptaktionen auf.
Wählen Sie Neue übermitteln aus, und geben Sie Folgendes ein:
Eigenschaft Wert Skripttyp -Custom Name Fix for kernel soft lock issue Bash-Skript-URI https://raw.githubusercontent.com/hdinsight/hdinsight.github.io/master/ClusterCRUD/KernelSoftLockFix/scripts/KernelSoftLockIssue_FixAndReboot.sh
Knotentyp(en) Worker, Zookeeper Parameter – Wählen Sie Speichern Sie diese Skriptaktion... aus, wenn Sie das Skript beim Hinzufügen neuer Knoten ausführen möchten.
Klicken Sie auf Erstellen.
Warten Sie, bis die Ausführung erfolgreich abgeschlossen wurde.
Führen Sie die Skriptaktion für den Hauptknoten aus, indem Sie Schritt 3 erneut ausführen. Dieses Mal jedoch mit dem Hauptknotentyp.
Warten Sie, bis die Ausführung erfolgreich abgeschlossen wurde.
Nächste Schritte
Wenn Ihr Problem nicht aufgeführt ist oder Sie es nicht lösen können, besuchen Sie einen der folgenden Kanäle, um weitere Unterstützung zu erhalten:
Nutzen Sie den Azure-Communitysupport, um Antworten von Azure-Experten zu erhalten.
Setzen Sie sich mit @AzureSupport in Verbindung, dem offiziellen Microsoft Azure-Konto zum Verbessern der Kundenfreundlichkeit. Verbinden der Azure-Community mit den richtigen Ressourcen: Antworten, Support und Experten.
Sollten Sie weitere Unterstützung benötigen, senden Sie eine Supportanfrage über das Azure-Portal. Wählen Sie dazu auf der Menüleiste die Option Support aus, oder öffnen Sie den Hub Hilfe und Support. Ausführlichere Informationen hierzu finden Sie unter Erstellen einer Azure-Supportanfrage. Zugang zu Abonnementverwaltung und Abrechnungssupport ist in Ihrem Microsoft Azure-Abonnement enthalten. Technischer Support wird über einen Azure-Supportplan bereitgestellt.