CMTrace

Gilt für: Configuration Manager (Current Branch)

CMTrace ist eines der Configuration Manager Tools. Es ermöglicht Ihnen, Protokolldateien anzuzeigen und zu überwachen, einschließlich der folgenden Typen:

  • Protokolldateien im Configuration Manager- oder CCM-Format (Client Component Manager)

  • Einfache ASCII- oder Unicode-Textdateien, z. B. Windows Installer-Protokolle

Das Tool hilft bei der Analyse von Protokolldateien durch Hervorhebung, Filterung und Fehlersuche.

Hinweis

CMTrace wird nicht automatisch bei Windows registriert, um die Dateierweiterung .log zu öffnen. Weitere Informationen finden Sie unter Dateizuordnungen.

Configuration Manager Version 2107 enthält mehrere Leistungsverbesserungen für den CMTrace-Protokoll-Viewer.

Speicherorte

Configuration Manager installiert CMTrace automatisch an den folgenden Speicherorten:

  • Das Toolsverzeichnis des Standortservers. Beispiel: cd.latest\SMSSETUP\Tools\CMTrace.exe
  • Das Installationsverzeichnis des Verwaltungspunkts. Beispiel: C:\SMS_CCM\CMTrace.exe
  • Das Clientinstallationsverzeichnis. Beispiel: C:\Windows\CCM\CMTrace.exe
  • Startimages für die Betriebssystembereitstellung. Beispiel: X:\sms\bin\x64\CMTrace.exe

Wenn Sie eine Kopie von CMTrace an einem anderen Speicherort haben, sollten Sie sie entfernen und eine Kopie in einem der Standardpfade verwenden. Wenn es sich an einem benutzerdefinierten Standort befindet, der Ihre Geschäftlichen Anforderungen erfüllt, stellen Sie sicher, dass Sie über einen Prozess verfügen, um ihn auf dem neuesten Stand zu halten. Wenn Ihr benutzerdefinierter Standort für andere Kunden von Vorteil sein könnte, senden Sie Produktfeedback.

Im Community Hub ist ein Skript verfügbar, mit dem Sie CMTrace-Versionen suchen und auf die neueste Version aktualisieren können: CMTraceUpdate. Weitere Informationen finden Sie unter Direkte Links zu Community Hub-Elementen.

Verwendung

Führen Sie CMTrace.exeaus. Wenn Sie das Tool zum ersten Mal ausführen, wird eine Aufforderung zur Dateizuordnung angezeigt. Weitere Informationen finden Sie unter Dateizuordnungen.

Sie führen die meisten Aktionen in CMTrace über die folgenden Menüs aus:

Menü "Datei"

Die folgenden Aktionen sind im Menü Datei verfügbar:

Im Menü Datei werden auch die letzten acht zuletzt verwendeten Dateien aufgelistet. Öffnen Sie eines dieser Protokolle schnell erneut, indem Sie es im Menü Datei auswählen.

Öffnen

Zeigt das Dialogfeld Öffnen an, um nach einer Protokolldatei zu suchen.

Filtern Sie die Ansicht nach Dateien der folgenden Typen:

  • Protokolldateien (*.log)
  • Alte Protokolldateien (*.lo_)
  • Alle Dateien (*.*)

Die folgenden beiden Optionen sind standardmäßig nicht ausgewählt:

  • Vorhandene Zeilen ignorieren: Wenn diese Option ausgewählt ist, ignoriert CMTrace den vorhandenen Inhalt der ausgewählten Protokolldatei und zeigt neue Zeilen nur an, wenn sie hinzugefügt werden. Verwenden Sie diese Option, um nur neue Aktionen zu überwachen, wenn Sie nicht den vollständigen Verlauf der Protokolldatei benötigen.

  • Ausgewählte Dateien zusammenführen: Wenn Sie diese Option aktivieren und mehrere Protokolldateien auswählen, führt CMTrace die ausgewählten Protokolle in der Ansicht zusammen. Sie werden angezeigt, als ob es sich um eine einzelne Protokolldatei handelt. Das zusammengeführte Protokoll aktualisiert dasselbe und unterstützt alle anderen CMTrace-Features, als ob es sich um eine einzelne Protokolldatei handelt.

Auf Server öffnen

Durchsuchen Sie den Ordner Configuration Manager Protokolle auf einem Standortsystemcomputer mit dem Standarddialogfeld Durchsuchen. Sie können auch das Netzwerk nach einem Remotecomputer durchsuchen.

Wenn Sie einen Remotecomputer zum Durchsuchen auswählen, sucht CMTrace nach der Configuration Manager Freigabe. Wenn eine Freigabe mit Configuration Manager Protokolldateien nicht gefunden werden kann, wird eine Fehlermeldung angezeigt.

Um eine direkte Verbindung mit einem bekannten Computer herzustellen, ohne zu navigieren, verwenden Sie die Aktion Öffnen . Geben Sie dann einen Servernamen und eine Freigabe im UNC-Format ein.

Drucken

Zeigt das Standardmäßige Windows-Dialogfeld Drucken an. Diese Aktion sendet die aktuelle Protokolldatei an einen Drucker. Die Ausgabe wird entsprechend den Einstellungen auf der Registerkarte Drucken der CMTrace-Einstellungen formatiert.

Einstellungen

Konfigurieren Sie Einstellungen für CMTrace. Die folgenden Optionen sind verfügbar:

  • Registerkarte "Allgemein"

    • Updateintervall: Steuert, wie oft CMTrace nach Änderungen an Protokolldateien sucht und neue Zeilen lädt. Standardmäßig beträgt dieser Wert 500 Millisekunden.

    • Hervorhebung: Legt die Farbe fest, die CMTrace beim Hervorheben der von Ihnen ausgewählten Protokolllinien verwendet. Standardmäßig ist diese Farbe gelb (Rot: 255, Grün: 255, Blau: 0).

    • Spalten: Konfiguriert die Spalten, die in der Protokollansicht sichtbar sind, und die Reihenfolge, in der sie angezeigt werden. Standardmäßig werden Protokolltext, Komponente, Datum/Uhrzeit und Thread angezeigt.

  • Registerkarte "Drucken "

    • Spalten: Konfigurieren Sie, welche Spalten beim Drucken von Protokolldateien verwendet werden, und die Reihenfolge, in der sie angezeigt werden. Standardmäßig werden die gleichen Spalten ausgegeben, wie sie angezeigt werden.

    • Ausrichtung: Legt die Standardausrichtung beim Drucken von Protokolldateien fest. Überschreiben Sie diese Einstellung im Dialogfeld Drucken. Standardmäßig wird die Hochformatausrichtung verwendet.

  • Registerkarte "Erweitert"

    • Aktualisierungsintervall: Erzwingt CMTrace, die Protokollansicht in einem angegebenen Intervall zu aktualisieren, wenn eine große Anzahl von Zeilen geladen wird. Standardmäßig ist diese Option mit dem Wert 0 (null) deaktiviert.

      Hinweis

      Im Allgemeinen sollten Sie das Aktualisierungsintervall nicht ändern. Es kann die Zeit, die zum Öffnen großer Protokolldateien benötigt wird, erheblich verlängern.

Menü 'Extras'

Die folgenden Aktionen sind im Menü Extras verfügbar:

Suchen

Durchsuchen Sie die geöffnete Protokolldatei nach einer angegebenen Textzeichenfolge.

Weitersuchen

Sucht die nächste übereinstimmende Zeichenfolge, wie Sie zuvor im Dialogfeld Suchen angegeben haben.

In Zwischenablage kopieren

Kopiert die ausgewählten Zeilen als Nur-Text in die Windows-Zwischenablage. Wenn Sie Configuration Manager- und CCM-Protokolldateien untersuchen, werden die Spalten in der gleichen Reihenfolge wie die Ansicht kopiert. Jede Spalte wird durch ein Tabstoppzeichen getrennt. Verwenden Sie diese Aktion, wenn Sie Protokolle in E-Mail-Nachrichten oder andere Dokumente kopieren.

Highlight

Geben Sie eine Zeichenfolge ein, die CMTrace verwendet, um den Text der einzelnen Protokolleinträge zu durchsuchen. Anschließend werden alle Protokolltexte hervorgehoben, die mit der eingegebenen Zeichenfolge übereinstimmen.

  • Die Hervorhebung verwendet die Farbe, die Sie in den Einstellungen angegeben haben.

  • Um die Hervorhebung zu deaktivieren, löschen Sie die Zeichenfolge aus diesem Feld.

  • Wenn Sie eine Dezimal- oder Hexadezimalzahl eingeben, versucht CMTrace, den Wert der Threadspalte abzugleichen. Verwenden Sie dieses Verhalten, um die Verarbeitung eines einzelnen Threads hervorzuheben, ohne andere Threads herauszufiltern, die möglicherweise mit diesem thread interagieren.

  • Um Zeichenfolgen nach Groß-/Kleinschreibung zu vergleichen, aktivieren Sie die Option unter Groß-/Kleinschreibung beachten.

Filter

Ein- oder Ausblenden von Protokollzeilen basierend auf den angegebenen Kriterien. Wenden Sie Filter auf eine der vier Spalten an, unabhängig davon, ob sie sichtbar sind. Diese Einstellungen gelten für jede geöffnete Protokolldatei.

Beispiele:

  • Filtern Sie smsts.log nach Dem Eintragstext, der "die Aktion" oder "die Gruppe" enthält.
  • Filtern Sie InventoryAgent.log , wobei der Eintragstext "Destination" enthält.

Fehlersuche

Geben Sie einen Fehlercode im Dezimal- oder Hexadezimalformat ein, oder fügen Sie ihn ein, um eine Beschreibung anzuzeigen. Mögliche Fehlerquellen sind: Windows, WMI oder Winhttp.

Anhalten

Anhalten oder Neustarten der Protokollüberwachung. Die folgenden Anwendungsfälle sind einige der möglichen Gründe für die Verwendung dieser Aktion:

  • Wenn CMTrace Protokolldateiinformationen zu schnell anzeigt

  • Wenn Sie die Protokollüberwachung anhalten, gehen die von CMTrace angezeigten Informationen nicht verloren, wenn für die aktuelle Datei ein Rollover zu einem neuen Protokoll ausgeführt wird.

  • Wenn Sie verhindern möchten, dass CMTrace neue Daten anzeigt, während Sie die Protokolldatei untersuchen

Details ein-/ausblenden

Alle Spalten außer dem Protokolltext ein- oder ausblenden. Außerdem wird die Protokolltextspalte auf die Breite des Fensters erweitert. Verwenden Sie diese Aktion, wenn Sie Protokolle auf einem Computer mit niedriger Bildschirmauflösung anzeigen. Es wird ein weiterer Protokolltext angezeigt.

Hinweis

Beim Anzeigen von Nur-Text-Dateien blendet CMTrace automatisch Details aus, da sie immer leer sind.

Infobereich ein-/ausblenden

Blenden Sie den Infobereich ein oder aus. Verwenden Sie diese Aktion, wenn Sie Protokolle auf einem Computer mit niedriger Bildschirmauflösung anzeigen. Weitere Protokollierungsdetails werden angezeigt.

Protokollbereich

Der Protokollbereich befindet sich oben im CMTrace-Fenster. Es zeigt Zeilen aus Protokolldateien an.

Wenn Sie eine Linie auswählen, wird sie vorübergehend mithilfe des Windows-Auswahlfarbschemas hervorgehoben.

Hervorgehobene Linien entsprechen den Kriterien, die Sie mit der Option Hervorheben im Menü Extras definieren. Die Hervorhebung verwendet die Farbe, die Sie unter Einstellungen angeben.

CMTrace zeigt Zeilen mit Fehlern unter Verwendung eines roten Hintergrunds und gelber Textfarbe an. In Protokollen im CCM-Format weisen Protokolleinträge einen expliziten Typwert auf, der den Eintrag als Fehler angibt. Bei anderen Protokollformaten führt CMTrace in jedem Eintrag eine Suche ohne Berücksichtigung der Groß-/Kleinschreibung nach textzeichenfolgen durch, die mit "error" übereinstimmen.

Es werden Zeilen mit Warnungen mit einem gelben Hintergrund angezeigt. In Protokollen im CCM-Format weisen Protokolleinträge einen expliziten Typwert auf, der den Eintrag als Warnung angibt. Bei anderen Protokollformaten führt CMTrace in jedem Eintrag eine Suche ohne Berücksichtigung der Groß-/Kleinschreibung nach einer beliebigen Textzeichenfolge durch, die mit "warn" übereinstimmt.

Infobereich

Der Infobereich befindet sich am unteren Rand des CMTrace-Fensters. Sie enthält die folgenden Features:

  • Details zum aktuell ausgewählten Protokolleintrag

  • Ein Textfeld, in dem der Protokolltext angezeigt wird

  • Es zeigt Wagenrückläufe an, sodass formatierter Text leichter zu lesen ist.

  • Einfachere Lesbarkeit langer Einträge, die im Protokollbereich nicht vollständig sichtbar sind

Ein- oder Ausblenden des Infobereichs mit der Option Infobereich ein-/ausblenden im Menü Extras . Wenn der Infobereich mehr als die Hälfte des Protokollfensters einnimmt, blendet CMTrace es automatisch aus.

Statusanzeige

Wenn Sie eine Protokolldatei zum ersten Mal öffnen, ersetzt CMTrace den Infobereich durch eine Statusanzeige. Dieser Fortschritt gibt an, wie viel des vorhandenen Dateiinhalts geladen wird. Der Fortschritt erreicht 100 Prozent, CMTrace entfernt die Statusanzeige und ersetzt sie durch den Infobereich. Wenn Sie große Dateien laden, gibt ihnen dieses Verhalten einen Hinweis darauf, wie lange die Last dauern kann.

Statusleiste

Bei Protokolldateien im Configuration Manager- und CCM-Format zeigt die Statusleiste die verstrichene Zeit für die ausgewählten Protokolleinträge an. Wenn Sie einen einzelnen Eintrag auswählen, zeigt das Tool die Zeit vom ersten Protokolleintrag bis zum ausgewählten Eintrag an. Wenn Sie mehrere Einträge auswählen, wird die Zeit vom am höchsten ausgewählten Eintrag bis zum am weitesten unten ausgewählten Eintrag berechnet. CMTrace formatiert diese Informationen wie folgt:

Elapsed time is <hours>h <minutes>m <seconds>s <milliseconds>ms (<seconds+milliseconds> seconds)

Windows-Shellintegration

CMTrace unterstützt Dateizuordnungen und Drag-and-Drop.

Dateizuordnungen

CMTrace kann sich log- und .lo_ Dateinamenerweiterungen zuordnen. Wenn das Programm gestartet wird, überprüft es die Registrierung, um festzustellen, ob es diesen Dateinamenerweiterungen bereits zugeordnet ist. Wenn CMTrace noch keiner Dateinamenerweiterung zugeordnet ist, werden Sie aufgefordert, die Dateinamenerweiterungen CMTrace zuzuordnen. Wenn Sie Dies nicht erneut fragen auswählen, überspringt CMTrace diese Überprüfung, wenn sie auf diesem Computer ausgeführt wird.

Ziehen und Ablegen

CMTrace unterstützt grundlegende Drag-and-Drop-Funktionen. Ziehen Sie eine Protokolldatei aus Windows-Explorer in CMTrace, um sie zu öffnen.

Weitere Tipps

Registrierungsschlüssel des letzten Verzeichnisses

Standardmäßig speichert CMTrace den zuletzt geöffneten Protokollspeicherort. Dieses Verhalten ist auf dem Standortserver nützlich, da es standardmäßig jedes Mal den Protokollpfad verwendet.

Wenn Sie es zum ersten Mal auf einem Client starten, wird standardmäßig das aktuelle Arbeitsverzeichnis verwendet. Dieser Speicherort kann der Pfad sein, in dem Sie CMTrace gespeichert haben, oder ein Pfad wie %userprofile%\Desktop.

Der Wert Last Directory im Registrierungsschlüssel HKEY_CURRENT_USER\Software\Microsoft\Trace32 steuert diesen Standardspeicherort. Wenn Sie diesen Wert %windir%\CCM\Logs auf Ihren Clients auf festlegen, öffnet CMTrace Dateien am Speicherort des Clientprotokolls, wenn Sie es zum ersten Mal ausführen.

Nächste Schritte

OneTrace ist der Protokoll-Viewer im Supportcenter. Es funktioniert ähnlich wie CMTrace, mit Verbesserungen. Weitere Informationen finden Sie unter Supportcenter OneTrace.