Tutorial: Erstellen von ansprechenden Berichten aus Excel-Arbeitsmappen in Power BI Desktop

GILT FÜR: ✔️ Power BI Desktop ✔️ Power BI-Dienst

In diesem Tutorial erstellen Sie einen ansprechenden Bericht. Dafür benötigen Sie insgesamt nicht mehr als 20 Minuten.

Screenshot des fertiggestellten Power BI-Berichts

Ihr Vorgesetzter möchte einen Bericht der aktuellen Umsatzzahlen haben. Dazu sollen Sie eine Kurzfassung folgender Informationen erstellen:

  • In welchem Monat und Jahr konnten die höchsten Gewinne erzielt werden?
  • Wo sieht das Unternehmen den größten Erfolg (nach Land/Region)?
  • In welches Produkt und Segment sollte das Unternehmen weiter investieren?

Mithilfe der Finanzbeispielarbeitsmappe können Sie diesen Bericht innerhalb kürzester Zeit erstellen. Der fertige Bericht sollte folgendermaßen aussehen. Dann legen wir los!

In diesem Tutorial lernen Sie Folgendes:

  • Herunterladen von Beispieldaten auf zwei verschiedene Arten
  • Vorbereiten Ihrer Daten mit mehreren Transformationen
  • Erstellen eines Berichts mit einer Kachel, drei Visuals und einem Slicer
  • Veröffentlichen Ihres Berichts im Power BI-Dienst zur Freigabe für Kollegen

Voraussetzungen

  • Bevor Sie starten können, müssen Sie Power BI Desktop herunterladen.
  • Wenn Sie Ihren Bericht in Power BI veröffentlichen möchten und sich noch nicht registriert haben, registrieren Sie sich hier für eine kostenlose Testversion.

Datensammlung

Sie können die Daten für dieses Tutorial mit zwei verschiedenen Methoden abrufen.

Abrufen von Daten in Power BI Desktop

Öffnen Sie Power BI Desktop, und wählen Sie auf der leeren Canvas die Option Beispieldataset ausprobieren aus.

Screenshot der Option „Beispieldataset ausprobieren“ auf der Canvas

Wenn Sie über Power BI Desktop in dieses Tutorial gelangt sind, fahren Sie fort, indem Sie Daten laden auswählen.

Screenshot der beiden Möglichkeiten zum Verwenden von Beispieldaten > Daten laden.

Herunterladen des Beispiels

Sie können die Beispielarbeitsmappe auch direkt herunterladen.

  1. Laden Sie die Excel-Finanzbeispielarbeitsmappe herunter.
  2. Öffnen Sie Power BI Desktop.
  3. Klicken Sie im Bereich Daten im Menüband Start auf Excel.
  4. Navigieren Sie zum Speicherort der Beispielarbeitsmappe, und klicken Sie auf Öffnen.

Bereiten Sie die Daten vor.

Im Navigator stehen Ihnen die Optionen zum Transformieren oder Laden der Daten zur Verfügung. Im Navigator können Sie eine Vorschau Ihrer Daten anzeigen, damit Sie überprüfen können, ob Sie den richtigen Datenbereich angegeben haben. Numerische Datentypen werden kursiv geschrieben. Wenn Sie Änderungen vornehmen müssen, transformieren Sie Ihre Daten vor dem Laden. Damit die Visualisierungen einfacher gelesen werden können, sollen die Daten nun transformiert werden. Bei Durchführung der einzelnen Transformationen können Sie sehen, wie sie unter Abfrageeinstellungen bei Angewendete Schritte hinzugefügt werden.

  1. Wählen Sie die Tabelle Financials aus, und klicken Sie auf Daten transformieren.

    Screenshot des Navigators in Power BI mit den Finanzbeispieldaten

  2. Klicken Sie auf die Spalte Units Sold (Verkaufte Einheiten). Klicken Sie auf der Registerkarte Transformieren auf Datentyp, und wählen Sie ganze Zahl aus. Klicken Sie auf Aktuelle ersetzen, um den Spaltentyp zu ändern.

    Einer der häufigsten von Benutzern durchgeführten Bereinigungsschritte ist das Ändern von Datentypen. In diesem Fall sind die verkauften Einheiten im Dezimalformat angegeben. Es ergibt jedoch keinen Sinn, über 0,2 oder 0,5 verkaufte Einheiten zu sprechen. Deshalb sollen hier ganze Zahlen verwendet werden.

    Screenshot: Ändern einer Dezimalzahl in eine ganze Zahl

  3. Klicken Sie auf die Spalte Segment. Wir möchten die Segmente später im Diagramm einfacher anzeigen können, also formatieren wir die Segmentspalte. Klicken Sie auf der Registerkarte Start auf Format, und klicken Sie dann auf GROSSBUCHSTABEN.

    Screenshot: Ändern von klein zu groß geschriebenen Überschriften

  4. Kürzen Sie den Spaltenname ab, sodass anstatt Month Name (Monatsname) nur noch Month (Monat) angezeigt wird. Doppelklicken Sie auf die Spalte Month Name, und benennen Sie sie ihn Month um.

    Screenshot des Kürzens eines Spaltennamens

  5. Klicken Sie in der Spalte Product (Produkt) auf das Dropdownmenü, und löschen Sie den Inhalt im Feld neben Montana.

    Es ist bekannt, dass das Produkt „Montana“ im letzten Monat eingestellt wurde, weshalb diese Daten aus dem Bericht herausgefiltert werden sollen, um Verwirrungen vorzubeugen.

    Screenshot: Löschen der Werte für das Produkt „Montana“

  6. Sie können nun sehen, dass die einzelnen Transformationen unter Abfrageeinstellungen bei Angewendete Schritte hinzugefügt wurden.

    Screenshot der Liste angewendeter Schritte

  7. Klicken Sie auf der Registerkarte Start auf Close & Apply (Schließen und übernehmen). Die Daten sind bald soweit, um für das Erstellen eines Berichts verwendet zu werden.

    Beachten Sie das Sigmasymbol in der Felderliste. Es bedeutet, dass Power BI diese Felder als numerisch erkannt hat. Power BI kennzeichnet außerdem das Feld „Date“ (Datum) mit einem Kalendersymbol.

    Screenshot der Liste mit Feldern mit numerischen Feldern und einem Datumsfeld

Zusätzliche Gutschrift: Schreiben eines Ausdrucks in DAX

Das Schreiben von Measures und Erstellen von Tabellen in der DAX-Formelsprache ist eine sehr leistungsfähige Option für die Datenmodellierung. In der Power BI-Dokumentation finden Sie viele Informationen zu DAX. Schreiben Sie zunächst einen einfachen Ausdruck, und verknüpfen Sie zwei Tabellen.

  1. Klicken Sie im Menüband Start auf Neue Measure.

    Screenshot eines neuen Measure-Symbols auf dem Menüband Start.

  2. Geben Sie diesen Ausdruck ein, um alle Zahlen in der Spalte „Verkaufte Einheiten“ hinzuzufügen.

    Total Units Sold = SUM(financials[Units Sold])    
    
  3. Klicken Sie zur Bestätigung der Eingabe auf das Häkchen.

    Screenshot des DAX-Ausdrucks „Total Units Sold“.

  4. Wählen Sie nun auf der linken Seite die Ansicht Daten aus.

    Screenshot des Symbols „Datenansicht“

  5. Klicken Sie im Menüband Start auf Neue Tabelle.

    Screenshot des Symbols „Neue Tabelle“

  6. Geben Sie diesen Ausdruck ein, damit eine Tabelle „Kalender“ aller Daten zwischen dem 1. Januar 2013 und dem 31. Dezember 2014 generiert wird.

    Calendar = CALENDAR(DATE(2013,01,01),Date(2014,12,31))    
    
  7. Klicken Sie zur Bestätigung der Eingabe auf das Häkchen.

    Screenshot des DAX-Ausdrucks „Kalender“.

  8. Klicken Sie nun links auf Modellansicht.

    Screenshot des Symbols „Modellansicht“

  9. Ziehen Sie das Feld Datum aus der Tabelle „Financials“ in das Feld Datum in der Kalendar-Tabelle, um die Tabellen miteinander zu verknüpfen, und erstellen Sie eine Beziehung zwischen diesen beiden Tabellen.

    Screenshot einer Beziehung zwischen den Date-Feldern

Erstellen Sie den Bericht.

Nachdem die Daten nun also transformiert und geladen wurden, können Sie Ihren Bericht erstellen. Im Bereich der Felder auf der rechten Seite werden die Felder im von Ihnen erstellten Datenmodell angezeigt.

Schließen Sie nun die Erstellung des Berichts ab. Gehen Sie dabei von Visual zu Visual vor.

Screenshot aller Elemente im Bericht, mit Zahlen versehen

Visual 1: Titel hinzufügen

  1. Klicken Sie im Menüband Einfügen auf Textfeld. Geben Sie „Executive Summary – Finance Report“ (Kurzfassung: Finanzbericht) als Titel ein.

  2. Wählen Sie den eingegebenen Text aus. Legen Sie den Schriftgrad auf 20 und Fettdruck fest.

    Screenshot: Formatieren des Titels

  3. Passen Sie die Größe des Felds so an, dass es in eine Zeile passt.

Visual 2: Profit by Date

Als nächsten Schritt erstellen Sie einen Liniendiagramm, um zu sehen, in welchem Monat und Jahr der höchste Gewinn erzielt wurde.

  1. Ziehen Sie aus dem Bereich der Felder das Feld Profit (Gewinn) auf einen leeren Zeichenbereich des Berichts. In Power BI wird automatisch ein Säulendiagramm mit einer Säule (Profit) angezeigt.

  2. Ziehen Sie das Feld Date in dasselbe Visual. Wenn Sie weiter oben in diesem Artikel in Bonus: Schreiben eines Measures in DAX eine Tabelle „Calendar" (Kalender) erstellt haben, ziehen Sie stattdessen das Feld Date (Datum) aus der Tabelle „Calendar“.

    Power BI aktualisiert das Säulendiagramm, um die Gesamtgewinne der beiden Jahren anzuzeigen.

    Screenshot des Säulendiagramms „Profit by Year“

  3. Klicken Sie im Bereich Felder des Visualisierungsbereichs auf das Dropdownmenü für den Wert für X-Achse. Ändern Sie Datum von Date Hierarchy (Datumshierarchie) in Datum.

    Screenshot: Ändern von „Date Hierarchy“ in „Date“

    Power BI aktualisiert das Säulendiagramm, um Gewinne nach den einzelnen Monaten anzuzeigen.

    Screenshot: Säulendiagramm nach Monaten

  4. Ändern Sie im Visualisierungsbereich den Visualisierungstyp in Liniendiagramm.

    Screentshot: Ändern des Säulen- in ein Balkendiagramm

    Nun können Sie einfach erkennen, dass im Dezember 2014 der höchste Gewinn erzielt werden konnte.

Visual 3: Profit nach Land/Region

Erstellen Sie eine Karte, um zu sehen, welches Land/welche Region die höchsten Gewinne erzielt hat.

  1. Ziehen Sie im Bereich „Felder“ das Feld Country (Land) auf einen leeren Zeichenbereich, um eine Karte zu erstellen.

  2. Ziehen Sie das Feld Profit (Gewinn) auf die Karte.

    Power BI erstellt eine Kartenvisualisierung mit Blasendiagramm, die den relativen Gewinn jedes Standorts darstellt.

    Screenshot: Erstellen eines Kartendiagramms

    Europa scheint dabei im Vergleich zu Nordamerika besser abzuschneiden.

Visual 4: Sales by Product and Segment

Erstellen Sie ein Balkendiagramm, um bestimmen zu können, in welche Unternehmen und Segmente investiert werden sollte.

  1. Ziehen Sie die beiden erstellten Diagramme so, dass sie im oberen Teil des Zeichenbereichs nebeneinander platziert sind. Lassen Sie links auf dem Zeichenbereich etwas Platz frei.

  2. Wählen Sie einen leeren Bereich im unteren Teil des Zeichenbereich Ihres Berichts aus.

  3. Wählen Sie im Bereich „Felder“ die Felder Sales (Umsatz), Product (Produkt) und Segment aus.

    In Power BI wird automatisch ein Säulendiagramm (gruppiert) erstellt.

  4. Ändern Sie die Größe des Diagramms so, dass es groß genug ist, um den Bereich unterhalb der beiden oberen Diagramme abzudecken.

    Screenshot eines gruppierten Säulendiagramms

    Der Schluss liegt nahe, dass das Unternehmen weiterhin in das Produkt „Paseo“ investieren sollte und den Fokus auf die Segmente der kleinen Unternehmen und Behörden legen sollte.

Visual 5: Jahresslicer

Slicer sind ein hilfreiches Tool für das Filtern der Visuals auf einer Berichtsseite auf eine bestimmte Auswahl. Für diesen Fall können zwei verschiedene Slicer erstellt werden, um die Anzeige auf die Leistung pro Monat und Jahr einzugrenzen. Ein Slicer verwendet das Datumsfeld in der ursprünglichen Tabelle. Der andere verwendet die Datumstabelle, die Sie möglicherweise zuvor in diesem Tutorial für den „Bonus“ erstellt haben.

Datenschnitt nach Datum unter Verwendung der ursprünglichen Tabelle

  1. Wählen Sie im Bereich „Felder“ das Feld Date in der Tabelle „Financials“ aus. Ziehen Sie es in den leeren Bereich links neben der Canvas.

  2. Klicken Sie im Visualisierungsbereich auf die Option Slicer.

    Power BI erstellt automatisch einen Slicer für numerische Bereiche.

    Screenshot des Slicers für den numerischen Datumsbereich.

  3. Sie können die Enden zum Filtern ziehen oder den Pfeil in der oberen rechten Ecke auswählen und ihn in einen anderen Slicertyp ändern.

Datenschnitt nach Datum unter Verwendung der DAX-Tabelle

  1. Wählen Sie im Bereich „Felder“ das Feld Date in der Tabelle „Calendar“ aus. Ziehen Sie es in den leeren Bereich links neben der Canvas.

  2. Klicken Sie im Visualisierungsbereich auf die Option Slicer.

  3. Klicken Sie im Bereich „Felder“ des Visualisierungsbereichs auf das Dropdownmenü für Felder. Entfernen Sie die Optionen für Quartal und Tag, sodass nur noch Jahr und Monat angezeigt werden.

    Screenshot: Ändern der Datumshierarchie

  4. Klappen Sie die beiden Jahre auf, und ändern Sie die Größe des Visuals, sodass alle Monate angezeigt werden.

    Screenshot des Slicers für die Datumshierarchie

    Wir verwenden diesen Slicer im fertigen Bericht.

Wenn Ihr Vorgesetzter nun nur die Daten für das Jahr 2013 sehen möchte, können Sie mithilfe des Slicers das Jahr oder einzelne Monate eines Jahres auswählen.

Bonus: Formatieren des Berichts

Wenn Sie den Bericht durch Formatierung noch ansprechender gestalten möchten, finden Sie hier einige einfach durchzuführende Schritte.

Design

  • Ändern Sie das Design über das Menüband Ansicht in Executive.

    Screenshot: Auswahl des Designs „Executive“

Optimieren der Visuals

Nehmen Sie im Bereich „Visualisierungen“ auf der Registerkarte Format die folgenden Änderungen vor.

Screenshot: Registerkarte „Format“ im Bereich „Visualisierungen“

  1. Wählen Sie Visual 2 aus. Ändern Sie im Bereich Titel den Titeltext in „Profit by Month and Year“ (Profit nach Monat und Jahr) und die Textgröße in 16 pt. Legen Sie die Umschaltfläche Schatten auf Ein fest.

  2. Wählen Sie Visual 3 aus. Ändern Sie im Abschnitt Kartenstile das Design in Graustufen. Ändern Sie im Abschnitt Titel die Textgröße in 16 pt. Legen Sie die Umschaltfläche Schatten auf Ein fest.

  3. Wählen Sie Visual 4 aus. Ändern Sie im Abschnitt Titel die Textgröße in 16 pt. Legen Sie die Umschaltfläche Schatten auf Ein fest.

  4. Wählen Sie Visual 5 aus. Legen Sie unter Auswahlsteuerelemente die Option Option „Alles auswählen“ anzeigen auf Ein fest. Erhöhen Sie im Abschnitt Slicerheader die Textgröße auf 16 pt.

Hinzufügen eines Hintergrunds für den Titel

  1. Klicken Sie im Menüband Einfügen auf die Option Formen>Rechteck. Platzieren Sie dieses oben auf der Seite, und ändern Sie die Größe so, dass sie der Breite der Seite und der Höhe des Titels entspricht.

  2. Ändern Sie im Bereich Form formatieren im Bereich Gliederung die Option Transparenz in 100 % .

  3. Ändern Sie im Bereich Füllung die Option Füllfarbe in Designfarbe 5 #6B91C9 (blau).

    Screenshot der Designfarbe 5

  4. Klicken Sie auf der Registerkarte Format auf Eine Ebene nach hinten>In den Hintergrund.

  5. Wählen Sie den Text im Visual 1 aus, also den Titel, und ändern Sie die Schriftfarbe in Weiß.

Hinzufügen eines Hintergrunds für die Visuals 2 und 3

  1. Klicken Sie auf dem Menüband Einfügen auf Formen>Rechteck, und ändern Sie die Größe so, dass es der Höhe und Breite der Visuals 2 und 3 entspricht.
  2. Ändern Sie im Bereich Form formatieren im Bereich Gliederung die Option Transparenz in 100 % .
  3. Legen Sie die Farbe im Abschnitt Füllen auf Weiß, 10 % dunkler fest.
  4. Klicken Sie auf der Registerkarte Format auf Eine Ebene nach hinten>In den Hintergrund.

Fertiger Bericht

Hier sehen Sie, wie der optimierte Bericht endgültig aussieht:

Screenshot des endgültigen, formatieren Berichts

Zusammenfassend kann gesagt werden, dass dieser Bericht die wichtigsten Fragen Ihres Vorgesetzten beantworten kann:

  • In welchem Monat und Jahr konnten die höchsten Gewinne erzielt werden?

    Dezember 2014

  • In welchem Land bzw. in welcher Region ist das Unternehmen am erfolgreichsten?

    In Europa, insbesondere in Frankreich und Deutschland

  • In welches Produkt und Segment sollte das Unternehmen weiter investieren?

    Das Unternehmen sollte weiterhin in das Produkt „Paseo“ investieren und den Fokus auf die Segmente der kleinen Unternehmen und Behörden legen.

Bericht speichern

  • Klicken Sie im Menü Datei auf Speichern.

Veröffentlichen im Power BI-Dienst für die Freigabe

Veröffentlichen Sie Ihren Bericht in Power BI, um ihn für Ihre Vorgesetzten und Kollegen freizugeben. Wenn Sie den Bericht für Kollegen freigeben, die ein Power BI-Konto haben, können diese mit Ihrem Bericht interagieren, Änderungen jedoch nicht speichern.

  1. Klicken Sie in Power BI Desktop im Menüband Start auf die Option Veröffentlichen.

    Möglicherweise müssen Sie sich zuerst beim Power BI-Dienst anmelden. Wenn Sie noch kein Konto haben, können Sie sich für eine kostenlose Testversion registrieren.

  2. Wählen Sie in Power BI ein Ziel aus, z. B. Mein Arbeitsbereich, und klicken Sie auf >Auswählen.

  3. Klicken Sie auf „Name Ihrer Datei“ in Power BI öffnen.

    Screenshot: Öffnen Ihres Berichts in Power BI

    Der fertige Bericht wird im Browser geöffnet.

    Screenshot:Vollständiger Power BI-Bericht im Power BI-Dienst

  4. Zum Freigeben des Berichts klicken Sie am oberen Rand des Berichts auf die Option Freigeben.

    Screenshot: Freigeben Ihres Berichts in Power BI

Nächste Schritte

Weitere Fragen? Wenden Sie sich an die Power BI-Community.