Erste Schritte mit C++ in Visual Studio

Wenn Sie diese exemplarische Vorgehensweise durcharbeiten, werden Sie mit vielen Tools und Dialogfeldern vertraut, die Sie für die Entwicklung von Apps in Visual Studio verwenden können.Sie erstellen eine einfache "Hello, World"-App und lernen dabei die Arbeiten in der integrierten Entwicklungsumgebung (IDE) kennen.

Dieses Thema enthält folgende Abschnitte:

Anmelden bei Visual Studio

Erstellen einer einfachen App

Hinzufügen von Code zu einer App

Debuggen und Testen der App

Erstellen einer Releaseversion der App

Anmelden bei Visual Studio

Wenn Sie Visual Studio zum ersten Mal starten, erhalten Sie die Möglichkeit, sich mit einem Microsoft-Konto, z. B. Live oder Outlook, anzumelden.Durch die Anmeldung können Sie Ihre Einstellungen mit allen Geräten synchronisieren.Weitere Informationen finden Sie unter Anmelden bei Visual Studio.

Nach dem Öffnen von Visual Studio können Sie die drei grundlegenden Teile der IDE sehen: Toolfenster, Menüs und Symbolleisten sowie das Hauptfenster.Mit Schnellstart werden Toolfenster auf der linken und rechten Seite des Anwendungsfensters und die Menüleiste und die Standardsymbolleiste oben angedockt.In der Mitte des Anwendungsfensters befindet sich die Startseite.Wenn Sie eine Projektmappe oder ein Projekt öffnen, werden Editoren und Designer in diesem Bereich angezeigt.

IDE mit angewendeten Visual C++-Einstellungen

Abbildung 1: Visual Studio-IDE

Erstellen einer einfachen App

Wenn Sie eine App in Visual Studio erstellen, erstellen Sie zunächst ein Projekt und eine Projektmappe.Für dieses Beispiel erstellen Sie eine Windows-Konsolen-App.

Erstellen einer Konsolen-App

  1. Wählen Sie in der Menüleiste Datei, Neu, Projekt aus.

    Wählen Sie auf der Menüleiste "Datei", "Neu", "Projekt" aus.

  2. Wählen Sie in der Visual C++ Kategorie die Vorlage Win32-Konsolenanwendung aus, und nennen Sie das Projekt GreetingsConsoleApp.

    Vorlage für eine Win32-Konsolenanwendung

  3. Wenn der Win32-Anwendungs-Assistent angezeigt wird, wählen Sie die Schaltfläche Fertig stellen aus.

    Assistent für Win32-Konsolenanwendung

Das Projekt und die Projektmappe "GreetingsConsoleApp", mit den grundlegenden Dateien für eine Win32-Konsolen-App, werden erstellt und in Projektmappen-Explorer automatisch geladen.Die Datei "GreetingsConsoleApp.cpp" wird im Code-Editor geöffnet.Die folgenden Elemente werden in Projektmappen-Explorer angezeigt:

Abbildung 4: Projektelemente

Dateien für die Projektmappe im Projektmappen-Explorer

Hinzufügen von Code zur Anwendung

Als Nächstes fügen Sie Code hinzu, um das Wort "Hello" im Konsolenfenster anzuzeigen.

Anzeigen von "Hello" im Konsolenfenster

  1. Geben Sie in der Datei "GreetingsConsoleApp.cpp" vor der Zeile return 0; eine Leerzeile und dann den folgenden Code ein:

    cout <<"Hello\n";
    

    Eine rote Wellenlinie wird unter cout angezeigt.Wenn Sie darauf zeigen, wird eine Fehlermeldung angezeigt.

    Fehlertext für "cout"

    Die Fehlermeldung wird auch im Fenster Fehlerliste angezeigt.Sie können das Fenster auch anzeigen, indem Sie in der Menüleiste Ansicht die Option Fehlerliste auswählen.

    cout ist in der Headerdatei <iostream> enthalten.

  2. Um den iostream-Header einzuschließen, geben Sie den folgenden Code nach #include "stdafx.h" ein:

    #include <iostream>
    using namespace std;
    

    Wahrscheinlich haben Sie bemerkt, dass während der Codeeingabe ein Feld mit Empfehlungen für die Zeichen angezeigt wird, die Sie eingegeben haben.Dieses Feld ist Teil von C++-IntelliSense, das Code-Eingabeaufforderungen bietet, darunter Auflistungen der Klassen- oder Schnittstellen-Member sowie der Parameterinformationen.Außerdem können Sie Codeausschnitte verwenden, wobei es sich um vordefinierte Codeblöcke handelt.Weitere Informationen finden Sie unter Verwenden von IntelliSense und Codeausschnitte.

    Die rote Wellenlinie unter cout wird ausgeblendet, wenn Sie den Fehler korrigieren.

  3. Speichern Sie die Änderungen in der Datei.

    Code zum Beheben des cout-Fehlers

Debuggen und Testen der App

Sie können "GreetingsConsoleApp" debuggen, um festzustellen, ob das Wort "Hello" im Konsolenfenster angezeigt wird.

Debuggen der App

  • Starten Sie den Debugger.

    Befehl "Debugging starten" im Menü "Debuggen"

    Die Debugger wird gestartet und führt den Code aus.Das Konsolenfenster (ein separates Fenster, das wie eine Eingabeaufforderung aussieht) wird ein paar Sekunden lang angezeigt, wird jedoch schnell geschlossen, wenn der Debugger anhält.Um den Text anzuzeigen, müssen Sie einen Haltepunkt festlegen, um die Ausführung des Programms zu beenden.

Hinzufügen eines Haltepunktes

  1. Fügen Sie über die Menüleiste in der Zeile return 0; einen Haltepunkt hinzu.Sie können auch einfach in den linken Rand klicken, um einen Haltepunkt zu setzen.

    Befehl "Haltepunkt umschalten" im Menü "Debuggen"

    Am äußeren linken Rand des Editorfensters wird ein roter Kreis neben der Codezeile angezeigt.

  2. Drücken Sie die F5-TASTE, um das Debuggen zu starten.

    Der Debugger wird gestartet, und ein Konsolenfenster mit dem Wort "Hello" wird angezeigt.

    "Hello"-Text im Windows-Befehlseingabeaufforderungsfenster

  3. Drücken Sie UMSCHALT + F5, um den Debugvorgang zu beenden.

Weitere Informationen finden Sie unter Vorbereitung zum Debuggen: Konsolenprojekte.

Erstellen einer Releaseversion der App

Nachdem Sie überprüft haben, dass alles funktioniert, können Sie einen Releasebuild der App vorbereiten.

Bereinigen der Projektmappendateien und Erstellen einer Releaseversion

  1. Löschen Sie in der Menüleiste Zwischendateien und Ausgabedateien, die bei vorherigen Builds erstellt wurden.

    Befehl "Projektmappe bereinigen" im Menü "Erstellen"

  2. Ändern Sie die Buildkonfiguration für GreetingsConsoleApp von Debuggen zu Version.

    Version der Anwendung erstellen

  3. Erstellen Sie die Projektmappe.

    Befehl "Projektmappe erstellen" im Menü "Erstellen"

Herzlichen Glückwunsch, Sie haben diese exemplarischen Vorgehensweise abgeschlossen!Weitere Beispiele zum Durcharbeiten finden Sie unter Visual Studio-Beispiele.

Siehe auch

Konzepte

Exemplarische Vorgehensweise: Erstellen einer einfachen Anwendung mit Visual C# oder Visual Basic

Produktivitätstipps für Visual Studio

Erste Schritte mit Visual Studio

Weitere Ressourcen

Visual Studio-Beispiele