Beheben eines Nichtübereinstimmungs der Websitebenutzer-ID in SharePoint oder OneDrive

Symptome

Wenn Benutzer in Ihrem organization versuchen, mithilfe eines neuen Kontos, das einen Benutzernamen mit einem früheren Konto teilt, auf eine OneDrive- oder SharePoint-Website zuzugreifen, treten mindestens eines der folgenden Probleme auf:

  • Fehlermeldung "Zugriff verweigert"
  • Eine inkonsistente Benutzererfahrung
  • Eine neue OneDrive-Website, deren Suffix an die erwartete URL angefügt ist, z https://contoso-my.sharepoint.com/personal/UserA_Contoso_com1 . B. (das Suffix kann eine Zahl oder eine GUID sein)

Ursache

Diese Probleme treten in der Regel auf, wenn ein Benutzerkonto aus dem Microsoft 365 Admin Center gelöscht wird und dann ein neues Konto mit dem Benutzerprinzipalnamen (UPN) erstellt wird, der vom gelöschten Konto verwendet wurde. Dem neuen Konto wird ein neuer ID-Wert zugewiesen, obwohl der UPN identisch ist. Die UserInfo-Liste für die SharePoint- und OneDrive-Websites, die dem Konto zugeordnet sind, enthält jedoch nur die alte ID. Wenn Benutzer versuchen, mit ihrem neuen Konto auf eine SharePoint- oder OneDrive-Website zuzugreifen, stimmt ihre neue ID nicht mit der ID in der UserInfo-Liste überein. Daher wird ihnen der Zugriff auf die Website verweigert.

Diese Probleme können auch während der Verzeichnissynchronisierung zwischen einer Active Directory-Organisationseinheit (OE) und SharePoint auftreten. Wenn Sich Benutzer bereits bei SharePoint angemeldet haben und später in eine andere Organisationseinheit verschoben werden, können diese Probleme auftreten, wenn die Organisationseinheit mit SharePoint synchronisiert wird.

Lösung

Um diese Probleme zu beheben, führen Sie die Diagnose "Websitebenutzerkonflikt" mithilfe eines Microsoft 365-Administratorkontos (Global Admin oder SharePoint Admin) aus.

Hinweis

  • Diese Diagnose ist für die Umgebungen GCC High und DoD sowie für „Microsoft 365 operated by 21Vianet“, nicht verfügbar.
  • Bevor Administratoren die Diagnose ausführen, um die Probleme für OneDrive-Websites zu beheben, müssen sie sicherstellen, dass der Benutzername des neuen Benutzerkontos mit dem alten Konto übereinstimmt. Administratoren ist es untersagt, OneDrive-Websites zu verbinden, die sich zuvor möglicherweise im Besitz eines anderen Benutzerkontos befanden. 
  • Wenn die Diagnose ein Problem im Zusammenhang mit einer OneDrive-Website erfolgreich behoben hat, kann es ungefähr 24 Stunden dauern, bis die Änderungen wirksam werden. Dieser Zeitraum umfasst das Aktualisieren der OneDrive-Kachel, um auf die richtige Website zu verweisen, und das Recyceln zusätzlicher OneDrive-Websites.

Wählen Sie die folgende Schaltfläche Tests ausführen, wodurch die Diagnose im Microsoft 365 Admin Center angezeigt wird. Die Diagnose führt eine Vielzahl von Prüfungen für interne oder externe Benutzende und Gäste durch, die versuchen, auf SharePoint- und OneDrive-Websites zuzugreifen.

Wenn Sie dazu aufgefordert werden, geben Sie die folgenden Informationen an:

  • Das betroffene Benutzerkonto, z. B. UserA@contoso.com
  • Die ursprüngliche Website-URL, z. B. https://contoso-my.sharepoint.com/personal/UserA_Contoso_com

Häufige Szenarien

Die Diagnose "Standortbenutzerkonflikt" kann die folgenden häufigen Probleme beheben, die auftreten können, wenn ein neues Konto mithilfe des UPN erstellt wird, der von einem gelöschten Konto verwendet wurde.

Ein Benutzer wird zu einer neuen OneDrive-Website weitergeleitet, deren Suffix an die erwartete URL angefügt ist.

Wenn ein neues Benutzerkonto erstellt wird, wird ihm eine neue OneDrive-Website zugewiesen. Wenn ein Benutzerkonto gelöscht wird, wird die dem Konto zugewiesene OneDrive-Website nicht sofort gelöscht. Wenn also ein neues Benutzerkonto mit dem UPN eines gelöschten Kontos erstellt wird, hat die neue OneDrive-Website, die dem neuen Konto zugewiesen ist, dieselbe URL wie die alte OneDrive-Website mit einem hinzugefügten Suffix. Dieses Suffix ist entweder eine Zahl oder eine GUID.

Wenn das neue Benutzerkonto dieselbe OneDrive-Website verwenden soll, die dem alten Konto zugewiesen wurde, überprüft die Diagnose, ob dem Benutzer der Besitz der ursprünglichen Website zugewiesen werden kann. Nachdem die Berechtigungen des Benutzers erfolgreich überprüft wurden, bietet die Diagnose an, den Benutzer erneut mit seiner ursprünglichen Website zu verbinden und die neue aktive Website mit dem Suffix wie wiederzuverwenden https://contoso-my.sharepoint.com/personal/UserA_Contoso_com1.

Wenn Sie zu einem späteren Zeitpunkt auf Inhalte auf der neuen OneDrive-Website zugreifen müssen, können Sie das gelöschte OneDrive wiederherstellen.

Zugriff auf eine OneDrive-Website verweigert

Wenn einem Benutzer der Zugriff auf seine alte OneDrive-Website verweigert wird, nachdem ein neues Konto für sie erstellt wurde, wird das Profil des Benutzers durch die Diagnose neu konfiguriert. Anschließend wird der Benutzer erneut mit seiner alten OneDrive-Website verbunden, um das Zugriffsproblem zu beheben.

Hinweis

Administratoren können dieses Problem nicht beheben, indem sie die Besitzer der OneDrive-Website manuell aktualisieren oder die Benutzerprofileigenschaften bearbeiten, die der OneDrive-Website zugeordnet sind. Die Diagnose ist die einzige empfohlene Lösung, um dieses Problem zu beheben.

Nicht übereinstimmende Benutzer-ID auf SharePoint-Websites oder OneDrive-Websites, die nicht zum Benutzer gehören

Wenn die Diagnose einen Konflikt mit der Benutzer-ID in der UserInfo-Liste erkennt, wird angeboten, die alte ID zu entfernen. Nachdem Sie akzeptiert haben und die alte ID entfernt wurde, weisen Sie dem neuen Benutzerkonto die entsprechenden Berechtigungen für die SharePoint-Website zu.

Hinweis: Wenn Sie dieses Problem manuell beheben möchten, müssen Sie das alte Benutzerkonto aus der UserInfo-Liste entfernen und dann Berechtigungen für das neue Benutzerkonto erteilen.

Weitere Informationen

Weitere Informationen zu Zugriffsproblemen in SharePoint und OneDrive finden Sie unter Fehler "Zugriff verweigert" oder "Sie benötigen Eine Berechtigung" in SharePoint Online und OneDrive.