AKS-Clusterupgrade schlägt aufgrund von NSG-Regeln fehl
In diesem Artikel wird erläutert, wie Sie Probleme beheben, wenn das Upgrade Ihres Azure Kubernetes Service-Clusters (AKS) aufgrund von NSG-Regeln (Netzwerksicherheitsgruppen) fehlschlägt.
Voraussetzungen
Für diesen Artikel ist Die Azure CLI-Version 2.0.65 oder eine höhere Version erforderlich. Führen Sie aus, um die Versionsnummer zu az --version
ermitteln. Wenn Sie die Azure CLI installieren oder aktualisieren müssen, lesen Sie Installieren der Azure CLI.
Ausführlichere Informationen zum Upgradeprozess finden Sie im Abschnitt "Upgraden eines AKS-Clusters" unter Upgraden eines Azure Kubernetes Service (AKS)-Clusters.
Problembeschreibung
Ein AKS-Clusterupgrade schlägt fehl, und Sie erhalten eine Fehlermeldung, die angibt, dass eine NSG-Regel beteiligt ist.
Ursache
Eine NSG-Regel verhindert, dass der Cluster erforderliche Ressourcen herunter lädt.
Lösung
Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:
Führen Sie aus
az network nsg list -o table
, und suchen Sie dann die NSG, die mit Ihrem Cluster verknüpft ist. Die NSG befindet sich in einer Ressourcengruppe namensMC_<RG name>_<your AKS cluster name>
.Führen Sie den folgenden Befehl aus, um die NSG-Regeln anzuzeigen:
az network nsg rule list --resource-group <Rg name> --nsg-name <nsg name> --include-default -o table
Der folgende Screenshot zeigt die Standardregeln.
Wenn Sie über die Standardregeln verfügen, überspringen Sie diesen Schritt. Andernfalls überarbeiten und entfernen Sie die Regeln, die den Internetdatenverkehr blockieren. Führen Sie dann den folgenden Befehl aus, um den AKS-Cluster auf dieselbe Version zu aktualisieren, auf die Sie zuvor ein Upgrade versucht haben. Dieser Prozess löst eine Abstimmung aus.
az aks upgrade --resource-group <ResourceGroupName> --name <AKSClusterName> --kubernetes-version <KUBERNETES_VERSION>
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.