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Gilt für: ✔️ Windows-VMs
Ursprüngliche KB-Nummer: 4010137
Dieser Artikel enthält eine Lösung für ein Problem, bei dem windows-VM nicht mit Fehlercode 0xc0000098 beginnt.
Symptome
Windows wird nicht gestartet. Stattdessen generiert das System einen Fehler, der wie folgt aussieht:
Datei: \<BINARY>
Status: 0xc0000098
Info: Windows konnte nicht geladen werden, da ein kritischer Systemtreiber fehlt oder beschädigt ist.
In dieser Meldung stellt BINARY> die tatsächliche Binärdatei dar, <die gefunden wird.
Ursache
Dieses Problem tritt auf, wenn eine Binärdatei aus einer anderen Windows-Version als dem Betriebssystem des virtuellen Computers stammt.
Lösung
Tipp
Wenn Sie über eine aktuelle Sicherung der VM verfügen, können Sie versuchen, die VM aus der Sicherung wiederherzustellen, um das Startproblem zu beheben.
Führen Sie die folgenden Schritte aus, um das Problem zu beheben.
Schritt 1: Anfügen des Betriebssystemdatenträgers des virtuellen Computers als Datenträger an einen anderen virtuellen Computer
- Löschen Sie den virtuellen Computer (VM). Stellen Sie sicher, dass Sie die Option "Datenträger beibehalten" auswählen, wenn Sie dies tun.
- Fügen Sie den Betriebssystemdatenträger einer anderen VM (VM, auf der Sie die Problembehandlung ausführen) als Datenträger an. Weitere Informationen finden Sie unter Anfügen eines Datenträgers an eine Windows VM im Azure-Portal.
- Stellen Sie eine Verbindung mit der Problembehebungs-VM her. Öffnen Sie Computerverwaltung>Datenträgerverwaltung. Stellen Sie sicher, dass der Betriebssystemdatenträger online ist und dass den Partitionen Laufwerksbuchstaben zugewiesen sind.
Schritt 2: Reparieren oder Ersetzen der Binärdatei
Reparieren oder ersetzen Sie die System-Binärdatei (.sys), indem Sie die folgenden Schritte ausführen:
Reparieren der beschädigten Binärdatei
Öffnen Sie eine CMD-Eingabeaufforderung mit erhöhten Rechten, und führen Sie "chkdsk" auf dem Datenträger aus:
chkdsk <drive-letter>: /F
Ersetzen der beschädigten Binärdatei
Suchen Sie auf dem angehängten Datenträger nach dem Speicherort der Binärdatei, die in der Fehlermeldung angezeigt wird.
Benennen Sie die Datei von binärname>.sys in< binärname.sys.old um>.<
Navigieren Sie auf dem angefügten Datenträger zum Ordner \Windows\WinSxS . Suchen Sie dann nach der Binärdatei, die in der Fehlermeldung angezeigt wird. Verwenden Sie dazu den folgenden Befehl in einer Eingabeaufforderung:
dir <binary-name> /s
Der Befehl listet alle verschiedenen Versionen der Binärdatei zusammen mit dem Erstellungsdatum auf. Kopieren Sie die neueste Version der Binärdatei in den Ordner \Windows\System32\Drivers , indem Sie den folgenden Befehl ausführen:
copy <drive>:\Windows\WinSxS\<directory-where-file-is>\<binary-name>.sys <drive>:\Windows\System32\Drivers\
Sehen Sie sich zum Beispiel die folgende Konsolenausgabe an:
E:\Windows\WinSxS>dir ACPI.sys /s Volume in drive E has no label. Volume Serial Number is A0B1-C2D3 Directory of E:\Windows\WinSxS\amd64_acpi.inf_0123456789abcdef_6.3.9600.16384_none_cdef0123456789ab 11/21/2014 07:48 PM 94,989 acpi.sys 1 File(s) 94,989 bytes Directory of E:\Windows\WinSxS\amd64_acpi.inf_0123456789abcdef_6.3.9600.16384_none_89abcdef01234567 11/21/2014 07:48 PM 119,547 acpi.sys 1 File(s) 119,547 bytes Directory of E:\Windows\WinSxS\amd64_acpi.inf_0123456789abcdef_6.3.9600.16384_none_456789abcdef0123 11/21/2014 04:06 PM 533,824 acpi.sys 1 File(s) 533,824 bytes Total Files Listed: 3 File(s) 748,360 bytes 0 Dir(s) 123,967,512,576 bytes free E:\Windows\WinSxS>copy E:\Windows\WinSxS\amd64_acpi.inf_0123456789abcdef_6.3.9600.16384_none_cdef0123456789ab\acpi.sys E:\Windows\System32\Drivers\ 1 file(s) copied. E:\Windows\WinSxS>
Notiz
Wenn die System-Binärdatei nicht umbenannt werden kann, übernehmen Sie den Besitz der Datei. Mit dieser Aktion erhalten Sie vollzugriff auf diese Datei.
Die Beispielkonsolenausgabe zeigt die Lautstärke E als Beispiel an. Der tatsächliche Buchstabe sollte dem fehlerhaften Laufwerk entsprechen (das Betriebssystemlaufwerk, das als Datenlaufwerk mit der VM zur Problembehandlung verbunden ist).
Wenn die neueste Binärdatei nicht funktioniert, können Sie die vorherige Dateiversion ausprobieren, um eine frühere Systemaktualisierungsstufe für diese Komponente zu erhalten.
Wenn die einzige Binärdatei, die in diesem Schritt zurückgegeben wird, mit der Datei übereinstimmt, die Sie auf der betroffenen VM ersetzen möchten, und wenn beide Dateien dieselbe Größe und denselben Zeitstempel haben, können Sie die beschädigte Datei ersetzen, indem Sie sie von einer anderen funktionierenden VM mit demselben Betriebssystem und, wenn möglich, derselben Systemaktualisierungsstufe kopieren.
Trennen Sie den reparierten Datenträger von der VM, auf der Sie die Problembehandlung ausführen. Erstellen Sie dann einen virtuellen Computer vom Betriebssystemdatenträger.
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