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Die E-Mail-Adresse der Warteschlange wurde in Dynamics 365 nicht ordnungsgemäß aufgelöst.

In diesem Artikel wird ein Problem in Dynamics 365 behandelt, bei dem E-Mails, die an eine Warteschlange gesendet werden, die E-Mail-Adresse der Warteschlange im Feld An als nicht aufgelöst oder nicht erkannt anzeigen.

Symptome

Wenn E-Mails in Dynamics 365 an eine Warteschlange gesendet werden, wird die E-Mail-Adresse der Warteschlange im Feld An als nicht aufgelöst oder nicht erkannt angezeigt. Das System verarbeitet jedoch weiterhin die E-Mail und generiert Fälle wie erwartet.

Ursache

Dieses Problem tritt auf, wenn mehrere Datensätze in Dynamics 365 dieselbe E-Mail-Adresse gemeinsam nutzen. Das System identifiziert mehrere Übereinstimmungen und könnte zufällig eine davon auswählen. Daher wird die E-Mail-Adresse als ungelöst oder nicht erkannt angezeigt.

Beschluss

Gehen Sie folgendermaßen vor, um das Problem zu beheben:

  1. Verwenden Sie die folgende OData-Abfrage (Open Data Protocol), um doppelte E-Mail-Adressen im System zu finden. Diese Abfrage gibt alle Datensätze (Warteschlangen, Konten, Kontakte, Leads oder benutzerdefinierte Datensätze) zurück, die dieselbe E-Mail-Adresse verwenden.

    https://contoso.api.crm.dynamics.com/api/data/v9.1/emailsearches?$filter=emailaddress eq 'email@example.com'

    Hinweis

    Ersetzen Sie die Organisations-URL und die E-Mail-Adresse in der Abfrage so, dass sie ihrer Umgebung entspricht.

  2. Entfernen oder Aktualisieren doppelter E-Mail-Adressen:

    1. Ändern Sie die E-Mail-Adressen in doppelten Datensätzen, um sicherzustellen, dass jede E-Mail-Adresse für alle Datensätze eindeutig ist.

    2. Führen Sie nach dem Aktualisieren der E-Mail-Adressen die Abfrage erneut aus, und stellen Sie sicher, dass Duplikate nicht mehr im Abfrageergebnis angezeigt werden.

      Wenn Duplikate in den Abfrageergebnissen beibehalten werden, kann die Aktualisierung der E-Mail-Suchtabelle verzögert werden. Derzeit gibt es keine Methode, um eine sofortige Aktualisierung der E-Mail-Suchtabelle zu erzwingen.

  3. Passen Sie die Dynamics 365-Systemeinstellungen an:

    1. Navigieren Sie in Dynamics 365 zu Erweiterte Einstellungen>Einstellungen>Verwaltung>E-Mail.

    2. Suchen Sie die Felder "Auf", "cc", "bcc" als nicht aufgelöste Werte, wenn mehrere Übereinstimmungen in der Einstellung "Eingehende E-Mails" gefunden werden .

    3. Legen Sie die Einstellung auf "Nein" fest, um sicherzustellen, dass das System E-Mail-Adressen ordnungsgemäß auflösen kann, wenn nur ein übereinstimmener Datensatz vorhanden ist.

    Von Bedeutung

    Wenn die Einstellung auf "Ja" festgelegt ist, löst das System keine E-Mail-Adressen mit mehreren Übereinstimmungen auf. Diese E-Mail-Adressen werden rot markiert, sodass Sie sie manuell in einen bestimmten Datensatz auflösen müssen.