Eine OSD-Tasksequenz wird nicht fortgesetzt, nachdem Windows Setup oder ein direktes Upgrade abgeschlossen wurde.

Ursprüngliche Produktversion: Configuration Manager (Current Branch), System Center Configuration Manager 2012 R2
Ursprüngliche KB-Nummer: 4494015

In diesem Artikel wird ein Problem behoben, bei dem eine Tasksequenz nicht fortgesetzt wird, nachdem Windows Setup oder ein direktes Upgrade abgeschlossen wurde, wenn während der Windows-Bereitstellung ein OEM-Product Key verwendet wird.

Symptome

Wenn Sie eine Tasksequenz für die Betriebssystembereitstellung in Configuration Manager ausführen, treten die folgenden Probleme auf:

  • Die Tasksequenz Aktualisieren oder Neuer Computer wird nicht fortgesetzt, nachdem Windows Setup während des Schritts Windows und ConfigMgr setup abgeschlossen wurde.

    Der folgende Eintrag wird in der %windir%\panther\unattendGC\Setupact.log Datei protokolliert:

    [windeploy.exe] OEM-Lizenz erkannt, wird nicht ausgeführt SetupComplete.cmd

  • Eine Tasksequenz für ein direktes Upgrade wird nicht fortgesetzt, nachdem das direkte Upgrade während des Schritts Betriebssystem aktualisieren abgeschlossen wurde.

    In der %windir%\panther\unattendGC\Setupact.log Datei wird Folgendes protokolliert:

    [windeploy.exe] Clientbetriebssystem erkannt: 1
    [windeploy.exe] OEM-Lizenzierung erkannt: 1
    [windeploy.exe] EnterpriseS oder Enterprise oder EnterpriseSN oder EnterpriseN Edition erkannt: 0
    [windeploy.exe] Client OS edition and OEM license detected and no enterprise edition detected, will not run SetupComplete.cmd
    [windeploy.exe] Die Ausführung des Setupcomplete.cmd ist nicht zulässig, wird nicht SetupComplete.cmd

Diese Probleme treten in der Regel auf, wenn Sie eine Nicht-Unternehmensedition von Windows bereitstellen, z. B. Windows Professional Edition, Windows Embedded oder Windows IoT.

Ursache

Diese Probleme treten auf, weil während der Windows-Bereitstellung ein OEM-Product Key verwendet wird. Wenn ein OEM-Product Key verwendet wird, wird Setupcomplete.cmd deaktiviert. Dieses Verhalten tritt sowohl in Windows 8.1 als auch in Windows 10 auf. Sehen Sie sich die folgenden Informationen unter Windows-Bereitstellungsprobleme an:

  • [September 2012] Änderungen an der Out-Of-Box-Benutzeroberfläche (OOBE)

    Oobe.cmd und Setupcomplete.cmd sind deaktiviert, wenn ein OEM-Product Key verwendet wird. Dadurch soll sichergestellt werden, dass Endbenutzer die Startseite so schnell wie möglich erreichen. Wenn Sie über Tools oder Dienste verfügen, die diese Infrastruktur verwenden, müssen diese in Aufgaben geändert werden, die nach der Windows-Willkommensseite ausgeführt werden.

SetupComplete.cmd ist ein benutzerdefiniertes Skript, das während oder nach dem Windows Setup-Prozess ausgeführt wird. Es enthält Befehle zum Neustarten der Configuration Manager Tasksequenz, nachdem Windows Setup abgeschlossen wurde. Wenn SetupComplete.cmd deaktiviert ist, kann die Tasksequenz nach Abschluss von Windows Setup nicht fortgesetzt werden.

Lösung

Um das Problem zu beheben, geben Sie die KMS-Clienteinrichtungsschlüssel an den Speicherorten an, an denen der OEM-Product Key für die Version von Windows angegeben ist, die Sie bereitstellen möchten. Geben Sie beispielsweise den KMS-Clientsetupschlüssel im Schritt Windows-Einstellungen anwenden oder Betriebssystem aktualisieren an.

Wenn der OEM-Product Key verwendet werden muss, führen Sie zusätzlich zum Angeben des KMS-Clienteinrichtungsschlüssels die folgenden Schritte aus:

  1. Fügen Sie den Schritt Befehlszeile ausführen nach dem Schritt Windows einrichten und ConfigMgr in einer Tasksequenz Aktualisieren oder neuer Computer oder nach dem Schritt Betriebssystem aktualisieren in einer Tasksequenz für direktes Upgrade hinzu.
  2. Verwenden Sie im Schritt Befehlszeile ausführenchangepk.exe oder slmgr.vbs , um den OEM-Schlüssel in der Befehlszeile anzugeben.

Wenn der OEM-Schlüssel im BIOS oder in der Firmware des Geräts verwendet werden muss, führen Sie den folgenden PowerShell-Befehl aus, um den Schlüssel abzurufen:

Get-CIMInstance SoftwareLicensingService | Select -ExpandProperty OA3xOriginalProductKey

OEM-Product Key-Standorte

Der OEM-Product Key kann an den folgenden Stellen angegeben werden:

  • In einer Tasksequenz Aktualisieren oder Neuer Computer :
    • Gehen Sie im Schritt Windows-Einstellungen anwenden vor .
    • In einer benutzerdefinierten Antwortdatei (Unattend.xml). Diese Datei wird normalerweise im Schritt Betriebssystem anwenden angegeben.
    • Über Variablen wie OSDProductKey oder ProductKey (in einer MDT-integrierten Tasksequenz).
  • In einer Tasksequenz für ein direktes Upgrade :
    • Führen Sie im Schritt Upgrade Operating System (Betriebssystem aktualisieren ) aus.
    • Über die OSDSetupAdditionalUpgradeOptions Variable mithilfe der Befehlszeilenoption /PKey .

Der OEM-Product Key kann auch automatisch vom Windows Setup aus dem BIOS oder der Firmware des Geräts abgerufen werden. In diesem Fall wird der folgende Eintrag in der %windir%\panther\Setupact.log Datei protokolliert:

MOUPG ProductKey: Product Key in Digital Marker gefunden.
MOUPG ProductKey: Product Key für Image wird überprüft.
SPValidateProductKey: Aufrufen von PidGenX
MOUPG ProductKey: Product Key mit pkey edition = [Professional].
MOUPG ProductKey: Übereinstimmende Installation von Wim für exakte Editionen
MOUPG ProductKey: Entspricht Install Wim.
MOUPG ProductKey: Matched Professional mit Professional
MOUPG ProductKey: Übereinstimmende Install Wim: Gefunden [1] übereinstimmende Images.
MOUPG ProductKey: Extrahieren von Eula
MOUPG ProductKey: Product Key wurde erfolgreich überprüft.
MOUPG ProductKey: Product EditionID = Professional
MOUPG ProductKey: Product InstallChannel = OEM
MOUPG ProductKey: Eula = C:\$WINDOWS.~BT\Sources\Panther\<file>.tmp
MOUPG ProductKey: Gültiger Product Key gefunden = [TRUE].