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Ursprüngliche Produktversion: Configuration Manager (aktueller Zweig), System Center Configuration Manager 2012 R2
Ursprüngliche KB-Nummer: 4494015
In diesem Artikel wird ein Problem gelöst, bei dem eine Tasksequenz nicht fortgesetzt wird, nachdem Windows Setup oder ein In-Place-Upgrade abgeschlossen wurde, wenn während der Windows-Bereitstellung ein OEM-Product Key verwendet wird.
Symptome
Wenn Sie eine Tasksequenz für die Betriebssystembereitstellung in Configuration Manager ausführen, treten die folgenden Probleme auf:
Eine Tasksequenz "Refresh" oder "Neuer Computer" wird nicht fortgesetzt, nachdem das Windows Setup während des Schritts Windows einrichten und ConfigMgr konfigurieren abgeschlossen wurde.
Der folgende Eintrag wird in der
%windir%\panther\unattendGC\Setupact.logDatei protokolliert:[windeploy.exe] OEM-Lizenz erkannt, daher wird SetupComplete.cmd nicht ausgeführt
Eine Tasksequenz für ein In-Place-Upgrade wird nach Abschluss des In-Place-Upgrades während des Schritts zum Upgrade des Betriebssystems nicht fortgesetzt.
Folgendes wird in der
%windir%\panther\unattendGC\Setupact.logDatei protokolliert:[windeploy.exe] Clientbetriebssystem erkannt: 1
[windeploy.exe] OEM-Lizenzierung erkannt: 1
[windeploy.exe] EnterpriseS, Enterprise, EnterpriseSN oder EnterpriseN Edition erkannt: 0
[windeploy.exe] Client-OS-Edition und OEM-Lizenz erkannt, jedoch keine Enterprise-Edition erkannt, SetupComplete.cmd wird nicht ausgeführt.
[windeploy.exe] Es ist nicht zulässig, die SetupComplete.cmd auszuführen. Die SetupComplete.cmd wird nicht ausgeführt.
Diese Probleme treten in der Regel auf, wenn Sie eine nichtterprise Edition von Windows bereitstellen, z. B. Windows Professional Edition, Windows Embedded oder Windows IoT.
Ursache
Diese Probleme treten auf, da während der Windows-Bereitstellung ein OEM-Product Key verwendet wird. Wenn ein OEM-Product Key verwendet wird, wird Setupcomplete.cmd deaktiviert. Dieses Verhalten tritt in allen derzeit unterstützten Versionen von Windows auf. Weitere Informationen finden Sie unter Windows-Bereitstellungsprobleme:
[September 2012] Änderungen in der Out-Of-Box-Erfahrung (OOBE)
Oobe.cmd und Setupcomplete.cmd werden deaktiviert, wenn ein OEM-Product Key verwendet wird. Dadurch wird sichergestellt, dass Endbenutzer den Start so schnell wie möglich erreichen. Wenn Sie über Tools oder Dienste verfügen, die diese Infrastruktur verwenden, müssen diese in Aufgaben geändert werden, die nach der Out-of-Box-Erfahrung auftreten.
SetupComplete.cmd ist ein benutzerdefiniertes Skript, das während oder nach dem Windows Setup-Prozess ausgeführt wird. Es enthält Befehle, um die Configuration Manager-Tasksequenz neu zu starten, nachdem Windows Setup abgeschlossen wurde. Wenn SetupComplete.cmd deaktiviert ist, kann die Tasksequenz nach Abschluss von Windows Setup nicht fortgesetzt werden.
Lösung
Um das Problem zu beheben, geben Sie die KMS-Clientsetupschlüssel an den Stellen an, an denen der OEM-Product Key für die Windows-Version angegeben ist, die Sie bereitstellen möchten. Geben Sie z. B. den KMS-Clientsetupschlüssel im Schritt "Windows-Einstellungen anwenden" oder im Schritt "Betriebssystem aktualisieren " an.
Wenn der OEM-Product Key verwendet werden muss, führen Sie zusätzlich zur Angabe des KMS-Clientsetupschlüssels die folgenden Schritte aus:
- Fügen Sie einen Run Command Line-Schritt nach dem Setup Windows und ConfigMgr-Schritt in einer Aktualisieren- oder Neuer Computer-Tasksequenz hinzu oder nach dem Upgrade Operating System-Schritt in einer Direktes Upgrade-Tasksequenz.
- Verwenden Sie im Schritt "Befehlszeile ausführen" changepk.exe oder slmgr.vbs, um die OEM-Taste in der Befehlszeile anzugeben.
Wenn der OEM-Schlüssel im BIOS oder der Firmware des Geräts verwendet werden muss, führen Sie den folgenden PowerShell-Befehl aus, um den Schlüssel abzurufen:
Get-CIMInstance SoftwareLicensingService | Select -ExpandProperty OA3xOriginalProductKey
OEM Product Key-Standorte
Der OEM-Product Key kann an den folgenden Speicherorten angegeben werden:
- In einer Tasksequenz "Aktualisieren" oder "Neuer Computer ":
- Im Schritt "Windows-Einstellungen anwenden".
- In einer benutzerdefinierten Antwortdatei (Unattend.xml). Diese Datei wird normalerweise im Schritt "Betriebssystem anwenden" angegeben.
- Durch Variablen wie
OSDProductKeyoderProductKey(in einer MDT-integrierten Tasksequenz).
- In einer Tasksequenz für ein In-Place-Upgrade:
- Im Schritt 'Betriebssystem-Upgrade'.
- Durch die
OSDSetupAdditionalUpgradeOptionsVariable mithilfe der/PKeyBefehlszeilenoption.
Der OEM-Product Key kann auch automatisch von Windows Setup über das BIOS oder die Firmware des Geräts abgerufen werden. In diesem Fall wird der folgende Eintrag in der %windir%\panther\Setupact.log Datei protokolliert:
MOUPG ProductKey: Product Key in Digital Marker gefunden.
MOUPG ProductKey: Überprüfung des Produktschlüssels für das Image.
SPValidateProductKey: Aufrufen von PidGenX
MOUPG ProductKey: Product Key mit Pkey-Edition = [Professional].
MOUPG ProductKey: Übereinstimmende Installation Wim für genaue Editionen
MOUPG ProductKey: Übereinstimmendes Installations-Wim.
MOUPG ProductKey: Übereinstimmung Professional mit Professional
MOUPG ProductKey: Matching Install Wim: [1] übereinstimmende Abbilder gefunden.
MOUPG ProductKey: Extrahieren von Eula
MOUPG ProductKey: Product Key wurde erfolgreich überprüft.
MOUPG ProductKey: Product EditionID = Professional
MOUPG ProductKey: Produkt Installationskanal = OEM
MOUPG ProductKey: Eula = C:\$WINDOWS.~BT\Sources\Panther\<file>.tmp
MOUPG ProductKey: Gültiger Product Key gefunden = [TRUE].