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So entfernen Sie das Gerät eines deaktivierten Microsoft Entra-Benutzers aus Intune

In diesem Artikel wird erläutert, wie Sie ein verwaistes Gerät in Intune entfernen, wenn sein Besitzer aus der Microsoft Entra-ID gelöscht wurde. In diesem Szenario wird der Benutzerprinzipalname (User Principal Name, UPN) des Geräts in Intune als "Keine" aufgeführt.

Problembeschreibung

Wenn Sie ein registriertes Gerät im Microsoft Intune Admin Center unter "Alle Geräte"> anzeigen, sehen Sie, dass der UPN keine ist.

Ursache

Dieses Problem tritt auf, wenn ein Administrator einen Benutzer aus der Microsoft Entra-ID entfernt oder löscht, bevor er sein registriertes Gerät in Microsoft Intune löscht. Sobald der Benutzer aus der Microsoft Entra-ID entfernt wurde, werden die Intune-Informationen für diesen Benutzer nicht verfügbar, und der UPN für sein registriertes Gerät zeigt "Keine" an.

Lösung

Ein Skript ist verfügbar, das ein verwaistes, intune verwaltetes Gerät entfernt, wenn der Besitzer aus der Microsoft Entra-ID entfernt wurde. Das Skript erfordert, dass Sie über den UPN des aktiven oder gelöschten Benutzers verfügen. Sie können das Skript (RemoveIntuneDevice.ps1) von der folgenden Microsoft-Website herunterladen:
https://github.com/patlewis-MSFT/RemoveIntuneDevice

Voraussetzungen

  • Der Papierkorb der Microsoft Entra-ID muss aktiviert sein, bevor Sie ein Gerät für einen gelöschten Benutzer löschen. Weitere Informationen zur Microsoft Entra Connect-Synchronisierung: Ad-Papierkorb aktivieren.

  • Der angemeldete Benutzer muss über die entsprechenden Graph-Berechtigungen in Intune verfügen, bevor Sie das Skript ausführen. Weitere Informationen finden Sie im Abschnitt "Intune-Berechtigungsbereiche " unter Verwendung der Microsoft Entra-ID für den Zugriff auf die Intune-APIs in Microsoft Graph.

  • Installieren Sie das Microsoft Graph PowerShell-Modul, indem Sie das PowerShell-Modul mit erhöhten Rechten ausführen Install-Module Microsoft.Graph oder Install-Module Microsoft.Graph.Beta an einer PowerShell-Eingabeaufforderung mit erhöhten Rechten ausführen.

  • Sie müssen über einen Intune-Mandanten verfügen, der die Azure-Portal unterstützt, indem Sie über eine Produktions- oder Testlizenz verfügen. Weitere Informationen zur Einführung in Microsoft Intune finden Sie im Azure-Portal.

  • Die Verwendung der Microsoft Graph-APIs zum Konfigurieren von Intune-Steuerelementen und -Richtlinien erfordert eine Intune-Lizenz.

  • Sie müssen über ein Konto verfügen, das über Berechtigungen zum Verwalten des Intune-Diensts verfügt.

  • Sie müssen PowerShell 5.0 unter Windows 10 x64 verwenden (PowerShell 4.0 ist eine Mindestanforderung für die ordnungsgemäße Funktion der Skripts.)

    Notiz

    Für PowerShell 4.0 müssen Sie über das PowershellGet-Modul verfügen, um die Funktion "Install-Module " zu aktivieren. Eine erstmalige Verwendung dieser Skripts erfordert einen globalen Administrator des Mandanten, um die Berechtigungen der Anwendung zu akzeptieren.

  • Wenn Sie eine Fehlermeldung erhalten, die besagt, dass Skripts auf Ihrem Computer deaktiviert sind, müssen Sie das Skript durch Ausführen des Set-ExecutionPolicy Cmdlets aktivieren. Weitere Informationen finden Sie unter Set-ExecutionPolicy.

Ausführen des Skripts

Nachdem die erforderlichen Komponenten installiert oder erfüllt wurden, führen Sie die folgenden Schritte aus, um das Skript zu verwenden:

  1. Laden Sie die Skriptdatei RemoveIntuneDevice.ps1 auf Ihren lokalen Windows-Computer herunter.
  2. Führen Sie PowerShell mit erhöhten Rechten aus.
  3. Navigieren Sie zu dem Ordner, in den Sie RemoveIntuneDevice.ps1 kopiert haben, und geben Sie dann Folgendes ein: .\RemoveIntuneDevice.ps1.
  4. Folgen Sie den Anweisungen zur Authentifizierung und zum Abrufen des UPN des Besitzers oder des Geräts des vorherigen Besitzers.