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Dieser Artikel enthält Lösungen und Problemumgehungen für mehrere anmeldebezogene Probleme in Power Automate für Desktop.
Allgemeine Anmelde- oder Abmeldeprobleme
Power Automate für Desktop verwendet eine Datei namens "msalcache.bin3", um Token zu erwerben und Benutzer zu authentifizieren.
Wenn beim Anmelden oder Abmelden Fehler auftreten, entfernen Sie alle gespeicherten Token, indem Sie diese Datei löschen.
Um die Datei zu löschen, navigieren Sie zu %localappdata%\Microsoft\Power Automate Desktop\Cache\MSI
MSI-Installationen oder %localappdata%\Microsoft\Power Automate Desktop\Cache\Store
für Microsoft Store-Installationen.
Notiz
Wenn der Ordner AppData in Ihrem Benutzerordner nicht sichtbar ist, versuchen Sie versteckte Dateien anzuzeigen.
Schließen Sie nach dem Löschen der Datei "msalcache.bin3 " die Power Automate-Konsole, beenden Sie Power Automate über die Taskleiste, oder starten Sie den Power Automate-Dienst neu, und versuchen Sie dann erneut, sich anzumelden.
Web Account Manager (WAM)-Fehler
Standardmäßig authentifiziert Power Automate für Desktop Benutzer über den Web Account Manager (WAM); eine Windows-Komponente, die im Betriebssystem enthalten ist und als Authentifizierungsbroker fungiert.
Weitere Informationen zu WAM und verwandten Fehlern finden Sie unter Verwenden von MSAL.NET mit Web Account Manager (WAM) und Interactive mit WAM.
Falsche Regionsprobleme
Stellen Sie vor der Anmeldung sicher, dass Sie die richtige Region aus der Option "Region ändern" ausgewählt haben.
Browser blockiert Cookies
Wenn Sie sich bei Power Automate für Desktop anmelden, wird die folgende Fehlermeldung angezeigt:
Wir können Sie nicht anmelden. Ihr Browser ist zurzeit so eingestellt, dass Cookies blockiert werden. Sie müssen zulassen, dass Cookies diesen Dienst verwenden können.
Lösung
Wechseln Sie zu Systemsteuerung> Internet-Optionen>für>vertrauenswürdige Websites.
Fügen Sie die folgenden URLs hinzu:
login.microsoft.com
login.windows.net
login.microsoftonline.com
secure.aadcdn.microsoftonline-p.com
Anmeldung aufgrund eines Verbindungsproblems nicht möglich
Wenn Sie sich bei Power Automate für Desktop anmelden, wird die folgende Fehlermeldung angezeigt:
Bei der Anmeldung ist ein Problem aufgetreten. Versuchen Sie es später erneut, oder wenden Sie sich an einen Administrator.
Überprüfen des Problems
Versuchen Sie, sich bei Power Automate anzumelden. Wenn es wie erwartet funktioniert, sollte das Problem mit der lokalen Netzwerkkonfiguration des Computers zusammenhängen, auf dem Power Automate für Desktop gehostet wird.
Lösung
Weitere Informationen zu möglichen Ursachen und Schritten zur Behebung dieses Problems finden Sie unter "Kann keine Desktopflüsse erstellen, bearbeiten, speichern oder anzeigen".
Das Anmeldefenster wird immer wieder angezeigt.
Beim Anmelden bei Power Automate für Desktop wird die Anmeldung beim Kontofenster angezeigt, wenn Sie die Anmeldeinformationen eingeben. Wenn Sie das Fragezeichensymbol (?) auswählen, um das Konto in "Bei Ihrem Microsoft-Konto anmelden" zurückzusetzen, wird das Anmeldefenster ausgeblendet.
Ursache
Ein anderer Prozess kann einen benannten Pipeserver auf demselben Computer ausführen. Dieser Prozess wird mit erhöhten Rechten mithilfe des localhost-Endpunkts ausgeführt und blockiert andere Anwendungen daran, diesen Endpunkt zu verwenden.
So ermitteln Sie, ob ein anderer Prozess ausgeführt wird:
Laden Sie die Sysinternals-Suite herunter.
Extrahieren Sie die .zip Datei in einen Ordner.
Führen Sie eine Eingabeaufforderung als Administrator aus.
Navigieren Sie zu dem Ordner, in dem die Sysinternals Suite extrahiert wurde.
Führen Sie den folgenden Befehl aus:
handle net.pipe
Notiz
Wenn Sie diesen Befehl ausführen, sollte eine Liste von Prozessen angezeigt werden, die Named Pipes verwenden, und die Adresse, auf die sie hören.
Ermitteln Sie anhand des folgenden Links, ob ein Prozess die
EbmV0LnBpcGU6Ly8rLw==
Zeichenfolge anzeigt und den Prozess decodiert:https://www.base64decode.org/
Zum Beispiel:
PAD.BrowserNativeMessageHost.exe pid: 21064 type: Section 464: \Sessions\1\BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rL0JST1dTRVJOQVRJVkVIT1NULzE2NjIwLzEv Microsoft.Management.Services.IntuneWindowsAgent.exe pid: 26708 type: Section 6AC: \BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rL0lOVFVORU1BTkFHRU1FTlRFWFRFTlNJT04vU1RBVFVTU0VSVklDRS8= PipesTest.Server.exe pid: 6540 type: Section 3AC: \BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rLw==
Lösung
Um dieses Problem zu beheben, beenden Sie den im vorherigen Schritt identifizierten Prozess, oder wenn es sich um einen internen Prozess handelt, verwenden Sie einen spezifischeren Endpunkt, z net.pipe://localhost/something
. B. .
Stellen Sie alternativ sicher, dass Power Automate für Desktop geschlossen ist (auch von der Taskleiste), beenden Sie den in den vorherigen Schritten identifizierten Prozess, und versuchen Sie es dann erneut, Power Automate für Desktop neu zu starten.
Wenn die anderen Lösungen nicht möglich sind, geben Sie Power Automate für Desktop ausführbaren Dateien an, die als Administrator ausgeführt werden sollen. Diese Problemumgehung kann in einigen Fällen nur das Problem lösen, und es wird jedes Mal eine Eingabeaufforderung für die Benutzerkontensteuerung (User Account Control, UAC) angezeigt.