Anmelden bei Visual Studio unter Windows

Gilt für:yesVisual Studio noVisual Studio für MacnoVisual Studio Code

In diesem Artikel lernen Sie Folgendes:

Vorteile der Anmeldung

Obwohl Sie sich nicht anmelden müssen, hat eine Anmeldung viele Vorteile.

Vorteil BESCHREIBUNG
Verlängern Ihres Visual Studio-Testzeitraums Sie können Visual Studio Professional oder Visual Studio Enterprise für weitere 90 Tage verwenden und sind nicht auf den Testzeitraum von 30 Tagen beschränkt.
Entsperren von Visual Studio Machen Sie Visual Studio verfügbar, wenn Sie ein Konto verwenden, das mit einem Visual Studio-Abonnement oder mit einer Azure DevOps-Organisation verknüpft ist.
Synchronisieren Ihrer Einstellungen Von Ihnen angepasste Einstellungen, beispielsweise Tastenzuordnungen, Fensterlayouts und Farbdesigns, werden sofort übernommen, wenn Sie sich auf einem beliebigen Gerät bei Visual Studio anmelden.
Automatische Verbindungsherstellung mit Azure-Diensten Die Verbindung mit Diensten wie Azure und Azure DevOps Services wird über die IDE hergestellt, ohne dass Sie noch einmal aufgefordert werden, für dasselbe Konto Ihre Anmeldeinformationen einzugeben.
Weiterverwenden der Community Edition ohne Unterbrechungen Wenn Sie während der Installation regelmäßig aufgefordert werden, sich anzumelden, melden Sie sich bei der IDE an, um Visual Studio Community weiterhin ohne Unterbrechungen nutzen zu können.
Verwendung von Visual Studio Dev Essentials Dieses Programm umfasst u. a. kostenlose Softwareangebote, Schulungen und Support.

Anmelden mit einem Microsoft-Konto oder einem Unternehmenskonto

  1. Starten Sie Visual Studio. Wenn Sie Visual Studio erstmals öffnen, werden Sie aufgefordert, sich anzumelden und einige grundlegenden Registrierungsinformationen bereitzustellen.

    Aufforderung zum Anmelden

    Hinweis

    Wenn Sie sich beim ersten Öffnen von Visual Studio nicht anmelden möchten, können Sie dies später jederzeit nachholen. Suchen Sie nach dem Link Anmelden oben rechts in der Visual Studio-Umgebung.

  1. Starten Sie Visual Studio. Wenn Sie Visual Studio erstmals öffnen, werden Sie aufgefordert, sich anzumelden und einige grundlegenden Registrierungsinformationen bereitzustellen.

    Aufforderung zum Anmelden

  1. Wählen Sie ein Microsoft-Konto oder ein Geschäfts-, Schul- oder Unikonto aus. Wenn Sie keines besitzen, erstellen Sie kostenlos ein Microsoft-Konto, indem Sie den Link neben Anmelden auswählen.

  2. Wählen Sie Ihr bevorzugtes Farbschema und andere Benutzeroberflächeneinstellungen aus. Visual Studio speichert diese Einstellungen und synchronisiert sie in allen Visual Studio-Umgebungen, in denen Sie angemeldet sind. Sie können die Einstellungen später im Visual Studio-Menü unter Extras>Optionen ändern.

    In der oberen rechten Ecke von Visual Studio sehen Sie, dass Sie erfolgreich angemeldet wurden. Sofern Sie sich nicht abmelden, sind Sie automatisch angemeldet, wenn Sie Visual Studio starten. Alle Änderungen an synchronisierten Einstellungen werden automatisch übernommen.

Aktuell angemeldeter Benutzer in VS2019

Aktuell angemeldeter Benutzer in VS2019

Hinzufügen und Wechseln von Benutzerkonten

Wenn Sie mehrere Microsoft-Konten und/oder Geschäfts- oder Schulkonten haben, können Sie all diese Konten zu Visual Studio hinzufügen, sodass Sie über jedes Konto auf die Ressourcen zugreifen können, ohne sich separat anmelden zu müssen.

Wenn Sie auf einem Computer mehrere Benutzerkonten hinzufügen, sind diese Konten auch dann verfügbar, wenn Sie sich auf einem anderen Computer bei Visual Studio anmelden.

Hinweis

Es werden zwar die Namen der Konten übernommen, jedoch nicht die Anmeldeinformationen. Sie werden aufgefordert, die Anmeldeinformationen für die anderen Konten einzugeben, wenn Sie zum ersten Mal versuchen, die dazugehörigen Ressourcen auf einem neuen Computer zu verwenden.

Hinzufügen eines weiteren Kontos zu Visual Studio

Gehen Sie wie folgt vor, um ein weiteres Konto zu Visual Studio hinzuzufügen:

  1. Klicken Sie auf Datei>Kontoeinstellungen.

  2. Wählen Sie unter Alle Konten ein Konto aus. Verwenden Sie hierzu entweder + oder die Dropdownliste Hinzufügen.

  3. Wählen Sie auf der Seite Bei Ihrem Konto anmelden das entsprechende Konto aus, oder klicken Sie auf Anderes Konto verwenden. Folgen Sie den Anweisungen, um die neuen Anmeldeinformationen für das Konto einzugeben.

(Optional) Wenn Sie jetzt zum Server-Explorer wechseln, werden die Azure-Dienste angezeigt, die dem Konto zugeordnet sind, das Sie gerade hinzugefügt haben. Klicken Sie im Server-Explorer erst mit der rechten Maustaste auf den Azure-Knoten und anschließend mit der linken auf Manage and Filter Subscriptions (Abonnements verwalten und filtern). Wählen Sie das neue Konto durch Klicken auf den Dropdownpfeil neben dem aktuellen Konto aus, und wählen Sie dann aus, welche Abonnements Sie im Server-Explorer anzeigen möchten. Es sollten alle Dienste angezeigt werden, die dem angegebenen Abonnement zugeordnet sind. Auch wenn Sie mit dem zweiten Konto gerade nicht bei Visual Studio angemeldet sind, sind Sie bei den Diensten und Ressourcen dieses Kontos angemeldet. Gleiches gilt für Projekt>Verbundenen Dienst hinzufügen.

Hinzufügen eines GitHub-Kontos zu Visual Studio

Ab Version 16.8 können Sie Ihrer Keychain sowohl GitHub- als auch GitHub Enterprise-Konten hinzufügen. Sie können sie genauso wie bei Microsoft-Konten hinzufügen und nutzen, d. h., dass Sie einfacher auf die GitHub-Ressourcen in Visual Studio zugreifen können.

Ausführliche Anweisungen finden Sie unter Arbeiten mit GitHub-Konten in Visual Studio.

Hinzufügen eines für Multi-Faktor-Authentifizierung (MFA) aktivierten Kontos zu Visual Studio

In Version 16.6 haben wir Visual Studio 2019 neue Funktionen hinzugefügt, mit denen Sie optimieren können, wie Benutzer auf Ressourcen zugreifen können, die über Richtlinien für bedingten Zugriff wie MFA geschützt sind. Um diesen verbesserten Workflow nutzen zu können, müssen Sie sich für die Verwendung des Standardwebbrowsers Ihres Systems als Mechanismus zum Hinzufügen und erneuten Authentifizieren von Visual Studio-Konten entscheiden.

Ausführliche Anweisungen finden Sie unter Arbeiten mit Konten, die Multi-Faktor-Authentifizierung (MFA) erfordern.

Zugreifen auf mehrere Konten, die dem Visual Studio-Anmeldekonto zugeordnet sind

Nachdem Sie sich mit einem Microsoft- oder Organisationskonto bei Visual Studio angemeldet haben, können Sie die Ressourcen, auf die von Ihren Konten aus zugegriffen werden kann, z. B. im Dialogfeld Verbundenen Dienst hinzufügen, Server-Explorer und Team Explorer anzeigen.

Für Azure, Application Insights, Azure DevOps und Microsoft 365 wird die optimierte Anmeldung unterstützt.

Zugreifen auf Ihr Azure-Konto in Server-Explorer

Um den Server-Explorer zu öffnen, wählen Sie Ansicht>Server Explorer (oder, wenn Sie die „Allgemeinen“ Umgebungseinstellungen verwenden, drücken Sie STRG+Alt+S). Erweitern Sie den Knoten Azure. Dann sollten Ihnen die in dem Azure-Konto verfügbaren Ressourcen angezeigt werden, die dem Konto zugeordnet sind, das Sie zur Anmeldung in Visual Studio verwendet haben. Dies sollte in etwa wie folgt aussehen:

Server-Explorer mit erweitertem Azure-Knoten

Server-Explorer mit erweitertem Azure-Knoten

Wenn Sie Visual Studio auf einem bestimmten Gerät zum ersten Mal verwenden, zeigt das Dialogfeld nur die Abonnements an, die unter dem Konto registriert sind, mit dem Sie sich angemeldet haben. Auf die Ressourcen Ihrer anderen Konten können Sie direkt über den Server-Explorer zugreifen, indem Sie mit der rechten Maustaste auf den Azure-Knoten klicken, Manage and Filter Subscriptions (Abonnements verwalten und filtern) auswählen und Ihre Konten über das Steuerelement zur Kontoauswahl hinzufügen. Um ein anderes Konto auszuwählen, klicken Sie auf den Pfeil nach unten, und wählen Sie das gewünschte Konto aus der Liste aus. Wenn Sie das Konto ausgewählt haben, können Sie bearbeiten, welche Abonnements dieses Kontos im Server-Explorer angezeigt werden sollen.

Dialogfeld

Wenn Sie den Server-Explorer dann das nächste Mal öffnen, werden die Ressourcen für dieses Abonnement angezeigt.

Zugreifen auf Ihr Azure-Konto über das Dialogfeld "Verbundenen Dienst hinzufügen"

  1. Wählen Sie ein bereits vorhandenes Projekt aus, oder erstellen Sie ein neues.

  2. Wählen Sie im Projektmappen-Explorer den Projektknoten aus, und klicken Sie anschließend mit der rechten Maustaste auf Hinzufügen>Verbundener Dienst.

    Im daraufhin angezeigten Fenster Verbundene Dienste wird die Liste der Dienste in dem Azure-Konto angezeigt, das mit Ihrem Visual Studio-Personalisierungskonto verknüpft ist. Sie müssen sich nicht separat bei Azure anmelden. Allerdings müssen Sie sich beim ersten Versuch, von einem anderen Computer auf die Ressourcen eines anderen Kontos zuzugreifen, bei diesem Konto anmelden.

Zugreifen auf Azure Active Directory in einem Webprojekt

Azure Active Directory (Azure AD) unterstützt einmaliges Anmelden für Endbenutzer in MVC-Webanwendungen in ASP.NET oder AD-Authentifizierung in Web-API-Diensten. Die Domänenauthentifizierung unterscheidet sich von der Authentifizierung einzelner Benutzerkonten. Benutzer, die Zugriff auf Ihre Azure AD-Domäne haben, können ihre bereits vorhandenen Azure AD-Konten verwenden, um eine Verbindung mit Ihren Webanwendung herzustellen. Auch Microsoft 365-Anwendungen können die Domänenauthentifizierung verwenden.

Um einen Eindruck zu erhalten, erstellen Sie ein neues Projekt vom Typ ASP.NET Core-Web-App. Wählen Sie auf der Seite Weitere Informationen in der Dropdownliste Zielframework die Option .NET Core 3.1 (Langfristige Unterstützung) und anschließend in der Dropdownliste Authentifizierungstyp einen Authentifizierungstyp aus.

Um einen Eindruck zu erhalten, erstellen Sie ein neues Projekt vom Typ ASP.NET Core-Web-App. Wählen Sie auf der Seite Weitere Informationen in der Dropdownliste Zielframework die Option .NET Core 6 (Langfristige Unterstützung) und anschließend in der Dropdownliste Authentifizierungstyp einen Authentifizierungstyp aus.

Identität: Proxyunterstützung für durch Azure Active Directory geschützte Konten

Visual Studio kann jetzt erkennen, wann Benutzer hinter einem Proxy stehen und proaktiv zu Proxyanmeldeinformationen aufgefordert werden, wenn Microsoft-Konten (MSA) oder Geschäfts- oder Schulkonten (WSA) zu Visual Studio hinzugefügt werden.

Proxyanmeldeinformationen werden in der Windows-Anmeldeinformationsverwaltung gespeichert und nach Bedarf verwendet, um identitätsbezogene Vorgänge auszuführen.

Hinweis

Wenn der Proxyserver nach dem Öffnen Visual Studio gestartet oder geändert wird, wird im Dialogfeld Kontoeinstellungen eine Warnung angezeigt. Sie müssen jedoch Visual Studio neu starten, um die Eingabeaufforderung für die Proxyanmeldeinformationen anzuzeigen.

Abmelden des Kontos

  1. Wählen Sie oben rechts in der Visual Studio-Umgebung das Symbol mit Ihrem Profilnamen aus.
  2. Wählen Sie Konteneinstellungen aus.
  3. Wählen Sie Abmelden aus.

Aktualisieren Ihres Kontoprofils

  1. Wechseln Sie zu Dateikontoeinstellungen > ... und wählen Sie den Link "Visual Studio-Profil verwalten " aus.
  2. Wählen Sie im Browserfenster Profil bearbeiten aus, und ändern Sie die gewünschten Einstellungen.
  3. Wenn Sie fertig sind, wählen Sie Speichern aus.

Siehe auch