2. Einrichten von Photon Unity Networking

In diesem Tutorial bereiten Sie sich mithilfe des Photon Unity-Netzwerks (PUN) auf das Erstellen einer gemeinsamen Benutzeroberfläche vor. Sie erfahren, wie Sie eine PUN-App erstellen, PUN-Ressourcen in Ihr Unity-Projekt importieren und Ihr Unity-Projekt mit der PUN-App verbinden.

Ziele

  • Erfahren, wie eine PUN-App erstellt wird
  • Erfahren, wie die PUN-Ressourcen gesucht und importiert werden
  • Erfahren, wie eine Verbindung Ihres Unity-Projekts mit der PUN-App hergestellt wird

Erstellen und Vorbereiten des Unity-Projekts

In diesem Abschnitt erstellen Sie ein neues Unity-Projekt und bereiten es für die MRTK-Entwicklung vor.

Befolgen Sie zunächst die Anweisungen unter Initialisieren Ihres Projekts und Bereitstellen Ihrer ersten Anwendung, jedoch ohne die Anweisungen zum Hinzufügen von Handinteraktion zu einem Objekt und zum Erstellen Ihrer Anwendung auf Ihrem Gerät, die die folgenden Schritte beinhalten:

  1. Erstellen eines neuen Unity-Projekts, das mit einem passenden Namen bezeichnet wird, beispielsweise MRTK-Tutorials
  2. Wechseln der Buildplattform
  3. Importieren der TextMeshPro Essential-Ressourcen
  4. Importieren des Mixed Reality Toolkits und Konfigurieren des Unity-Projekts
  5. Erstellen der Szene und Konfigurieren des MRTK sowie Bezeichnen der Szene mit einem passenden Namen, z. B. MultiUserCapabilities

Befolgen Sie dann die Anweisungen unter Ändern der Anzeigeoptionen für räumliche Wahrnehmung, um die folgenden Aufgaben auszuführen:

  1. Ändern des MRTK-Konfigurationsprofils in DefaultHoloLens2ConfigurationProfile.
  2. Ändern der Anzeigeoptionen für das Gittermodell für räumliche Wahrnehmung in Occlusion (Verdeckung).

Aktivieren zusätzlicher Funktionen

Wählen Sie im Unity-Menü Edit>Project Settings... (Bearbeiten > Projekteinstellungen) aus, um das Fenster mit den Player-Einstellungen zu öffnen, und suchen Sie dann den Abschnitt Player>Publishing Settings (Player > Veröffentlichungseinstellungen):

Unity Player settings

Scrollen Sie in Publishing Settings (Veröffentlichungseinstellungen) nach unten zum Abschnitt Capabilities (Funktionen), und vergewissern Sie sich, dass die Funktionen InternetClient, Microphone, SpatialPerception und GazeInput, die Sie im Schritt Konfigurieren des Unity-Projekts weiter oben aktiviert haben, aktiviert sind.

Aktivieren Sie dann die folgenden zusätzlichen Funktionen:

  • InternetClientServer-Funktion
  • PrivateNetworkClientServer-Funktion

Unity Capabilities settings

Importieren der Tutorialressourcen

Laden Sie die folgenden benutzerdefinierten Unity-Pakete herunter, und importieren Sie sie in der Reihenfolge, in der sie aufgelistet sind:

Tipp

 Wenn Sie eine Auffrischung zum Importieren eines benutzerdefinierten Unity-Pakets benötigen, lesen Sie die Anweisungen unter Importieren der Tutorialressourcen.

Hinweis

Nach dem Importieren des Pakets mit den MultiUserCapabilities-Tutorialressourcen werden im Konsolenfenster mehrere CS0246-Fehler angezeigt, die besagen, dass der Typ oder Namespace fehlt. Dies ist das erwartungsgemäße Verhalten, das im nächsten Abschnitt durch das Importieren der PUN-Ressourcen behoben wird.

Importieren der PUN-Ressourcen

Wählen Sie im Unity-Menü Window>Asset Store (Fenster > Asset Store) aus, um das Asset Store-Fenster zu öffnen, suchen Sie unter „Exit Games“ PUN 2 - FREE aus, und klicken Sie dann auf die Schaltfläche Download, um das Ressourcenpaket in Ihr Unity-Konto herunterzuladen.

Wenn der Download abgeschlossen ist, klicken Sie auf die Import-Schaltfläche, um das Fenster Import Unity Package (Unity-Paket importieren) zu öffnen:

Unity Asset Store with PUN 2 - Free

Klicken Sie im Import Unity Package-Fenster (Unity-Paket importieren) auf die Schaltfläche All (Alle), um sicherzustellen, dass alle Assets ausgewählt sind, und klicken Sie dann auf die Schaltfläche Import (Importieren), um die Assets zu importieren:

Unity with PUN 2 import window

Nachdem Unity den Importvorgang abgeschlossen hat, wird das Fenster des PUN-Assistenten mit geöffnetem PUN-Setupmenü geladen. Für den Augenblick können Sie dieses Fenster ignorieren oder schließen:

Unity with PUN Setup window

Erstellen der PUN-Anwendung

In diesem Abschnitt erstellen Sie ein Photon-Konto, falls dies noch nicht geschehen ist, und Sie erstellen eine neue PUN-App.

Navigieren Sie zum Photon-Dashboard, und melden Sie sich an, wenn Sie bereits über ein Konto verfügen, das Sie verwenden möchten, oder klicken Sie andernfalls auf den Link Create One (Konto erstellen), und befolgen Sie die Anweisungen zum Registrieren eines neuen Kontos:

Photon login page

Nachdem Sie sich angemeldet haben, klicken Sie auf die Schaltfläche Create a New App (Neue App erstellen):

Photon dashboard welcome page

Geben Sie auf der Seite „Create a New Application“ (Neue Anwendung erstellen) die folgenden Werte ein:

  • Wählen Sie als Photon-Typ „PUN“ aus.
  • Geben Sie als Namen einen passenden Namen ein, beispielsweise MRTK-Tutorials
  • Geben Sie als Beschreibung optional eine passende Beschreibung ein
  • Lassen Sie das Feld „URL“ leer

Klicken Sie dann auf die Schaltfläche Create (Erstellen), um die neue App zu erstellen:

Photon create application page

Nachdem Photon den Erstellungsvorgang abgeschlossen hat, wird die neue PUN-App auf Ihrem Dashboard angezeigt:

Photon application page

Verbinden des Unity-Projekts mit der PUN-Anwendung

In diesem Abschnitt verbinden Sie Ihr Unity-Projekt mit der PUN-App, die Sie im vorherigen Abschnitt erstellt haben.

Klicken Sie auf dem Photon-Dashboard auf das Feld App-ID, um die App-ID anzuzeigen, und kopieren Sie sie dann in die Zwischenablage:

Photon application page with App Id selected

Wählen Sie im Unity-Menü Window>Photon Unity Networking>PUN Wizard (Fenster > Photon Unity-Netzwerk > PUN-Assistent) aus, um das Fenster des Pun-Assistenten zu öffnen, klicken Sie auf die Schaltfläche Setup Project (Projekt einrichten), um das PUN-Setupmenü zu öffnen, und konfigurieren Sie es wie folgt:

  • Fügen Sie im Feld AppId or Email (AppID oder E-Mail) die PUN-App-ID ein, die Sie im vorherigen Schritt kopiert hatten

Klicken Sie anschließend auf die Schaltfläche Setup Project (Projekt einrichten), um die AppID zu übernehmen:

Unity PUN Setup window with AppId filled in

Sobald Unity den PUN-Setupprozess abgeschlossen hat, zeigt das PUN-Setupmenü die Meldung Fertig! an und wählt automatisch das Medienobjekt PhotonServerSettings im Projektfenster aus, sodass seine Eigenschaften im Inspektorfenster angezeigt werden:

Unity PUN Setup window with Setup Project applied

Herzlichen Glückwunsch!

Sie haben erfolgreich eine PUN-Anwendung erstellt und sie mit Ihrem Unity-Projekt verbunden. Der nächste Schritt besteht im Zulassen von Verbindungen mit anderen Benutzern, sodass sich mehrere Benutzer gegenseitig sehen können.