Share via

Set alert for Microsoft 365 Global Admin password reset

Cloud_Geek_82 901 Reputation points
2024-03-08T08:37:09.7333333+00:00

Hi Guys,

Is it possible to set an alert that would send an email every time Microsoft 365 Global Admin password is changed?

Thanks in advance.

Azure Monitor
Azure Monitor

An Azure service that is used to collect, analyze, and act on telemetry data from Azure and on-premises environments.

Microsoft 365 and Office | Install, redeem, activate | For business | Windows
Microsoft Security | Microsoft Entra | Microsoft Entra ID
0 comments No comments

Answer accepted by question author

  1. Michael Smith 2,931 Reputation points Microsoft Employee Moderator
    2024-03-14T10:46:18.68+00:00

    Hey,

    I set up an alert for password changes doing the following steps:

    1. Open log analytics

    User's image

    1. run the query to ensure you see results.
      User's image

    User's image

    1. once confirmed the query is ok and returning events. click "new alert rule"

    User's image

    1. you can leave the conditions as they are. The query should already be in the box.
    2. go to actions and create an action group.

    User's image

    1. Set the action group name and display name.
      User's image
    2. add the users and emails you want to notify when the password changes are detected.
      User's image

    User's image

    1. test your action group.

    User's image

    User's image

    You can review and save.

    Change the password for one of the accounts in your query and confirm the alert is triggered.

    0 comments No comments

4 additional answers

Sort by: Most helpful
  1. Cloud_Geek_82 901 Reputation points
    2024-03-20T09:33:03.78+00:00

    @Michael Smith

    Thanks you very much for your help.

    Works exactly the way I was needed.

    1 person found this answer helpful.
    0 comments No comments

  2. Michael Smith 2,931 Reputation points Microsoft Employee Moderator
    2024-03-09T07:26:16.59+00:00

    Hey,

    Thank you for contacting the Q&A community.

    If you want to set up alerts for specific accounts you can do so using alerts in log analytics.

    Create the workspace here
    https://portal.azure.com/#view/HubsExtension/BrowseResource/resourceType/Microsoft.OperationalInsights%2Fworkspaces

    You need to create a log analytics workspace then export your audit logs to the workspace.

    Then go to your audit logs and choose export data settings

    User's image

    User's image

    Once the audit logs are being exported you can run the following query to find the audit logs for the password changes for the specific users.

    AuditLogs
    | where TargetResources[0].userPrincipalName == "******@domain.com" or TargetResources[0].userPrincipalName == "******@domain.com"
    | where OperationName == "Change user password"
    

    Then follow the doc below to set up the alert rule. You need to create an action group where you can specify the emails that are alerted. This is also in the doc.
    https://learn.microsoft.com/en-us/azure/azure-monitor/alerts/tutorial-log-alert

    Let us know if you need additional assistance. If the answer was helpful, please accept it and rate it so that others facing a similar issue can easily find a solution.

    1 person found this answer helpful.

  3. Andy David - MVP 160.2K Reputation points MVP Volunteer Moderator
    2024-03-08T13:27:04.3066667+00:00

    You can set in the Entra portal

    User's image

    1 person found this answer helpful.

  4. Cloud_Geek_82 901 Reputation points
    2024-03-14T20:21:32.7266667+00:00

    Hi @Michael Smith

    Thanks for the detailed guide.

    Just one question on the steps of of creating an alert rule.

    Could you please advise what I should select in the highlighted fields.

    alert rule

    Also for testing purposes I reset a password for one of the Microsoft 365 accounts but I run the query I get "No results found from the last 30 minutes Try selecting another time range". (I used the same query you posted and only replaced with my UPN addresses.)


Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.