Upgrade to SxSStack-1.0.2208.17178 causes some remote apps not to show on the user's desktop

Krzysztof Knapik 6 Reputation points
2022-09-27T09:10:35.967+00:00

Hello,

I am running Win 10 host in the Remote App configuration for about 3 years now. Last week users started reporting issues trying to run some of the applications, older Delphi apps to be more precise - still supported and regularly updated by the vendor. Trying to run the application from the user perspective (using the Remote Desktop Client app and clicking the app icon) does not work, the application is not shown (if this is the first try after reboot/logoff the connection window is displayed but then nothing). Looking into the host I see that the application is started for the user, trying to run it directly on the host works. What is surprising is that using the WVD Web Client does display the app as always.

For the last couple of days, I tried to troubleshoot and I found that removing the host from the pool and re-adding it fixes the issue for a few hours (the Remote Desktop Client app is showing the application when it was started). I also noticed that restoring the VM from the backup from around the 15th of September has the same effect and the old Delphi apps are working for a couple of hours but then again the issue is back.

From my tests, it looks like the issue is related to the SxSStack. After the host is re-added to the pool (based on the instructions https://learn.microsoft.com/en-us/azure/virtual-desktop/troubleshoot-agent#your-issue-isnt-listed-here-or-wasnt-resolved) or the VM is restored I see that there is only one SxSStack version installed in the system, the SxSStack-1.0.2207.18200. After a couple of hours when the issue is back I see a second version installed, the newer SxSStack-1.0.2208.17178.

Another observation is that if the user session was started when the "older" SxSStack was installed and the user was not logoff from the host, the old apps are working even if the newer SxSStack was automatically installed, but after a logoff, the started apps are not visible to the user again.

Have anyone had a similar issue with the SxSStack? Are the know issues with this version of the SxSStack? I found a post suggesting changes in the registry to force usage of an older SxSStack version but this does not seem to be the right solution https://learn.microsoft.com/en-us/answers/questions/722820/sxsstacklistenercheck-failed.html.

To clarify: The issue affects only older apps, modern ones like Excel are working.

Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,382 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Krzysztof Knapik 6 Reputation points
    2022-10-02T12:50:31.637+00:00

    Contacting the support team helped and the resolution to the issue was found.

    It turned out that the affected host was running in the "validation environment" mode, causing the host pool to install the latest version of different remote desktop services. Switching off the validation environment (portal->host pool->properties) forced the remote services to downgrade to older versions running correctly.

    My problem is solved but the support case will remain open to investigate the issue more deeply.

    @vipullag-MSFT thank you for your help with this.

    1 person found this answer helpful.