SQL Server Management Studio 18 remember password not working?

galletto 171 Reputation points

With one of the latest updates of SSMS 18 (I'm now on 18.6), the remember password feature does not seem to work anymore. Am I missing something?


SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,288 questions
{count} votes

11 answers

Sort by: Most helpful
  1. Lee Lepkowski 31 Reputation points

    Thank you @Abdul Arfat Mohammed and @Sean that simple solution (delete the server from the drop-down options, maybe re-launch SSMS, add the server being sure "Remember password" is checked) seems to do the trick.

    In case that fails these are the tedious/manual steps to accomplish the same thing:

    1. Exit SSMS
    2. Edit C:\Users\%username%\AppData\Roaming\Microsoft\SQL Server Management Studio\18.x\UserSettings.xml
    3. Look at the <Servers> and child <Element> with child <Connections> and subsequent child <Element> tags, remove just the <Element>...</Element> items for specific connections and/or servers where the saved password is an issue
    4. Before re-opening SSMS, using Windows 10 Credential Manager under "Windows Credentials" find and delete the Microsoft:SSMS:18:<serverName>:<userName>:<guid>... credentials for the specific logins that were problematic
    5. Re-open SSMS, connect to your server(s) using the "save password" option; the passwords will be saved

    Answer is from https://feedback.azure.com/forums/908035-sql-server/suggestions/32906749-ssms-still-forgets-passwords

    6 people found this answer helpful.

  2. Abdul Arfat Mohammed 26 Reputation points

    @galletto Hi there!

    I faced the same problem. As a workaround, you can delete that entry (which SSMS forgets) from the 'Connect to Server' dialog box as shown below:

    • Hover on that entry
    • Click del on keyboard
    • Now close SSMS and open it and type in that entry again and make sure you click remember password checkbox.
    • Now open SSMS it should be remembering password now.

    Let me know how it goes for you.

    Probably my guess is that SSMS is unable to save the password later if we initially (first time) ask it to not remember.

    5 people found this answer helpful.

  3. Cris Zhan-MSFT 6,601 Reputation points

    Hi @galletto ,

    Can you describe your situation/scenario in detail to conclude that this feature is not available.
    I used SSMS18.6 on multiple machines and did not encounter this problem.

    SSMS's password management switched to Windows Credential Manager with version 18

  4. Ronen Ariely 15,081 Reputation points

    Good day all :-)

    Here is my 2 cants on the topic:


    galletto: I don't see anything resembling a Credential Manager in my W10 PC?

    There are multiple options to open the "Credential Manager" or the "Stored User Names and Password" GUI.

    Both provide the same information and the options to add, edit, and remove credentials. The "Stored User Names and Password" GUI also provide option to backup and restore information. The information can be also managed using command shell and PowerShell

    option 1: To open Credential Manager in windows 10, type "credential manager" (without the quotation marks) in the search box on the taskbar and select "Credential Manager Control panel" or "Credential Manager".

    Option 2: Open "Control Panel" -> Select "User accounts" -> select "Credential Manager"


    Option 3: To manage Credential using PowerShell and Command Shell you can use the utility "cmdkey.exe" using the command "cmdkey"

    # Get more information  
    # Show all Credentials  
    cmdkey /list  
    # Add Credential  
    cmdkey /add:<target> /user:<user_name> /pass:<password>  

    option 4: Open the "Stored User Names and Password" GUI

    Start > Run > rundll32.exe keymgr.dll,KRShowKeyMgr

    Option 5: open the Credential Manager (Do not ask me why "Userpasswords2" but this works)

    Start > Run > Control Userpasswords2 > Click the "Advanced" tab and then click "Manage Passwords".

    Option 6: Using Control Panel

    Open "Control Panel" > "User Accounts" > "Credentional manager"


    Erland: It seems to work for me, but I don't have that many SQL logins.

    Not sure if this considered as many, but on my laptop I have about 50 and I did not noticed any issue.


    So what does it mean that SSMS switched to Windows Credential Manager?

    SQL Server Management Studio version 18 stores the passwords under the windows application saved password which can be managed using the "Credential Manager". Therefore, we can use the options above in order to open the "Credential Manager" and you will see the SSMS stored password by default.

    If there is an issue and the passwords where not stored then we should not see them there. If the passwords were stored then you should see one entry for each case (for each user in each app).

    (1) Open Credential Manager and move to the tab "Windows Credential" (usually in opened on "Web Credential")


    (2) Scroll down to the list of "generic Credential", where you should find the SSMS Credentials

    check if you see Credentials which look like: Microsoft:SSMS:18:<here comes the specific information for this Credential>

    If you have these then SSMS probably stored your information.

    Moreover, we can add password to the SSMS directly in the "Credential Manager" without even open the SSMS.

    Do I need to do anything about that in SSMS?

    Usually not and it should work, but in case it does not works well then you can check the information using the Credential Manager

    1 person found this answer helpful.

  5. Erland Sommarskog 99,071 Reputation points MVP

    It seems to work for me, but I don't have that many SQL logins.

    An MVP colleague had problems with this, but I believe this was in an earlier version and I think 18.6 resolved his problem.

    In the Control Panel, you can look in the Credential Manager. I seem to recall that he had a bit of a mess there.