Text To Speech USP error: timeout waiting for the first audio chunk

MarkL 56 Reputation points
2022-10-13T15:08:10.053+00:00

I have been using some slightly modified sample code to generate speech from text. It has been working without issue. I returned to the project after maybe a week, and it is now receiving timeouts:

CANCELED: Reason=Error
CANCELED: ErrorCode=ServiceTimeout
CANCELED: ErrorDetails=[USP error: timeout waiting for the first audio chunk]
CANCELED: Did you update the subscription info?

The sample code I am using is here: https://learn.microsoft.com/en-ca/azure/cognitive-services/speech-service/get-started-text-to-speech?tabs=windows%2Cterminal&pivots=programming-language-csharp

I have tried:

  • Regenerating API keys
  • Creating new resource group
  • Creating new services

All yielding the same result.

Is anyone else having similar issues? I have also tried with Python examples with the same result.

Thanks in advance!

Azure AI Speech
Azure AI Speech
An Azure service that integrates speech processing into apps and services.
1,438 questions
Azure AI services
Azure AI services
A group of Azure services, SDKs, and APIs designed to make apps more intelligent, engaging, and discoverable.
2,443 questions
{count} votes

Accepted answer
  1. YutongTie-MSFT 46,996 Reputation points
    2022-10-14T19:35:08.993+00:00

    Hello @Oxueillirep @stephanus @Tanmay Dixit @Strada Francesco @Egil Sandfeld @MarkL @Andrey Bobrovsky @yyseasia008 @Tuan(トアン) Hoang

    Thanks for the report, everyone! There has been some extensive investigation over the past 12-16 hours, and it's been found that this is a result of a Windows 10/11 patch on Tuesday that changed the behavior of TLS in the operating system. Speech SDK is not the only ones impacted and a wide variety of TLS-dependent service use started failing with the latest patches.

    This issue is specific to those Windows clients with the latest updates from Tuesday.

    The Windows team is working on the root problem, and we expect a fix to be rolled out to Windows fairly quickly (for a Windows update--there's no ETA but we should assume it's still on the order of a week or two). In the interim, rolling back either of the above KBs can resolve the issue, and forcing TLS 1.2 in Windows's Internet Settings may be another way of working around the problem.

    Besides above, API and MacOS should work properly. I hope those helps! I will post more updates once I get more.

    [Update for Windows 11 22H2]
    The 22H2 feature release from September 20 does not actually contain the fix. You need to install the preview feature release (KB5018496) from October 25th to get the fix for 22H2:
    https://support.microsoft.com/topic/october-25-2022-kb5018496-os-build-22621-755-preview-64040bea-1e02-4b6d-bad1-b036200c2cb3

    For windows 10 22H2, please try KB5020435 - thanks for Carlos to post the exact link
    https://www.catalog.update.microsoft.com/Search.aspx?q=KB5020435

    Regards,
    Yutong

    -Please kindly accept the answer if you feel helpful to support the community, thanks a lot.

    2 people found this answer helpful.

21 additional answers

Sort by: Most helpful
  1. Strada Francesco 16 Reputation points
    2022-10-14T13:10:54.477+00:00

    Same problem please fix. As noted on the github issue I also encountered the problem only on machines which have the Windows 10 to KB5018410 Update.

    3 people found this answer helpful.
    0 comments No comments

  2. stephanus 11 Reputation points
    2022-10-14T14:25:13.263+00:00

    we have the same problem
    Azure troubleshooting indicate no problem but service is not working

    2 people found this answer helpful.
    0 comments No comments

  3. Andrey Bobrovsky 6 Reputation points
    2022-10-14T05:12:01.353+00:00

    Hi guys, I have same error. My solution has been working good a several days and yesterday I stumbled onto the same error 'USP error: timeout waiting for the first audio chunk'. If will be usefull I attach my logs below. Be glad any help.
    250259-log.txt

    1 person found this answer helpful.
    0 comments No comments

  4. yyseasia008 16 Reputation points
    2022-10-14T06:46:52.133+00:00

    Hi, when will this be taken care of?

    1 person found this answer helpful.
    0 comments No comments