Setup repository and publish from one tenant to other

Krishnamohan Nadimpalli 401 Reputation points
2022-10-19T14:46:33.753+00:00

Hi

I have a problem publishing ADF resources to Azure DevOps. Please help me out on this.

My azure account is krishnamohan.nadimpalli@clcpep1uwkhtn.onmicrosoft.com

My Devops account is krishnamohan.nadimpalli.contractor@*******.com

I am trying to publish ADF resources to ADO . But I get the below error. Following is the screenshot

"Failed to save Publish branch. Error: You are not allowed to save to current branch, either select another branch, or resolve the permissions in Azure DevOps."

252121-image.png

How do I give permissions to My azure account is krishnamohan.nadimpalli@clcpep1uwkhtn.onmicrosoft.com in devops

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,906 questions
0 comments No comments
{count} votes

Accepted answer
  1. BhargavaGunnam-MSFT 28,111 Reputation points Microsoft Employee
    2022-10-20T20:13:13.973+00:00

    Hello @Krishnamohan Nadimpalli ,

    Welcome to the MS Q&A platform.

    Could you please follow this document to set the permissions at the project level?

    also, please see this document to set branch-level permissions.

    let me know if you still have any questions.

    252519-image.png

    252652-image.png

    ------------------------------

    • Please don't forget to click on 130616-image.png and upvote 130671-image.png button whenever the information provided helps you. Original posters help the community find answers faster by identifying the correct answer. Here is how
    • Want a reminder to come back and check responses? Here is how to subscribe to a notification
    • If you are interested in joining the VM program and help shape the future of Q&A: Here is how you can be part of Q&A Volunteer Moderators
    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Rahal Bamunusinghe 0 Reputation points
    2023-09-05T15:33:55.0833333+00:00

    I faced this when I set "Require a Minimum number of reviewers" in the mentioned branches ( main and/or adf_publish in your case) in Git policies. The issue was solved when I disabled the policy in GIT. Once I enabled the adf GIT connection successfully, re-enabled the policy in GIT and it worked. Try to reconnect by removing branch policies since you can re-activate them after you establish the connection. Hope you are already in the "contributors" or higher GIT access group before everything. ( To change the branch policies, you need to be in the admin group in GIT)

    0 comments No comments