what would be the reason where credential creation for linked service in ADF is taking time forever?

ArunRaaman 996 Reputation points
2022-11-01T01:31:21.003+00:00

Hello There,

I have an issue creating 'credential' in linked-service for 'azure blob storage' where after giving all the information including resource-group, resource-type, 'user-assigned-managed-identity', and hit the 'create' button, the creation process never coming to end; it can be understood from the screenshot attached to this post.

Same is the problem when tried to first create credential from the 'manage' tab (in ADF github mode).

Would you anyone help me understand and isolate the problem.

Thank you for your time and efforts.

255852-image.png

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,896 questions
0 comments No comments
{count} votes

Accepted answer
  1. PRADEEPCHEEKATLA-MSFT 82,271 Reputation points Microsoft Employee
    2022-11-01T10:34:17.063+00:00

    Hello @ArunRaaman ,

    Thanks for the question and using MS Q&A platform.

    As per the repro, this could not take more than 30secs to create a new credentials in ADF studio.

    256056-adf-credentials.gif

    In case, if you are still experiencing the longer time - you may try the following steps and let us know.

    • Clear “Cookies and Cached data” of your browser.
    • Private Mode (New InPrivate Window).
    • Try in different browser.

    Hope this will help. Please let us know if any further queries.

    ------------------------------

    • Please don't forget to click on 130616-image.png or upvote 130671-image.png button whenever the information provided helps you. Original posters help the community find answers faster by identifying the correct answer. Here is how
    • Want a reminder to come back and check responses? Here is how to subscribe to a notification
    • If you are interested in joining the VM program and help shape the future of Q&A: Here is jhow you can be part of Q&A Volunteer Moderators
    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. 2024-03-28T07:44:39.1833333+00:00

    Hello,

    Please, check in Azure Portal. Go to your Data Factory -> Settings -> Managed Identities -> User assigned Tab. Your managed identity should be indicated there.

    0 comments No comments