Unable to login to Azure AD Joined Device using Azure AD Creds

MG_096 1 Reputation point
2022-11-02T16:35:14.58+00:00

I am in the process of testing Azure AD join as a valid option for device management for our workstations and laptops.

For these purposes, I have an Azure AD Directory, an administrator account with full Azure role permissions, and a test Windows 11 workstation.

So far what works:

  1. Adding the device to Azure AD
  2. Successfully added device to Azure AD, it displays in Azure portal as Azure Domain Joined
  3. Adding user accounts to the Device
  4. Successfully onboarded 3 accounts via connect for users they're displayed as 'AzureAD\<User1>' ...'
  5. Successfully connected to Azure-AD from the device using Powershell Connect-AzureAD
  6. can query both device and user status and object information from the device

What is not working:

When I follow the next logical step to sign out of my local account and login using the Azure AD account, I get "password or username is incorrect"

  1. I've tried the UPN (<username>@<domain>.com)
  2. the UPN of azure root domain (<username>@<account>.onmicrosoft.com)
  3. the SAM account (AzureAD\<username>)
  4. the combination of both (AzureAD\<username>@<domain>.com)
  5. adding a pin and other sign-in options

I've removed the device and rejoined it with a different account and still the same issue

If the problem is with my Azure AD configuration or with the username input, I cannot find it. Please provide some advice or assistance.

Thank you in advance

Azure Active Directory Domain Services
{count} votes