Any way to remove all my address from the To field when I hit Reply All with multiple From accounts?

GraniteStateColin 146 Reputation points

I use multiple From accounts. For example, my email address is .com and then I can also "send as" some groups, like .com and .com. When emails come in from our automation systems on our website or from other sources, the message will usually both appear to come FROM one of the groups ( .com or .com) and also have that group in the TO or CC field. This is so that it sends the message to the customer (so he or she can see that something is happening and to just hit reply engage with us) and also a copy to us internally so that we follow-up with the customer immediately, without waiting for the customer to hit Reply on his or her end.

I would assume that's a fairly common scenario.

So because it appears to come from, say, .com, I need to hit Reply All to actually reply to the customer (if I just hit Reply, it will reply to .com). But then I have to remember to go to the To field and manually remove any other .com addresses, otherwise, I'm spamming my co-workers and confusing the customer.

Is there any way to default to removing all other addresses .com from the To field? Or, remove any other address I can use in the From field drop-down? Or anything else that might help mitigate this problem?

Note that our main problem is on Outlook on the Web. For some reason I can't explain, even though the same problem occurs with Desktop Outlook, we don't seem to miss removing the extra addresses from the To field so frequently in Desktop Outlook. Something about the web UI seems to ensure we miss noticing our own extra address in the To field.


Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
4,982 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Victor Ivanidze 101 Reputation points

  2. Faery Fu-MSFT 17,716 Reputation points Microsoft Vendor

    Hi @GraniteStateColin ,

    When you Reply to a message in the Sent Items folder, your address is in the To field, because your address is the From address, and the reply is sent to the person who sent the message, in this case.

    You should use Reply all (delete your address from the To field if your version of Outlook doesn't remove it) or open the sent message and resend the message using Actions > Resend message.

    In addition, I searched for an article that mentioned that you can use macros to send messages to the original recipients.
    (Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.)

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.