Log Analytics Workspace Connection Status stuck at Connecting and Disconnecting

Daniel Gunawan 11 Reputation points
2022-11-15T21:58:44.457+00:00

Seems to be not very common issue.

As per the screenshot below, the VMs were previously showing 'Connecting' in the Portal for about 2 days before I removed MMA from the top VM to see how it would deal with that.

260639-screenshot-2022-11-16-110340.jpg

Now it is showing ;Disconnecting' and has been like that for the last 3 or so hours.

Note that logs are actually flowing through as expected, checking the installation logs in the machine themselves show that MMAs had been successfully installed, and for the top VM it is now showing it's been uninstalled.

I thought I'll ask the question here first before raising a Support ticket with Microsoft.

Unfortunately the 'Connect' or 'Disconnect' buttons at the top of this screen are greyed out when it is showing 'Connecting' or 'Disconnecting'

260548-screenshot-2022-11-16-105648.jpg

Any help will be much appreciated

Azure Monitor
Azure Monitor
An Azure service that is used to collect, analyze, and act on telemetry data from Azure and on-premises environments.
2,987 questions
{count} vote

1 answer

Sort by: Most helpful
  1. Stanislav Zhelyazkov 22,101 Reputation points MVP
    2022-11-16T09:12:26.897+00:00

    Hi,
    You will need to troubleshoot this on your own. Official guide is located here. Reasons for this could be different - agent cannot connect, you have already another agent installed and connected to another workspace, etc. What I would suggest you though to use Azure Monitor agent as Log Analytics agent will be deprecated at some point in the future.

    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    1 person found this answer helpful.