Intune Win32 App not working with user context on Win11 22H2.

Sandeep More 1 Reputation point
2022-11-30T13:18:47.647+00:00

we have some Intune win32 application created with user context that are working fine on all version of win10 and win11 22H1. we have recently upgraded few devices to Win11 22H2. It has been observed that any application deployed with user context gets failed on Win11 22H2 with error Unknown (0x87D30000)
Also we are using ServiceUI.exe in order to bring the SYSTEM Process to Interactive Mode for some packages which are deployed with system context. Such packages are also getting failed with same error code on Win11 22H2.

IntuneManagementExtension.log shows the IPExitCode -4294967295

265734-intunelog-error.png

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,880 questions
Microsoft Intune Application management
Microsoft Intune Application management
Microsoft Intune: A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.Application management: The process of creating, configuring, managing, and monitoring applications.
912 questions
0 comments No comments
{count} votes

7 answers

Sort by: Most helpful
  1. Rahul Jindal [MVP] 9,556 Reputation points MVP
    2022-11-30T22:34:56.007+00:00

    What is compliance status for the apps in question in Intune?

    0 comments No comments

  2. Crystal-MSFT 45,896 Reputation points Microsoft Vendor
    2022-12-01T01:57:22.613+00:00

    @Sandeep More , Thanks for posting in Q&A. From the log, it seems the app install result has returned with error to IME. Could you check if the app is successfully installed on the device?

    Meanwhile, you can check the application event log to see if there's any more finding. In addition, you can also test to install the application with user context manually on the Win11 22H2 device to see if it can be installed. If not, I think you need to contact app developer to make sure the app is supported on win 11 22H2.

    Please check the above information and if there's anything unclear, feel free to let us know.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  3. Rahul Jindal [MVP] 9,556 Reputation points MVP
    2022-12-01T07:38:16.913+00:00

    Intune is just a delivery tool for the payload. If the apps are installing manually, then there could be in issue with how they setup in Intune. I will suggest to check for your installer scripts, install context, requirements for Windows 11. If everything checks out then the next logical option will be to open a support case.


  4. Jeffrey 0 Reputation points
    2023-01-18T08:23:15.2833333+00:00

    Same problem here. I have a simple Win32 package to install Putty 0.78. I have installed older versions of this program succesfully so all the parameters are good. Now on my own Win11 22H2 laptop putty cannot be installed. It says that the application is not detected. (Nothing is installed, i have tried upgrades, fresh installations etc) and on the Win10 devices in our company everything is working fine. (Fresh installs of Putty, upgrades etc)

    Important note is that when i run the installer manually everything is installed succesfully. Even on Win11 22H2 devices.

    Currently the install behavior is: System.

    2023-01-18_09h29_25

    0 comments No comments

  5. DeepScout 0 Reputation points
    2023-01-20T05:56:24.4633333+00:00

    Got the same Problem here.

    It is independent with us of system or user content. The applications are not installed and get the return code you mentioned.

    Manual installation goes without problems and also on hardware-same devices with Windows 10 22H1/Windows 11 22H1 everything runs without problems.

    However, we could only observe the behavior on "New installation". Computers that have been upgraded (Win 10 -> Win 11 or Win 11 22H1 -> Win 11 22H2) do not have this problem.

    0 comments No comments