Exchange 2016: after installation of CU 18 attachments from shared mailbox can't be opened in OWA

Christoph 46 Reputation points
2020-09-30T10:31:23.44+00:00

Hi,

we installed last Thursday CU 18 on a single Exchange 2016. After that we recognized that attachment from shared mailboxes can't be opened anymore. This affects all attachments, download and preview. The problem seems to be that the URL for the attachment ist wrong. When we try to download an attchment a new windows is opened and we're redircted to a url in this format (original domain name is replaced):

"https://outlook.office365.com/owa/temp-test@domain-name.de/service.svc/s/GetAttachmentDownloadToken?redirect=%2fowa%2ftemp-test%40domain-name.de%2fservice.svc%2fs%2fGetFileAttachment%3fid%3dAAMkADVjYTJlNmVhLWU5YWUtNDExNC04YmI5LTNkNDI1NzU0YTRhZQBGAAAAAACFeKz%252b7LiwTJTGaiFKmoEUBwDgWBbEnQXzT5ipyGwAVbfZAAAAAAEMAADgWBbEnQXzT5ipyGwAVbfZAAAAAAk3AAABEgAQAHTIfMMNYkBEk%252bb%252f1UJcNZo%253d%26X-OWA-CANARY%3dji4zp9VACUGzxzvHkAjNH0AOjQZUZNgIt7lknLLRBv1JieCvW96de5oLgPWmV6rJSNOZafAG8fU.%26isDocumentPreview%3dFalse

I do not understand why this request is getting redirected to office365.com. We do not have an hybrid enviroment or anything like that. "Normal" user accounts does not have any problems. if we forward the affected e-mail from the shared mailbox to a real person, attachment can be opened. Event logs or similar do not show any related anomalies. Any ideas whats going on or how to fix this?

btw, problem exists only in OWA, the same attachment can be opened in Outlook without any problems. The problem also exists with a new shared mailbox.

kind regards Christoph

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,230 questions
{count} votes

Accepted answer
  1. David 91 Reputation points
    2020-10-14T09:57:17.057+00:00

    Hi everyone,

    Guess no one found a solution so far and we need a fix from MS?
    We have update to CU 18, same problem. But we do not have the recent updates installed from yesterday patch day.

    One workaround we discovered so far.
    Instead of "Open another mailbox..." you can access the shared mailbox with "Add shared folder..." instead.
    We run a DAG Exchange 2016 cluster on windows server 2012 R2 server.

    3 people found this answer helpful.

19 additional answers

Sort by: Most helpful
  1. Eric Yin-MSFT 4,386 Reputation points
    2020-10-09T06:55:48.53+00:00

    Hi everyone,
    The engineering team is working on the issue and fix would be release in the coming updates.
    Please wait for the next CU released then test if the issue persists.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.
    0 comments No comments

  2. Christoph 46 Reputation points
    2020-10-15T06:42:37.323+00:00

    btw, I got a nearly final anwser from the MS support that the real bugfix will be only available in the next CU.

    1 person found this answer helpful.

  3. Andy David - MVP 138.4K Reputation points MVP
    2020-09-30T12:32:10.157+00:00

    Hi @Christoph ,
    Microsoft support is aware of a similar issue and asks that you open a support ticket with them so they can track it down. So please do that to get some resolution. It's not something that can be solved here.

    Thanks!


  4. Eric Yin-MSFT 4,386 Reputation points
    2020-10-01T06:00:20.93+00:00

    It seems a bug with Exchange 2016 CU18, not heard such issues before and it's working well in my Lab(2013&2016).
    Let's see how Microsoft would explain about this.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments