vs2022 installer broken, not working

Karin Johnson 1 Reputation point
2022-12-31T15:54:16.24+00:00

About three weeks ago I downloaded and installed correctly VS2022 Community version. Worked great. Recently I tried to open VS2022 Community and all that happen was the splash screen showed for about a second then nothing. Program did not run. I completely deleted the version of VS2022 Community and tried to access the installer on the Microsoft VS web site. The installer code does download, size about 2 MB. But when clicking on the file to run, a window showing progress bar opens goes to 100 percent completion, then abruptly closes. VS2022 Community does not load or get downloaded as previously mentioned. Anyone else with this issue.

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
2,448 questions
No comments
{count} votes

8 answers

Sort by: Most helpful
  1. T. Kujala 8,421 Reputation points
    2023-01-01T05:28:30.44+00:00

    Hi @Karin Johnson ,

    You could test the following command if the program is not completely removed from your computer.

    Navigate to the following location.

    C:\Program Files (x86)\Microsoft Visual Studio\Installer and run the command: InstallCleanup.exe -full, which could help to remove the previous install cache.

    Then download the version of VS2022 here.

    No comments

  2. Karin Johnson 1 Reputation point
    2023-01-01T15:54:35.29+00:00

    The program referenced at that location does not exist on my computer. Therefore it can be run.
    Karin


  3. Anna Xiu-MSFT 11,206 Reputation points Microsoft Employee
    2023-01-02T09:38:59.803+00:00

    Hi @Karin Johnson ,

    Welcome to Microsoft Q&A!

    If you cannot find the InstallCleanup.exe, please try the following steps to uninstall your VS cleanly:

    1. Manually delete any leftover install and cache folder you previously installed to
      C:\Program Files (x86)\Microsoft Visual Studio
      %programdata%\Microsoft\visualstudio\packages
      C:\Program Files\Microsoft Visual Studio
    2. Delete the setup registry key, which was set when you first installed(Maybe there is only one key, please check one by one.):
      HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\VisualStudio\Setup
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\Setup
      HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\VisualStudio\Setup

    Then, re-download the new bootstrapper file from https://visualstudio.microsoft.com/downloads/ and run it as administrator.

    Sincerely,
    Anna
    *
    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  4. Karin Johnson 1 Reputation point
    2023-01-02T18:21:17.073+00:00

    I followed all of your instructions and deleted/removed all of the files and registry links you suggested. In addition I did a search of the C: drive and found and deleted all references to Visual Studio.
    I did restart the computer after doing all of this.
    Then went to the Visual Studio web site, downloaded the installer for Community. Same thing happens. the Installer file does download, then a progress bar window opens, goes to 100 percent then abruptly closes with no action. I did check with Task manager then, and found nothing running related to the Visual Studio installer. I give up.

    Karin

    No comments

  5. Karin Johnson 1 Reputation point
    2023-01-02T18:26:27.863+00:00

    Here is copy of the dd_bootstrapper_20230102132209.log file
    275429-dd-bootstrapper-20230102132209.log