Sharepoint 2016 Report Server Integration Feature Missing

Rui Ferreira 0 Reputation points
2023-01-18T12:35:44.3733333+00:00

I don't have the option Report Server Integration Feature available in Site Collection Features but it is activated in Central Admin in Service on Server.

The environment is a test server with just a sharepoint server 2016 and a SQL Server 2016. I have the microsft SQL Server 2016 RS Addin installed and the SQL SPRSService Application Pool is started

Any idea?

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
2,146 questions
SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,139 questions
SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,760 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Yi Lu_MSFT 17,366 Reputation points
    2023-01-19T05:25:24.1+00:00

    Hi @Rui Ferreira

    You could check whether you have run the right version of the RSSharePoint. To ensure I was repairing with the current version, I right-clicked the item right in Add/Remove Programs and selected "Repair".

    Here is a similar case for you to refer:

    [https://sharepoint.stackexchange.com/questions/242837/sharepoint-2013-sql-server-2012-report-server-integration-feature-disappeared


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Rui Ferreira 0 Reputation points
    2023-01-19T16:53:37.92+00:00

    I already solved the problem, Apparently the Application Proxies "SQL SPRSService Service Application Proxy" for that WebApplication was configured as custom. I went to check in the production environment and saw that it should be by default. I changed it and restarted the "SQL Server Reporting Services Service" in Service on Server and voilà, problem solved.

    Thanks

    0 comments No comments

  3. Yi Lu_MSFT 17,366 Reputation points
    2023-01-30T09:12:59.0566667+00:00

    Hi @Rui Ferreira

    I'm glad to hear you solve the problem ,if you have any issue about SharePoint, you are welcome to raise a ticket in this forum.

    By the way, since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others.". and according to the scenario introduced here: Answering your own questions on Microsoft Q&A, I would make a brief summary of this thread:

    Issue Symptom:
    I don't have the option Report Server Integration Feature available in Site Collection Features but it is activated in Central Admin in Service on Server.

    The environment is a test server with just a sharepoint server 2016 and a SQL Server 2016. I have the microsft SQL Server 2016 RS Addin installed and the SQL SPRSService Application Pool is started

    Current status:
    Rui Ferreira has already solved the problem, Apparently the Application Proxies "SQL SPRSService Service Application Proxy" for that WebApplication was configured as custom. He went to check in the production environment and saw that it should be by default. He changed it and restarted the "SQL Server Reporting Services Service" in Service on Server and voilà, problem solved.

    You could click the "Accept Answer" button for this summary to close this thread, and this can make it easier for other community member's to see the useful information when reading this thread. Thanks for your understanding!


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments