Visual Studio Code does not connect to my Azure account

LeonardoFucci-4004 15 Reputation points
2023-02-04T17:10:46.5+00:00

Hello.

So this problem, I have the latest Visual Studio Code version, I need to connect to Azure to publish my changes, does not really matter to what specific service. The problem is, when I try to authenticate my Azure to Visual Studio Code, it keeps doing nothing after my loging is completed.

For example, way 1:

  1. Click on azure extension
  2. Click on Sign in to Azure

User's image

  1. A web page asks for credentials, all good here, submit
  2. The following page appears:

User's image

  1. but visual studio keeps showing the 3 options from the first picture, is not loading.

Things I tried to solve my problem

  1. Azure: Sign out from the command palette. did nothing.
  2. Restart PC: sometimes it helps, sometimes it does not.
  3. Use different browsers to start the session. did nothing.
  4. Start visual studio code in admin mode. did nothing.
  5. Check the latest version. It's the latest version.

I don't know what else to do and this is slowing my work, I already spent hours trying in vain to connect and deploy.

Please help.

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,413 questions
Visual Studio Setup
Visual Studio Setup
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
937 questions
{count} votes

5 answers

Sort by: Most helpful
  1. Antonios Kokiantonis 105 Reputation points
    2023-02-06T07:08:44.35+00:00

    I found something that worked for me:

    Ctrl + Shift + P ------> Azure: Sign in with device code

    It will then proceed with a device authentication.

    Worked fine for me!

    I hope it helps

    15 people found this answer helpful.

  2. Kaskosz, Thomas 35 Reputation points
    2023-10-11T12:06:44.1+00:00

    I've had the same issue today and the solution was to change the authentication library in the settings of the "Azure Account" extension from ADAL (deprecated) to MSAL

    7 people found this answer helpful.
    0 comments No comments

  3. Manu Philip 16,901 Reputation points MVP
    2023-02-04T17:49:01.3466667+00:00

    Try the following steps and see if resolves the issue.

    Open Azure Account Extension settings

    User's image

    Add the tenant id at the bottom of the pageimage

    Sign Again

    User's image

    Hope, it solves the issue !


    --please don't forget to upvote and Accept as answer if the reply is helpful--

    6 people found this answer helpful.

  4. Antonios Kokiantonis 105 Reputation points
    2023-02-06T07:21:36.2666667+00:00

    I accidently wrote the same answer for a second time, but I can not delete for a reason.

    1 person found this answer helpful.
    0 comments No comments

  5. Tianyu Sun-MSFT 24,896 Reputation points Microsoft Vendor
    2023-02-08T08:34:11.99+00:00

    Hi there,

    Thank you for taking time to post this issue in Microsoft Q&A forum.

    Since Visual Studio Code is currently not supported in Microsoft Q&A forum, the supported products are listed over here: https://docs.microsoft.com/en-us/answers/products/. You can post this question here: Stack Overflow tagged Visual Studio Code (see this doc: Technical Support for details).

    Besides, perhaps the issue is also related to Azure/account/sign-in, I also suggest you add Azure related tags for better help.

    Thanks for your understanding, have a nice day.

    Sincerely,

    Tianyu


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments