Azure AD Join is failing with CAAA2000C

Trevor Hopkins 0 Reputation points
2023-03-01T09:40:31.7933333+00:00

I have a problem joining my Windows 10 laptop to my AAD domain. AAD Domain join results in an "oops something went wrong - error caaa2000c. AAD audit logs show the device as being successfully registered, immediately followed by successfully unregistered. I am a Global Admin.

The device was originally Hybrid-Joined although AD has now been decommissioned. I have removed the device from both Intune and Azure AD but this has not resolved the problem. The Device was originally registered for AutoPilot but I have also removed this registration to try and resolve this issue. I have also turned off MFA temporarily on my user account as the local device logs indicate a "user interaction required" issue.

Have ran the enrollment troubleshooter tool and this reports everything is in order for a Domain Join to happen. I've also tried dsregcmd /leave force and dsregcmd /join force, which hasn't worked either.

I don;t know what else to do - I have googled the hell of this issue and tried everything I have come across!

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
19,440 questions
{count} votes

2 answers

Sort by: Most helpful
  1. JimmySalian-2011 41,916 Reputation points
    2023-03-02T20:09:30.92+00:00

    Hi,

    Do you get any error codes?0x8xxx something? Can you export the logs from the Windows 10 device and upload here or onedrive from the device - User Device Registration. logs in the event logs.


  2. Givary-MSFT 27,796 Reputation points Microsoft Employee
    2023-03-03T10:28:10.6833333+00:00

    @Trevor Hopkins I'm glad that you were able to resolve your issue and thank you for posting your solution so that others experiencing the same thing can easily reference this! Since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others ", I'll repost your solution in case you'd like to "Accept " the answer.

    User's image

    0 comments No comments