Can Send As a different alias address in OWA, but can't in Outlook using Managed list?

Brad Wooder 0 Reputation points

I am trying to send as a secondary smtp/alias, because we have different domains in use.

O365, Hosted.

When i send a mail with OWA the alias works perfectly. When i send from outlook desktop client i can choose my alias and it looks like its working but the sender is than overwritten by the primary smtp.

I tried 3 different outlook client versions but it wont work.

As an example from outlook application - default SMTP - sends as expected - alias address - when sending, delivery address comes through as - new alias - when sending, delivery address comes through as

As an example from outlook web / OWA - default SMTP - sends as expected - alias address - sends as expected - new alias - sends as expected

Microsoft 365
Microsoft 365
Formerly Office 365, is a line of subscription services offered by Microsoft which adds to and includes the Microsoft Office product line.
3,699 questions
A family of Microsoft email and calendar products.
2,883 questions
Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
4,854 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Vasil Michev 94,131 Reputation points MVP

    Make sure you're typing in the email alias in the From > Other e-mail address box, do not select any stored/autocomplete entry. I'm using an Outlook build that's on the semi-annual channel, and it works fine there.

    Another thing to have in mind is that Outlook will resolve the recipient address on the received message against any existing contacts, and doesn't always indicate the alias used. The best way to confirm the address used is to check the From header of the message.

    0 comments No comments

  2. Faery Fu-MSFT 16,236 Reputation points Microsoft Vendor

    Hi @Brad Wooder ,

    Try to clear the autocomplete list: Clear the AutoComplete list Or Start Outlook by using the command: Select Start, and then select Run. Type Outlook.exe /CleanAutoCompleteCache.

    Check this link: and test if it works. (Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.)

  3. Paolo Miotti 5 Reputation points

    Hi @Brad Wooder ,

    Did you setting on the EXO mail flow settings sending from aliases?

    User's image

    Hope I was Help you

    My regards


    0 comments No comments