MECM Software Updates not working on task sequences or newly imaged PC

Rouleau, Mark C 5 Reputation points
2023-03-01T14:54:21.8033333+00:00

We recently restored our site server and WSUS to a newer server. Everything is working peachy-keen except for the Software Update step in our TS, which seems to hang. It used to work fine with our Win10 22H2 image. Nothing else has changed as far as I can tell. In addition, newly imaged PCs don't seem to be getting updates. Existing PCs seem to be getting

WUAHandler.log looks fine, confirmed that the imaged computer can connect to port 8530 on the site server. ScanAgent, UpdatesStore and UpdatesHandler as well.

I am seeing this error reoccurring in UpdatesDeployment.log:

Failed to attach update to the automation wrapper, error = 0x87d00215

Anyone run into this?

I should mention, other devices on the network are getting updates, site components are all green status.

The task sequence execution engine failed executing the action (Install Software Updates) in the group (Install Software) with the error code 2147943860

Action output: ... refer to logs: UpdatesDeployment.log, UpdatesHandler.log, UpdatesStore.log, wuahandler.log, WindowsUpdate.log

Waiting for RefreshUpdates complete notification from Updates Deployment Agent

FALSE, HRESULT=800705b4 (C:__w\1\s\src\client\OsDeployment\InstallSWUpdate\installswupdate.cpp,1522)

WaitForRefreshUpdatesComplete(spInstall), HRESULT=800705b4 (C:__w\1\s\src\client\OsDeployment\InstallSWUpdate\installswupdate.cpp,1677)

RefreshUpdates(bForceOnlineScan), HRESULT=800705b4 (C:__w\1\s\src\client\OsDeployment\InstallSWUpdate\installswupdate.cpp,1157)

InstallUpdates(pInstallUpdate, tType, sIdStr, sCallerStr, sJobID, sActiveRequestHandle), HRESULT=800705b4 (C:__w\1\s\src\client\OsDeployment\InstallSWUpdate\main.cpp,308)

Setting TSEnv variable SMSTSInstallUpdateJobGUID=

Process(pInstallUpdate, tType, sIdStr, sCallerStr, sPendingRebootUpdateIDs), HRESULT=800705b4 (C:__w\1\s\src\client\OsDeployment\InstallSWUpdate\main.cpp,409)

Time-out expired waiting for updates refresh complete notification.. The operating system reported error 2147943860: This operation returned because the timeout period expired.

Microsoft Configuration Manager
0 comments No comments
{count} votes

6 answers

Sort by: Most helpful
  1. Rouleau, Mark C 5 Reputation points
    2023-03-10T17:57:08.13+00:00
      1. 2207
    1. Alas, we had completely forgotten about the SCUP on the old server. It hadn't been used in several years but we never uninstalled it.
    2. No software updates are installed during the task sequence.
    3. Required for Installation from cached mode.

    I recently completely removed the SUP role from the server and am re-adding it, as well as redownloading and redistributing the updates. I believe based on limited testing that this will fix our issues. Will mark as solved if it does.

    Removing the SUP role and re-adding, then redownloading and redistributing fixed the issue.

    1 person found this answer helpful.
    0 comments No comments

  2. Duchemin, Dominique 2,006 Reputation points
    2023-03-01T19:05:56.47+00:00

    Hello,

    For 0x87wd00215

    https://learn.microsoft.com/en-us/archive/blogs/george_bethanis/cm12-sp1-clients-are-not-able-to-download-software-updates-error-setjobtimeoutoptions-failed-error-0x87d00215-updateshandler

    For 800705b4

    I have the same issue now and it seems to be related to the Network... still investigating ... firewall (Network & Local), access, ...

    Thanks,

    Dom


  3. CherryZhang-MSFT 6,481 Reputation points
    2023-03-02T08:39:09.8866667+00:00

    Hi @Rouleau, Mark C

    1, Whether the newer server is using the same FQDN and IP as the older server?

    2, Please help resync the update on SCCM console to see if it is successful? Please try to recreate the task sequence to test if it is successful?

    3, Please help upload the full logs of the following logs for our reference:

    Smsts.log, UpdatesDeployment.log, UpdatesHandler.log, UpdatesStore.log, wuahandler.log, WindowsUpdate.log

    Looking forward to your reply.

    Best regards,
    Cherry


  4. Rouleau, Mark C 5 Reputation points
    2023-03-02T16:33:18.1666667+00:00

    I created a new VM with a stripped down version of our regular task sequence. See attached logs.

    smsts.log

    UpdatesDeployment.log

    UpdatesDeployment-20230302-104905.log

    UpdatesHandler.log

    UpdatesHandler-20230302-104855.log

    UpdatesStore.log

    WUAHandler.log

    The Windows Update log was too large to upload. I'll see if I can shrink it or copy/paste it into a new entry.


  5. Rouleau, Mark C 5 Reputation points
    2023-03-03T23:29:32.0133333+00:00

    I might have solved it. It looks like an issue with the Network Access Account. After I deleted and re-added it, I was able to apply a test update to my task sequence. I will be able to confirm for sure next week.