Security warning when opening document with URI Schema ms-word

shp 0 Reputation points
2023-03-03T10:41:41.2133333+00:00

Hello,

In a web application, documents are opened using the ms-word protocol. The files are located on a local network drive and opened with a url of the following form:

<a href="ms-word:file://server/path/document.docx">Edit document</a> 

This has worked fine for quite some time, but after a recent Office update a prompt is shown with the following message: "Some files contain viruses that can be harmful to your computer. It is important to be certain that this file is from a trustworthy source. Do you want to open this file?"

The address in the security prompt is: "file:///\\server\path\document.docx".

Is there any way to avoid this security prompt?

Adding the folder as a Trusted Location does not have any effect. Adding the network drive to the local intranet in Internet Options does not solve the issue either.

Office Development
Office Development
Office: A suite of Microsoft productivity software that supports common business tasks, including word processing, email, presentations, and data management and analysis.Development: The process of researching, productizing, and refining new or existing technologies.
3,439 questions
Word Management
Word Management
Word: A family of Microsoft word processing software products for creating web, email, and print documents.Management: The act or process of organizing, handling, directing or controlling something.
890 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Emi Zhang-MSFT 21,391 Reputation points Microsoft Vendor
    2023-03-06T06:44:10.74+00:00

    Hi,

    I suggest you try this method to disable the display of security warnings for a specific protocol, follow these steps:

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate the following registry subkey: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\xx.0\Common\Security\Trusted Protocols\All Applications Note In this subkey, replace "xx.0" with 12.0 for Office 2007, 14.0 for Office 2010, 15.0 for Office 2013, and 16.0 for Office 2016 and later.
    3. Click the All Applications subkey.
    4. On the Edit menu, point to New, and then click Key.
    5. Type the name of the protocol that you want to exclude. For example, to disable the display of a security warning for the "Notes:" protocol, type Notes:. Note Make sure that you include the colon (:) character.
    6. Press Enter.
    7. Exit Registry Editor.

    Read this article about "Enable or disable hyperlink warning messages in Office programs" to get more information:

    https://learn.microsoft.com/en-us/microsoft-365/troubleshoot/administration/enable-disable-hyperlink-warning

    Just checking in to see if the information was helpful. Please let us know if you would like further assistance.


    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.