Iscsi not working after cluster made

George Lee 0 Reputation points

Hello, I have a slight issue with my Iscsi disks at the moment. So basically I have two nodes. The first node has all the physical disks and runs the target server. The over node purely just connects to those disk and I used that to create the failover cluster. Now that the cluster has been made all the iscsi initiators are just showing as Reconnecting and it can't.

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,315 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Limitless Technology 44,016 Reputation points


    Thank you for your question and reaching out. I can understand you are having query\issues related to iSCSI.

    There can be some connection issues , Please verify Gateway and DNS ips on both Servers and also Please try to reboot iSCSI target server.

    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments

  2. Alex Bykovskyi 1,821 Reputation points


    Did you run cluster validation? It might disconnect and connect iSCSI target. You can also restart iSCSI Target Server.

    Alternatively, disconnect your targets in iSCSI initiator and connect them again.

    If you use node for both iSCSI storage and compute, it will be a single point of failure. In case this node fails, entire cluster will go down. You will need shared storage to make 2 nodes redundant. You can use Storage Space Direct as a shared storage.

    As another option, StarWind VSAN can be used. It will create replicated storage pool between 2 nodes, which can be used to create Failover Cluster. Might help:

    Alex Bykovskyi 
    StarWind Software 
    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    0 comments No comments