question

JoeHinkle-7763 avatar image
0 Votes"
JoeHinkle-7763 asked kovicMartin-0277 published

Exchange 2016 / Outlook 2016 Mailbox Size Is Wrong

Note that we went through a full system loss in May and had to rebuild a failed 2010 installation as 2016 and import old user mailboxes in as .pst files.

I have users who are showing an odd issue. The total mailbox size in there Outlook is wrong but on the server it's correct. I've gone through the below items and do not see any issues yet. Has anyone seen this before?

  1. Exchange OWA has the correct info

  2. Outlook does not have the correct info. Both the total size of the mailbox and space used are wrong.

  3. The client is warning people that their mailbox is filling up even though the server still has the correct information.

  4. The feature that shows you space used locally disappears when you turn off Exchange Cached Mode. It might be related to caching?

  5. Building a new user profile in Outlook did not fix the issue.

  6. Deleting the .ost file and restarting Outlook makes it so the total size disappears.

  7. My account has this issue. I completely rebuilt my account from scratch in AD and Exchange after the rebuild in Exchange 2016.

Before the move to 2016 user mailboxes sizes were configured at the mailbox. I configured the sizes on the DB and set all users to use the DB settings. Is it possible some of the user accounts are trying to retain old settings?

office-exchange-server-administrationoffice-outlook-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JoeHinkle-7763 avatar image
0 Votes"
JoeHinkle-7763 answered EricYin-MSFT commented

I found the source of my problem and it has to do with the settings that Outlook receives for Quota's. If Outlook doesn't receive a setting for all options then it will disable displaying quota's in both the file menu and at the status bar at the bottom of Outlook.

The solution was to make sure that all the DB Quota defaults had a numerical value. The field for disable send/recieve was configured as unlimiited. I tested by setting the value on just my account, after it worked I set it up on the DB defaults. It took just over an hour for the settings to show up on Outlook clients. I tried a fresh account, an account with the wrong info, and an account with a rebuilt .ost file. All of them received their correct mailbox size after the back end of Exchange updated.

To verify settings on my DB I ran a powershell cmd. You can also view settings from the Servers section of the admin console. Below shows all the fields I should of received on the client but I found through testing that the Unlimited option was what the client didn't like. If there's a way to view what settings the client received I did not find it.

Get-MailboxDatabase | select identity,IssueWarningQuota,ProhibitSendReceiveQuota,ProhibitSendQuota,DeletedItemRetention

Identity : AdministrationDB
IssueWarningQuota : 2.5 GB (2,684,354,560 bytes)
ProhibitSendReceiveQuota : 4 GB (4,294,967,296 bytes)
ProhibitSendQuota : 3 GB (3,221,225,472 bytes)
DeletedItemRetention : 21.00:00:00

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Glad you have solved the issue, it's suggested to mark the solution as answer, which could highlight it and make it easy for those users having same issue to see it. Thanks in advance.

1 Vote 1 ·
kovicMartin-0277 avatar image
0 Votes"
kovicMartin-0277 answered kovicMartin-0277 published

Helped me too, Exchange 2019 environment

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.