Error with Azure STT (Speech to Text) - Internal server error

1234 30 Reputation points
2023-03-29T15:30:55.3466667+00:00

Hello everyone,

I am new to Azure Speech to Text (STT) and I am facing an issue while trying to test my model. Every time I try to test it, I get the following error message:

Internal server error. Please recreate the task in a while. If the failure still happens, please create an Azure support request.

I am not sure what is causing this error, and I have not been able to find any relevant information online. I am hoping that someone in the community might be able to provide some guidance or assistance.

Here is some information about my setup:

  • I am using Azure Speech to Text service for speech recognition.
  • I have created a custom model using plain text.
  • I am using the "Test Models" to test the model.
  • I am using audio files in WAV format to test.

I have tried recreating the task multiple times, but the error persists. I am not sure if there is an issue with my setup or if there is a problem with the Azure STT service itself.

If anyone has any experience with Azure STT or has faced a similar issue, I would greatly appreciate any help or guidance that you can provide.

Thank you in advance for your help!

Azure AI Speech
Azure AI Speech
An Azure service that integrates speech processing into apps and services.
1,431 questions
Azure
Azure
A cloud computing platform and infrastructure for building, deploying and managing applications and services through a worldwide network of Microsoft-managed datacenters.
990 questions
0 comments No comments
{count} votes

Accepted answer
  1. VasaviLankipalle-MSFT 14,831 Reputation points
    2023-03-29T21:03:25.77+00:00

    Hi @1234 , Thanks for using Microsoft Q&A Platform.

    I have tried to repro it on my end. I was able to successfully test the custom model in speech studio. Assuming you have followed the same document steps: https://learn.microsoft.com/en-us/azure/cognitive-services/speech-service/how-to-custom-speech-evaluate-data?pivots=speech-studio#create-a-test

    Generally, to check the Azure status page to see if there are any known issues with the Speech to Text service. You can access the status page at https://status.azure.com/en-us/status and under service health in Azure portal https://app.azure.com/h/BK1G-F80/609f27.

    In your case, there might be any issue with size of the training input or any other reasons.
    I would suggest you check and make sure that the plain text training file does not exceed 200MB.

    If the issue still persists, better you raise a support ticket.

    For a deeper investigation and assistance on this issue, if you have a support plan you may file a support ticket, else could you please send an email to azcommunity@microsoft.com with the below details, so that we can create a one-time-free support ticket for you to work closely on this matter.

    Subject: Attn: Vasavi
    Subscription ID:
    Thread URL: Link to this thread.

    I hope this helps. Let me know if you have any questions.

    Regards,
    Vasavi

    -Please kindly accept the answer and vote 'Yes if you feel helpful to support the community, thanks.

    0 comments No comments

0 additional answers

Sort by: Most helpful