Error in applying azzure CLI

Gerallt Skym 0 Reputation points
2023-04-10T07:21:01.4866667+00:00

When running the script for "creating a VM" I get an error? E: Unable to locate package nginx tee: /var/www/html/index.html: No such file or directory Please advise how I fix this?

Azure Training
Azure Training
Azure: A cloud computing platform and infrastructure for building, deploying and managing applications and services through a worldwide network of Microsoft-managed datacenters.Training: Instruction to develop new skills.
1,020 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Rohit Kumar Sinha 1,321 Reputation points
    2023-04-10T11:07:06.0533333+00:00

    HI Geralt , This has an external dependency which fails in rare cases. Resetting the VM is the most reliable way to resolve this. Please try and see if this works for you. If the above is useful please click Accept Answer.

    2 people found this answer helpful.

  2. kobulloc-MSFT 23,981 Reputation points Microsoft Employee
    2023-04-10T19:40:25.0433333+00:00

    Hello, @Gerallt Skym ! Where are you seeing this issue?

    Why am I running into an error when running the custom nginx script? In rare cases, this external dependency will result in an error. Edit: I was able to reproduce this recently and the suggestion from @Rohit Kumar Sinha is what I would recommend. Ultimately I deleted the VM and started over which was a quick workaround after hitting this several times. https://learn.microsoft.com/en-us/answers/questions/1084468/cannot-provision-nginx-in-sandbox-vm-based-on-the

    1 person found this answer helpful.
    0 comments No comments