Microsoft Store is stuck in old version 11910.1002.5.0 and won't update no matter what...

Alex CARRAUSSE 15 Reputation points
2023-04-16T03:54:55.4833333+00:00

We just reimaged some machines to 22H2 and for some reason the Microsoft Store is stuck in an old version 11910.1002.5.0 and won't update no matter what... On my machine it is up to date version 22301.1401.15.0 so 11910.1002.5.0 is pretty ancient... I tried all the tutorials that I could found online but no luck, it won't update. https://learn.microsoft.com/en-us/answers/questions/995651/ms-store-app-update-issue https://www.groovypost.com/howto/fix-a-stuck-app-download-in-microsoft-store/ https://support.microsoft.com/en-us/account-billing/fix-problems-with-apps-from-microsoft-store-93ed0bcf-9c12-3df6-6dda-92ec5d0415ac https://answers.microsoft.com/en-us/windows/forum/all/windows-store-stuck-updating/158811c2-23ec-4dc5-a912-ebef2d5da5cf I even tried these 2 commands but it will reinstall the old version! PS C:\WINDOWS\system32> get-appxpackage WindowsStore | remove-appxpackage PS C:\WINDOWS\system32> Get-AppXPackage WindowsStore -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} I tried wsreset, troubleshooter, rebuilding cache.... Any ideas where we should look at? Is it some GPO settings blocking something? Some registry? Need help, Thanks,

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,845 questions
Microsoft Configuration Manager Updates
Microsoft Configuration Manager Updates
Microsoft Configuration Manager: An integrated solution for for managing large groups of personal computers and servers.Updates: Broadly released fixes addressing specific issue(s) or related bug(s). Updates may also include new or modified features (i.e. changing default behavior).
985 questions
{count} votes

5 answers

Sort by: Most helpful
  1. HoeGang Noh 20 Reputation points
    2023-11-12T12:58:43.53+00:00

    hello everyone. I will be time savior for all of you.

    method: Xbox app needs Microsoft Store service to full application function. So the app provide way install newer version of Microsoft Store!

    1. Remove old version of Microsoft Store.
    1. install Xbox application: you can't download from Microsoft Store because its deleted. So use 'official' website. If you alreay have this app, you don't have to reinstall.
    1. Run Xbox App and install newer version of Microsoft Store.caninstall
    4 people found this answer helpful.

  2. Alex CARRAUSSE 15 Reputation points
    2023-04-16T04:00:48.4566667+00:00

    ScScreenshot_38

    1 person found this answer helpful.
    0 comments No comments

  3. Pavel yannara Mirochnitchenko 12,221 Reputation points MVP
    2023-04-17T09:21:14.4166667+00:00

    Do you have any limitations done with AD GPO, what could prevent updating modern apps? How about other modern apps, are they getting updates? GPO have some settings available which can prevent this to work.

    Other test scenario would be to uninstall CM client, test without it. And also you could heal your OS installations by executing sfc / scannow command.

    0 comments No comments

  4. Daniel Santos 0 Reputation points
    2023-06-17T03:10:41.0633333+00:00

    I managed to resolve the following error, it was being caused by an application, I went there and disable it, then I restart the PC, and went to update the microsoft store :)

    0 comments No comments

  5. Dorian Cooling 0 Reputation points
    2023-06-17T03:16:56.78+00:00

    I solved it using a method I read elsewhere. You have to uninstall the Microsoft Store altogether and then install the Xbox app. The Xbox app requires the Store to function and there's an option to download the newest version within the app.

    0 comments No comments