proxyAddresses duplication broke Azure Sync

Malcolm R 0 Reputation points
2023-05-03T06:01:08.02+00:00

my junior tech, added duplicate proxyAddress fields into two seperate distribution list groups, which were synced to azure, and in doing so, attempted changes and any future changes to AD, although the synchronisation service manager, has no issues claiming it has sent the changes to Azure, the changes have not changed within Azure.

Due to being a basic education azure subscription, we are unable to receive support, which we used to have access to. preventing rectification the issue.

All logs of the synchronisation service manager, indicate that it has sent the changes to Azure. but they have not reflected correctly within Azure.

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
22,111 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Akshay-MSFT 17,871 Reputation points Microsoft Employee
    2023-05-10T08:57:02.2166667+00:00

    @Malcolm R

    Since you were not able to respond to above shared request, I am sharing a known Proxy address conflict with you which you could try next time you face the issue.

    When you try to assign a proxy address to a new or existing mail recipient in Exchange Online, you receive an error message that resembles one of the following examples.

    Error 1

    The proxy address "SMTP:<conflicting SMTP address>" is already being used by "<domain>.prod.outlook.com/Microsoft Exchange Hosted Organizations/contoso.onmicrosoft.com/<forest>". Choose another proxy address.
    

    Error 2

    An Azure Active Directory call was made to keep object in sync between Azure Active Directory and Exchange Online. However, it failed. Detailed error message: Another object with the same value for property proxyAddresses already exists. ConflictingObject: PublicFolder_<GUID>.
    

    Examples of a mail recipient include a mail user, user mailbox, shared mailbox, distribution group, Microsoft 365 Group, and mail-enabled public folder (MEPF).

    Cause

    Cause 1

    The first error message occurs if a mail-enabled object in Exchange Online uses the proxy address that you want to assign.

    Cause 2

    The second error message occurs if an MEPF object that exists only in Azure Active Directory (Azure AD) uses the proxy address that you want to assign.

    Resolution

    The resolution for the first error is to check for and remove any conflicting proxy address in Exchange Online.

    The resolution for the second error is to check for and remove any conflicting proxy address in Exchange Online and to check for and remove any conflicting proxy address in Azure AD.

    Use the appropriate resolution, depending on the error message that you receive. Then, try to assign the proxy address again.

    The resolution for the first error is to check for and remove any conflicting proxy address in Exchange Online.

    The resolution for the second error is to check for and remove any conflicting proxy address in Exchange Online and to check for and remove any conflicting proxy address in Azure AD.

    Use the appropriate resolution, depending on the error message that you receive. Then, try to assign the proxy address again.

    Check for and remove any conflicting proxy address in Exchange Online

    Check for and remove any conflicting proxy address in Azure AD

    Please do let me know if you have any further queries in the comments section.

    Thanks,

    Akshay Kaushik

    Please "Accept the answer" (Yes), and share your feedback if the suggestion answers you’re your query. This will help us and others in the community as well.

    0 comments No comments

Your answer

Answers can be marked as Accepted Answers by the question author, which helps users to know the answer solved the author's problem.