Since you were not able to respond to above shared request, I am sharing a known Proxy address conflict with you which you could try next time you face the issue.
When you try to assign a proxy address to a new or existing mail recipient in Exchange Online, you receive an error message that resembles one of the following examples.
Error 1
The proxy address "SMTP:<conflicting SMTP address>" is already being used by "<domain>.prod.outlook.com/Microsoft Exchange Hosted Organizations/contoso.onmicrosoft.com/<forest>". Choose another proxy address.
Error 2
An Azure Active Directory call was made to keep object in sync between Azure Active Directory and Exchange Online. However, it failed. Detailed error message: Another object with the same value for property proxyAddresses already exists. ConflictingObject: PublicFolder_<GUID>.
Examples of a mail recipient include a mail user, user mailbox, shared mailbox, distribution group, Microsoft 365 Group, and mail-enabled public folder (MEPF).
Cause
Cause 1
The first error message occurs if a mail-enabled object in Exchange Online uses the proxy address that you want to assign.
Cause 2
The second error message occurs if an MEPF object that exists only in Azure Active Directory (Azure AD) uses the proxy address that you want to assign.
Resolution
The resolution for the first error is to check for and remove any conflicting proxy address in Exchange Online.
The resolution for the second error is to check for and remove any conflicting proxy address in Exchange Online and to check for and remove any conflicting proxy address in Azure AD.
Use the appropriate resolution, depending on the error message that you receive. Then, try to assign the proxy address again.
The resolution for the first error is to check for and remove any conflicting proxy address in Exchange Online.
The resolution for the second error is to check for and remove any conflicting proxy address in Exchange Online and to check for and remove any conflicting proxy address in Azure AD.
Use the appropriate resolution, depending on the error message that you receive. Then, try to assign the proxy address again.
Check for and remove any conflicting proxy address in Exchange Online
Check for and remove any conflicting proxy address in Azure AD
Please do let me know if you have any further queries in the comments section.
Thanks,
Akshay Kaushik
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