SCCM - Surface drivers do not show up in "All Software Updates"

Sokoban 996 Reputation points
2023-05-24T19:59:14.98+00:00

Hi

My problem is surface drivers do not show in "All Software Updates"

I have done following:

  • Enable in classification.

User's image

  • Enable in Client Settings , Software Updates

User's image

Something I have missed ?

Microsoft Configuration Manager Updates
Microsoft Configuration Manager Updates
Microsoft Configuration Manager: An integrated solution for for managing large groups of personal computers and servers.Updates: Broadly released fixes addressing specific issue(s) or related bug(s). Updates may also include new or modified features (i.e. changing default behavior).
1,005 questions
Microsoft Configuration Manager
0 comments No comments
{count} votes

Accepted answer
  1. CherryZhang-MSFT 6,486 Reputation points
    2023-05-30T06:34:55.01+00:00

    Hi @Sokoban ,

    Thanks for your feedback. We're glad that the question is fixed now. It's appreciated that you could click "Accept Answer" to the helpful reply, this will help other users to search for useful information more quickly. Here's a short summary for the problem.

    Problem/Symptom:

    SCCM - Surface drivers do not show up in "All Software Updates".

    Solution/Workaround:

    On the WSUS server, navigate to %SystemRoot%\system32\inetsrv. Create a new and emtpy w3wp.exe.config and add the below lines:

    <configuration>

    <runtime>

    <AppContextSwitchOverrides value="Switch.System.Net.DontEnableSystemDefaultTlsVersions=false"/>

    </runtime>

    </configuration>

    Finally, restart IIS and wait for synchronization.

    Thanks again for your time! Have a nice day!

    Best regards,

    Cherry

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. CherryZhang-MSFT 6,486 Reputation points
    2023-05-25T02:23:23.81+00:00

    Hi @Sokoban

    1, Please make sure that your environment meets the following prerequisites:

    • An internet connected top-level software update point.
    • All software update points must run Windows Server 2016 with cumulative update KB4025339 or later installed.
    • In version 2006 and earlier, Configuration Manager doesn't enable this optional feature by default.

    2, Please help make sure that you have checked the related products in Software Update Point Component Properties\Products window.

    The related products, please refer to this link:

    Managing Surface driver updates - Configuration Manager | Microsoft Learn

    3, To verifying the configuration, please help check WsyncMgr.log and WCM.log. The details about these logs, please refer this link:

    Manage Surface driver updates in Configuration Manager - Surface | Microsoft Learn

    Looking forward to your feedback.

    Best regards

    Cherry


     

    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Sokoban 996 Reputation points
    2023-05-30T05:22:52.4233333+00:00

    Solve that :-)

    Solved :-)
    
    Goto %SystemRoot%\system32\inetsrv create w3wp.exe.config add that:
    
     <configuration>
       <runtime>     <AppContextSwitchOverrides value="Switch.System.Net.DontEnableSystemDefaultTlsVersions=false"/>
       </runtime>
     </configuration> 
    
    Restart IIS and wait
    
    0 comments No comments