Enterprise Keyword not showing for non admin users

Bikram Pal 60 Reputation points
2023-07-10T18:53:12.67+00:00

I am facing a silly situation, as a non site collection admin (but i have full control access over sharepoint 2019 site), when i update the Enterprise Keyword field and click save, it doesn't show the value of Enterprise Keyword column in the document library all documents view. When i login as a farm administrator i am able to see the Enterprise Keyword for all the documents.

checking the version history when Login as Farm Administrator i can see Enterprise Keyword entered "test items".

Limage 1

On Checking the version history, when Login as Full Control user i cannot see Enterprise Keyword entered.

image2

please let me know how can i fix it.. all the end users are in farm are having this issue.

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
2,147 questions
SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,153 questions
{count} votes

Accepted answer
  1. Ling Zhou_MSFT 11,625 Reputation points Microsoft Vendor
    2023-07-12T07:53:35.81+00:00

    Hi @Bikram Pal,

    I am really glad to know that the problem has been solved. I appreciate you sharing the solution and I have learned a lot from it!

    By the way, since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others." And according to the scenario introduced here: Answering your own questions on Microsoft Q&A, I would make a brief summary of this thread:

    [Enterprise Keyword not showing for non admin users]

    Issue Symptom:
    Enterprise keywords are not visible in the version history for users other than the farm Administration.

    Current status:
    If you start at a blank site template and then retro fit MMD, then the permissions on the hidden taxonomy list being used to hold the enterprise key will not apply to all users, giving them read access.

    You can go to http://yoursiteURL/lists/TaxonomyHiddenList to check the permissions. If necessary, grant read to All Authenticated Users.

    Reference: https://sharepoint.stackexchange.com/questions/68724/users-cannot-read-enterprise-keywords

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link. 


    You could click the "Accept Answer" button for this summary to close this thread. By doing so, it will benefit all community members who are having this similar issue. Your contribution is highly appreciated!


2 additional answers

Sort by: Most helpful
  1. Ling Zhou_MSFT 11,625 Reputation points Microsoft Vendor
    2023-07-11T05:23:29.71+00:00

    Hi @Bikram Pal,

    Thank you for posting in this community.

    I tested your question on my side. Users with full access on my side are able to view the Enterprise Keyword.

    User's image

    User's image

    It seems that your question is not a common one. Since we can't reproduce your situation, we need to narrow down the problem and try some things.

    1. Except for the administrator of the farm, is the owner of the site or any other user with read privilege level and above invisible to the Enterprise Keyword? Please try users with other permission levels to see if they have the same problem.
    2. Please try a different site and see if the problem exists.
    3. Please try a different browser, use the browser privacy mode to access the web, and then see if the problem persists.
    4. Try a different computer and see if the problem persists.

    Your time and cooperation is much valued by us. If there is any other assistance I can provide, please feel free to let me know.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Bikram Pal 60 Reputation points
    2023-07-11T14:20:57.2366667+00:00

    the issue was resolved by using this link.

    https://sharepoint.stackexchange.com/questions/68724/users-cannot-read-enterprise-keywords

    There is a hidden taxonomy list at site collection level which is populated with terms as they are used. The default is for all users to have read access on this list. However, if you start with something like a blank site template and then retro fit MMD then it seems this permission does not always get applied.

    Navigate to the hidden list at /lists/TaxonomyHiddenList and check the permissions. If necessary grant read to All Authenticated Users.

    0 comments No comments