O365 Sender alias being stripped from emails

TPMR 25 Reputation points
2023-07-19T07:49:33.8+00:00

Hi,

We have a local SMTP relay setup to enable various on-site devices (printers etc.) to send emails.
The relay is setup to use a "service" mailbox (noreply[at]company[dot]com) that has various aliasses and send-as permissions assigned to it. (To identify the various on-site devices. printer1[at]company[dot]com, etc.)
We also set O365 to allow sending as aliasses.

When receiving an email the "From" header would contain the alias but outlook (desktop and owa) would display the service mailbox's name. (This seems to be as designed.)
We could then modify mail rules to check the header value vs. the sender value.
Since last night (probably around 0:00 GMT) the "From" header however no longer contains the used alias (nor can it be found in any other header) and thus all mail rules for these aliassed addresses no longer work.

Has the processing of sent by alias been changed or is there another/a new setting that needs to be set?

Additionally, though I'm not sure if it's connected, when looking at these "relayed"/"aliassed" emails in a mail trace, they'll show up twice in the mail trace.
1 line will show "Delivered" and a second row will show "GettingStatus".

Kind regards,
TPMR

Microsoft Exchange Online
0 comments No comments
{count} votes

Accepted answer
  1. Aholic Liang-MSFT 13,731 Reputation points Microsoft Vendor
    2023-07-25T05:48:58.31+00:00

    Hi @ TPMR,

    I'm glad to hear that the issue had solved and thanks for sharing.

    Since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others.". and according to the scenario introduced here: Answering your own questions on Microsoft Q&A, I would make a brief summary of this thread:

     

    [O365 Sender alias being stripped from emails]

     

    Issue Symptom:

    We have a local SMTP relay setup to enable various on-site devices (printers etc.) to send emails.

    Mail flow rules are applied based on the headers of received messages. Around 0:00  GMT, suddenly the mail flow rule is not running, and the check header no longer contains the alias used.

    The Solution:

    No processing, the issue has resolved itself. Expect a temporary issue with the operation of the O365 backend server.


    You could click the "Accept Answer" button for this summary to close this thread, and this can make it easier for other community member's to see the useful information when reading this thread. Thanks!


2 additional answers

Sort by: Most helpful
  1. Gary Chrisman 0 Reputation points
    2023-07-19T19:37:11.19+00:00

    I have the same question

    0 comments No comments

  2. Aholic Liang-MSFT 13,731 Reputation points Microsoft Vendor
    2023-07-20T09:23:40.6466667+00:00

    Hi @ TPMR,

    Have you tried sending mail via send as? Is there still a problem with the resulting header?

    If possible, could you provide the previous and current "From" header formats for us to better research.

     

    In addition, if you have not modified any settings, you can check   whether there are related issues with the current tenant through service health in the M365 admin center.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.