Logic App Standard InApp FTP connector ServiceProviderTriggerStateTooLarge error

Tadas 5 Reputation points

Using InApp FTP connector with Logic App Standard. Workflow is triggered using "When a file is added or updated". Trigger fails with the following information:




Outputs link
No outputs

App insights shows the following information:

{"code":"ServiceProviderTriggerStateTooLarge","message":"The size of the trigger state returned by the service provider with trigger name 'When_a_file_is_added_or_updated' has length '22478' characters which exceeds the maximum limit of '10240' characters. Please contact the service provider to get this fixed."}

Does it mean that FTP connector output is too large (since output link is empty)?

How to fix non working workflow?

I've tried workflow with mine FTP and it worked fine, but it doesn't with our customers FTP.

Azure Logic Apps
Azure Logic Apps
An Azure service that automates the access and use of data across clouds without writing code.
2,829 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Tadas 5 Reputation points

    @MayankBargali-MSFT no need and seems like I figured it out. Looks like I have to override value for


    in app settings but not


    as you've suggested. Overriding in host.json took no effect, but ServiceProviders.MaximumAllowedTriggerStateSizeInKB looks promising and not getting errors now.

    Furthermore an error was about 10240 limit so it's 10KB. Where the default limit for Microsoft.Azure.Workflows.ServiceProviders.MaximumAllowedTriggerStateSizeInKB is 1KB and limit for ServiceProviders.MaximumAllowedTriggerStateSizeInKB is 10KB

    1 person found this answer helpful.
    0 comments No comments

  2. MayankBargali-MSFT 68,391 Reputation points

    @Tadas Thanks for reaching out. It looks like you haven't updated the Microsoft.Azure.Workflows.ServiceProviders.MaximumAllowedTriggerStateSizeInKB configuration in your standard logic app. Can you try to set this value to a higher value as per your file size and see if it helps to you to resolve the issue?

    In case if you set it to some other values and see the same error with max limit of 'xx' characters then you need to further tweak the value.

    Important: Based on your storage size, avoid setting this value too high, which can adversely affect storage and performance.

    In case the above doesn't help then please let me know.


    Correct setting is ServiceProviders.MaximumAllowedTriggerStateSizeInKB