Visio 2021 Standard, Win 10 Freezes Up

Alan O 5 Reputation points
2023-09-12T18:51:25.21+00:00

Visio 2021 Standard, Win10 Freezes up on Zoom. This first started with Visio 2013 so I upgraded to 2021 hoping it would fix the problem. It still freezes when zooming in or out. Sometimes for a few seconds; sometimes much longer or completely – requiring Task Manager to shut it down. Below is my system information and the steps I've tried. Any help would be appreciated.

Visio 2021 Standard, Version 2308 (Build 16731.20234 Click-to-Run) 32-bit

 

Operating System:

Windows 10 Pro

Version 22H2

OS Build: 19045.3448

Experience: Windows Feature Experience Pack 1000.19044.1000.0

 

Graphics Cards:  (2)

NVIDIA Quadro 600

Driver Version: 21.21.13.7783

Diver Date: 1-13-2018

 

CPU:

Intel(R) Core(TM) i7-3930K CPU @ 3.20GHz   3.20 GHz

 

Installed RAM:

64GB

 

System Type: 64-bit operating system, x64-based processor

 

 

Steps tried:

1.      Updated everything in Windows Update, including “optional” updates and the latest NVIDIA drivers from the NVIDA site.

2.      Ran Office 365 Quick Repair and Online Repair.

3.      Deleted “ConfigContextData” in registry editor at location: HKEY_CURRENT_USER \ SOFTWARE \ Microsoft \ Office \ 16.0 \ Common \ ExperimentConfigs \ Ecs \ visio \ ConfigContextData  multiple times before and after other steps.  “Disable hardware graphics acceleration” option does not exist, regardless of this step and in safe mode or not.

4.      Running Viso in safe mode:  many times before and after the various other steps.

5.      Tried with and without the “Disable Enhanced Metafile optimizations” being checked.  With checked being the default.

6.      Disabled the NVIDIA 600 Quadro 600 graphics acceleration by:

1.      Turning “Threaded Optimization” off in the NVIDIA Control Panel.

2.      Adding “DisableHWAcceleration”, value data 1, base Hexadecimal to registry at:

“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers”

(I’ve reversed these two things now.)

Visio
Visio
A family of Microsoft products used to create diagrams and vector graphics.
76 questions
0 comments No comments
{count} vote

1 answer

Sort by: Most helpful
  1. AllenXu-MSFT 15,836 Reputation points Microsoft Vendor
    2023-09-13T06:38:56.86+00:00

    Hi @Alan O,

    Please try the following steps to make the "Disable hardware graphics acceleration" option appear.

    1. Exit all Microsoft Office programs.
    2. Open Registry Editor.
    3. Locate and select the registry key.

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\ExperimentConfigs\Ecs\visio

    1. Select File > Export, type a file name for the backup copy of the key, and then click Save.
    2. Make sure that the key that you just exported is selected, and then click Delete on the Edit menu. When you are prompted to respond to the following messages, click Yes:

     "Are you sure you want to delete this key and all of its subkeys?"

    1. Exit Registry Editor.

    Then go to File>Options>Advanced>Display, check "Disable hardware graphics acceleration".


    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.