Diagnostic settings not sending metrics for Email Communication Services

Albert Avetisian 0 Reputation points Microsoft Employee
2023-10-05T01:22:02.5+00:00

I set up diagnostic settings to send to my Log Analytics Workspace, but no metrics are showing up. Feels like something might be misconfigured because the domain / mail address isn't even showing up. Note, emails are being sent just fine. I can also see the METRICS, as in, just a count of the API being hit. But none of these deeper insights.

User's image

Azure Communication Services
Azure Communication Services
An Azure communication platform for deploying applications across devices and platforms.
704 questions
{count} votes

1 answer

Sort by: Most helpful
  1. SnehaAgrawal-MSFT 18,541 Reputation points
    2023-10-06T08:17:35.1333333+00:00

    @Albert Avetisian Thanks for asking question! It seems you want to use diagnostic setting email send service, Could you please confirm you have enabled the diagnostic setting from Monitoring menu and added destination and Save.

    Please refer to this doc link- https://learn.microsoft.com/en-us/azure/communication-services/concepts/analytics/enable-logging#access-diagnostic-settings

    Also, for viewing the logs it seems you are using Workspace, you can see logs from Logs menu under Monitoring- and by using default query pack for email send request summary or any.

    see- https://learn.microsoft.com/en-us/azure/communication-services/concepts/analytics/query-call-logs

    For your reference added screen shot with steps to be followed, Let us know if issue remains.

    User's image

    User's image

    User's image

    User's image

    User's image

    0 comments No comments